OPNsense Forum

International Forums => German - Deutsch => Topic started by: NicholasRush on October 07, 2017, 11:48:48 pm

Title: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on October 07, 2017, 11:48:48 pm
Hallo zusammen,

in diesem Thread soll es nur darum gehen, eure probleme mit dem Siproxd Plugin zu lösen und etwaige Lösungen für euch bereitzustellen. Ich werde dazu diesen Anfangspost immer um Lösungen im Zusammenhang mit eurer Hardware  ergänzen. Sodass niemand lange suchen muss und soll, damit die Probleme schnell gelöst sind.  :)

VOIP-Providerspezifische Einstellungen:

Bilderanleitungen: Dropbox (https://www.dropbox.com/sh/o5px7n1aww42tl6/AAA2rdF4Gul6NEc8dZmLQDhia?dl=0)

Die Transparenten Proxy Einstellungen für Siproxd sind nun in der Bilderanleitung enthalten.
Die IP Adresse in der Port Forwarding Regel ist die eures LAN Interfaces der OPNsense alternativ könnt ihr auch den Localhost "127.0.0.1" nehmen.



Title: <-- Reserviert für Lösungen -->
Post by: NicholasRush on October 07, 2017, 11:57:06 pm
Telepark Passau: VOIP Probleme mit Lösung (https://forum.opnsense.org/index.php?topic=7483.0)
Telekom-VoIP mit Fritzbox 7490 hinter opnSense (https://forum.opnsense.org/index.php?topic=7663.0)

Selfmade OPNsense Appliance (vom OPNsense User: Imrazor) Themen: Hardware, Software, VOIP (https://www.imrazor.de/howto/selfmade-opnsense-appliance/)
Ein sehr umfangreich geschriebener Artikel, zu den Themen Hard- und Software sowie der Grundkonfiguration von VOIP.

Bei falschem Rufnummernformat in Verbindung mit der FritzBox und der Telekom bitte folgenden Beitrag beachten: Link (https://forum.opnsense.org/index.php?topic=6112.msg46487)

Gehört zwar normalerweise nicht hierher:
Anleitung: AVM Fritz!Box als Einwahlrouter IPv6 Prefix Delegation mit OPNsense (https://forum.opnsense.org/index.php?topic=7528.msg34249#msg34249)
Title: Re: [Siproxd Support] Problem- und Lösungsthread
Post by: eugenmayer on December 07, 2017, 12:09:45 am
Ich wollte mich bei dir herzlich bedanken. Ich habe das mit deiner Hilfe und dem Plugin perfekt hinbekommen.
Möchtest du das HowTo von dir vielleicht hier als Ergebnis posten?

Kurze Setup-Info von mir:
- Telekom VDSL ( Symmetric NAT )
- Vigor 130 VDSL mit PPPO Passthrough
- OPNsense 17.x (als VM auf Proxmox) auf einem HP Gen8
- Sipproxy Plugin installiert: outbound domain + STUN konfiguriert - alles standard ansonsten
- WAN ports UDP 5060 und UDP 7070 - 7079 geöffnet
- Gigaset C610IP (outbound proxy konfiguriert)
- Sip Phone ( OSX Telephone ) (outbound proxy konfiguriert)

ich benutze nun gleichzeitig das VOIP der Telekom und von Sipgate - läuft klasse. Danke!

Und
Title: Re: [Siproxd Support] Problem- und Lösungsthread
Post by: NicholasRush on December 07, 2017, 01:09:13 am
Ich wollte mich bei dir herzlich bedanken. Ich habe das mit deiner Hilfe und dem Plugin perfekt hinbekommen.
Möchtest du das HowTo von dir vielleicht hier als Ergebnis posten?

Kurze Setup-Info von mir:
- Telekom VDSL ( Symmetric NAT )
- Vigor 130 VDSL mit PPPO Passthrough
- OPNsense 17.x (als VM auf Proxmox) auf einem HP Gen8
- Sipproxy Plugin installiert: outbound domain + STUN konfiguriert - alles standard ansonsten
- WAN ports UDP 5060 und UDP 7070 - 7079 geöffnet
- Gigaset C610IP (outbound proxy konfiguriert)
- Sip Phone ( OSX Telephone ) (outbound proxy konfiguriert)

ich benutze nun gleichzeitig das VOIP der Telekom und von Sipgate - läuft klasse. Danke!

Und

Hallo eugenmayer,

freut mich sehr das mein "HowTo" geklappt hat und du zufrieden mit dem Ergebnis bist. Ich schreibe derzeit an einem etwas größeren Handbuch dazu, welches ich innerhalb nächsten Jahres veröffentlichen möchte. Ich werde deinen Lösungsweg dazu hier ebenfalls reinstellen. Auch wenn ich weiß das ein solches Mini-"HowTo" nicht für jedermann geeignet sein wird, insbesondere dann nicht, wenn man versucht diese Beispiel Konfiguration auf ein anderes Endgerät zu übertragen und den Wald vor lauter Bäumen nicht mehr sieht. Was dann unweigerlich wieder zu Problemen und Frustration führt. Das soll dieses HowTo-Handbuch dann versuchen zu lösen.

Beste Grüsse
NR

--

Hier das Mini-HowTo welches ich auf das neue oben von dir genannte Szenario etwas angepasst habe.

--

Wie viele VOIP Clients (Telefone), ob Hard- oder Software vorhanden sind, ist erstmal egal. Achtung die Telekom macht Symetric RTP. Andere Anbieter betrifft dieser Umstand natürlich nicht.

Der Normalfall sieht jetzt so aus, dass in der OPNsense Firewall die RTP- und SIP Ports, die auf das WAN Interface von OPNsense zeigen, geöffnet werden müssen. Das sind die Port Ranges die im Siproxd Plugin eingestellt sind. Also UDP 5060 und UDP 7070 - 7079 in den Standardeinstellungen.

Im Siproxd Plugin sollte in der Sektion "Stun" also weiter unten im Dialog ein STUN Server eingetragen werden.

In den VOIP Clients braucht jetzt nur noch als Outbound Proxy die OPNsense Box eingetragen werden (LAN Interface IP). Und die Telefone sollten sich dann beim jeweiligen Anbieter anmelden. In deinem Fall dann Sipgate/Telekom.

Achtung: Wenn in den Firewallregeln des LAN Interfaces der Zugriff auf OPNsense aus dem LAN beschränkt ist, müssen natürlich dort ebenfalls UDP 5060 und UDP 7070 - 7079 freigegeben werden.

Die VOIP Clients brauchen sich so nicht mehr um NAT Traversal zu kümmern, das macht dann Siproxd. Ebenso das Audio RTP Routing. Und da ist es dann egal ob Symetrisch oder Asymetrisch.

=> Weiterführende Providerspezifische Einstellungen (https://forum.opnsense.org/index.php?topic=6112.msg25603#msg25603)
Title: Re: [Siproxd Support] Problem- und Lösungsthread
Post by: itnetz24 on February 25, 2018, 04:33:56 pm
Hallo,

hatt jemand es schon mit Placetel am laufen?

Wenn ja würden mich die einstellungen interessieren.
Title: Re: [Siproxd Support] Problem- und Lösungsthread
Post by: NicholasRush on February 26, 2018, 02:48:14 am
Hallo,

hatt jemand es schon mit Placetel am laufen?

Wenn ja würden mich die einstellungen interessieren.

Die Einstellungen sind ähnlich wie im Post vor deinem beschrieben. Nur das in deinem falle Siproxd dann besser Transparent laufen sollte. Das machst du, indem du eine Portweiterleitung von deinem "LAN"-Interface auf IP: 127.0.0.1 Protokoll: UDP Port: 5060 erstellst. Da du bei einer Cloud Telefonanlage ohnehin mehrere Endgeräte hast, solltest du den RTP Port Bereich ruhig von 7000 - 7999 nutzen. Denn meistens ist in IP-Telefonanlagen Standard, dass du mindestens 2 Leitungen/ Telefon hast.

Ich habe leider keinen Zugriff auf eine Placetel Cloud TK-Anlage, daher kann ich dir momentan noch nicht mit einer exakten Konfiguration von Siproxd dienen, allerdings kann ich dir anbieten mit dir zusammen eine zu erarbeiten, die dann hier im Forum veröffentlicht wird.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Nephiria on April 17, 2018, 12:02:52 pm
Hallo zusammen,

Seit gestern versuche ich auf meiner OpnSense 18.1.6 VOIP einzurichten.
Leider nur mit mässig Erfolg.

Ich habe eine Basisstation TPG600 von Panasonic und ein entsprechendes Handteil dazu.
Mein Anbieter ist die "Quickline" darüber wird über die MAC Addresse der Basisstation die VOIP Geräte Konfiguriert und sollten eigentlich wenn die richtigen Ports etc. eingestellt werden erreichbar sein.

Leider blickt das gerät in einem hübschen Orange dauerhaft.
Es soll eigentlich auch laut dem Anbieter auf der Firewall "SIP ALG Deaktiviert werden" leider finde ich diese Funktion in OpnSense nicht.

Falls ich hier falsch bin an der stelle bitte ich das zu entschuldigen.
Nachdem ich den Artikel mir durchgelesen habe soll das Plugin für alle VOIP Anbieter sein oder muss für meinen Anbieter speziell was beachten?

Danke für das Feedback.

Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 17, 2018, 10:17:23 pm
Hallo zusammen,

Seit gestern versuche ich auf meiner OpnSense 18.1.6 VOIP einzurichten.
Leider nur mit mässig Erfolg.

Ich habe eine Basisstation TPG600 von Panasonic und ein entsprechendes Handteil dazu.
Mein Anbieter ist die "Quickline" darüber wird über die MAC Addresse der Basisstation die VOIP Geräte Konfiguriert und sollten eigentlich wenn die richtigen Ports etc. eingestellt werden erreichbar sein.

Leider blickt das gerät in einem hübschen Orange dauerhaft.
Es soll eigentlich auch laut dem Anbieter auf der Firewall "SIP ALG Deaktiviert werden" leider finde ich diese Funktion in OpnSense nicht.

Falls ich hier falsch bin an der stelle bitte ich das zu entschuldigen.
Nachdem ich den Artikel mir durchgelesen habe soll das Plugin für alle VOIP Anbieter sein oder muss für meinen Anbieter speziell was beachten?

Danke für das Feedback.

"SIP-ALG" wirst du in der OPNsense auch so niemals finden. Voll ausgeschrieben bedeutet SIP-ALG, SIP-Application Layer Gateway. Siproxd, wäre so ein "Application Layer Gateway", wenn du diesen nicht benutzt, oder installierst brauchst du den auch nicht auszuschalten.  ;)

Dein Anbieter Quickline  (https://www.quickline.ch/), ist der hinter dem Link oder? Ich müsste nur noch ein paar Infos mehr haben.  Die TPG600 von Panasonic sollte eine Konfigurationsurl (HTTP, TR069 etc.) im Webinterface eingetragen haben, darüber holt die sich dann die Konfiguration. Wenn die Station vorkonfiguriert war, einfach mal alle Ports für die Panasonic Station ausgehend offen lassen. Evtl. tut sich dann etwas. Ich kann dir zu der Station auch nicht mehr sagen, denn ich habe weder eine solche, noch komme ich da an Handbücher von Panasonic dran.

Zu deinem Anbieter: Ich weiß natürlich auch nicht ob die ein Separates VLAN für Telefonie bereitstellen, evtl. funktioniert die Autokonfiguration auch nur darüber?? Das müsstest du allerdings selber herausfinden.

Ich hoffe ich konnte dir helfen.

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Nephiria on April 23, 2018, 12:43:48 pm
Hallo @NicholasRush,

danke für deine Antwort habe es mittlerweile gelöst.
Es lag nicht an der Einstellung der Firewall (opnsense) sondern vielmehr war es ein Zusammenspiel zwischen dem Portal der Quickline (vPBX) und der Telefone daheim.

Danke für deine Unterstützung.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on May 02, 2018, 01:01:11 pm
Hi Nicholas .. ich hab daheim jetzt auch ne OPNsense und hab hier meine ersten Probleme mit VoIP.
Hab DSL von DTAG, aber ich verwende VoIP nur zur Asterisk von der Firma! Dazu wurde meine public IP von der DTAG an der Firewall in der Firma frei geschalten. Mit einem Zyxel 5501 als Router ging das problemlos. Wenn ich mit OPNsense tausche, outbound NAT auf static und reverse NAT auf mein Telefon mache kann mich die Gegenstelle hören, ich aber niemanden.

Im tcpdump sehe ich die Pakete vom LAN Richtung Telefon kommend und gehend, das passt also.

Hab dann das siproxd Plugin installiert und alles gemacht wie eugenmeyer, wenn man mich anruft alles super, wenn ich jemanden anrufe höre weder ich noch die Gegenstelle etwas.

Was sagt dein Mastermind dazu? Verkloppen wir alle den siproxd plugin maintainer???  :P
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on May 03, 2018, 01:53:48 am
Hi Nicholas .. ich hab daheim jetzt auch ne OPNsense und hab hier meine ersten Probleme mit VoIP.
Hab DSL von DTAG, aber ich verwende VoIP nur zur Asterisk von der Firma! Dazu wurde meine public IP von der DTAG an der Firewall in der Firma frei geschalten. Mit einem Zyxel 5501 als Router ging das problemlos. Wenn ich mit OPNsense tausche, outbound NAT auf static und reverse NAT auf mein Telefon mache kann mich die Gegenstelle hören, ich aber niemanden.

Im tcpdump sehe ich die Pakete vom LAN Richtung Telefon kommend und gehend, das passt also.

Hab dann das siproxd Plugin installiert und alles gemacht wie eugenmeyer, wenn man mich anruft alles super, wenn ich jemanden anrufe höre weder ich noch die Gegenstelle etwas.

Was sagt dein Mastermind dazu? Verkloppen wir alle den siproxd plugin maintainer???  :P

Hört sich witzig an die Geschichte.  ;D
Mal eine Frage, hast du auch die RTP Ports von Siproxd freigeschaltet?

Denn wenn du ausgehend ein Gespräch führst, wird der Port ja von selber offen gehalten, wenn du angerufen wirst, passiert das dann evtl. nicht. Wenn dein Telefon ohne Siproxd nicht funktioniert, musst du bei dem evtl. ein STUN Server eintragen. Dazu kannst du auch einfach den von der TELKO nehmen: stun.t-online.de.

Bei Siproxd brauchst du das ja wiederum nicht, da Siproxd die WAN IP Adresse ja kennt.

Wichtig ist, das mit und ohne Siproxd, es zwei völlig verschiedene Konfig Optionen sind. Die sehr verwirrend sein können. Ansonsten konfiguriere SIProxd mal nach dem Bsp: Bilderanleitung für Telekom (https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0)

Bei deinem Telefon brauchst du dann auch keinen STUN Server eintragen. Und im "Outbound-Domains" Tab trägst du die SIP Domain deiner Firma ein.
Zumindest weiß ich anhand deiner Fehlerbeschreibung, dass dein Firmen Asterisk kein Symetric RTP macht.  ;)
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on May 03, 2018, 07:06:50 am
Es kommt noch besser. Ich hab daheim ein Snom 760, aktuellste Firmware. Wie gesagt, mit Zyxel alles super. Inbound hab ich die komplette IP der TK freigeschaltet, von daher sind da die Ports vom RTP mit dabei.

Aber jetzt kommts, am Handy mit Zoiper Client geht es sofort. Und sobald es einmal mit dem Zoiper geklappt hat geht es auch mit dem Snom, aber nur bis ich die Firewall neu starte, dann wieder nicht mehr.

Ekiga Softphone am Notebook geht auch sofort.

Im tcpdump seh ich bei den Clients wo es geht das sie das noch machen:

15:44:03.472369 IP 192.168.2.127.39385 > X.X.X.X.5060: SIP: REGISTER sip:X.X.X.X SIP/2.0
15:44:03.487090 IP 192.168.2.127.39385 > 192.168.2.1.5060: SIP: SUBSCRIBE sip:asterisk@X.X.X.X:5060 SIP/2.0
15:44:03.487281 IP X.X.X.X.5060 > 192.168.2.127.39385: SIP: SIP/2.0 200 OK
15:44:03.501506 IP X.X.X.X.5060 > 192.168.2.127.39385: SIP: SIP/2.0 200 OK

Das Snom schickt keinen Subscribe. Hab dazu nicht viel gefunden, nur das mit Version 8.2.7 das unnütze Subscript vom Snom entfernt wurde :P

Ich trag heut im Snom mal die Daten von meinem Telekomanschluss ein, mal schauen was raus kommt.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on May 03, 2018, 11:14:58 am
Also es muss was im Zusammenspiel Snom und Asterisk sein. Hab auf dem Snom mal meine Telekom VoIP Daten hinterlegt und in siproxd rein. Jetzt geht Snom zu Asterisk ständig (auch nach Reboots), anscheinend merkt der sich irgendwas von der offenen Verbindung zum DTAG VoIP.

Auf jeden Fall kein OPNsense spezifisches Problem, da bin ich schon mal froh :D

Danke dir!

P.S.: Weisst du wie gut siproxd skaliert? Ich hab nen Kunden mit 40-80 DTAG CloudPBX Clients im Netz, momentan nur dummes NAT am Ciscorouter. Schafft das der kleine siproxd?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on May 03, 2018, 11:05:25 pm
Also es muss was im Zusammenspiel Snom und Asterisk sein. Hab auf dem Snom mal meine Telekom VoIP Daten hinterlegt und in siproxd rein. Jetzt geht Snom zu Asterisk ständig (auch nach Reboots), anscheinend merkt der sich irgendwas von der offenen Verbindung zum DTAG VoIP.

Auf jeden Fall kein OPNsense spezifisches Problem, da bin ich schon mal froh :D

Danke dir!

P.S.: Weisst du wie gut siproxd skaliert? Ich hab nen Kunden mit 40-80 DTAG CloudPBX Clients im Netz, momentan nur dummes NAT am Ciscorouter. Schafft das der kleine siproxd?

Siproxd skaliert bei mehreren Clients hervorragend, insofern genug Cores und Taktfrequenz vorhanden sind.
Die Taktfrequenz steht in direktem Zusammenhang mit der Latenz, die Cores eher mit den möglichen parallelen RTP Verbindungen. Auch wenn nichts umcodiert wird und auch nichts umcodiert werden kann (Unterstützt der Siproxd nämlich nicht), braucht der RTP Proxy nämlich entsprechend CPU Ressourcen.

Wenn du 80 DTAG Cloud PBX Clients hast, musst du mal im groben sehr großzügig überschlagen. Im Extremfall sage ich mal, werden rund 60 Gespräche gleichzeitig (Intern & Extern) geführt. Dann solltest du als Routerplatform schon einen Xeon E3-1241v3 als Hauptprozessor nehmen. Dazu eine Intel I340 4 Port NIC. So kann zumindest jeder Port einen eigenen Core zur Interruptabladung bekommen. Damit sollte es auch möglich sein 80 Gespräche und das Paketrouting mit 1-3 ms Latenz auch auf Layer 7 durchzubekommen. Natürlich könnte je nach Einsatzgebiet mein Vorschlag auch völlig überdimensioniert sein. Aber so musst du bei größeren Anforderungen auch nicht mehr aufrüsten. Bei einer CloudPBX kann die Internetleitung und der Router nicht Überdimensioniert genug sein.  ;)

Zu SNOM kann ich dir allerdings nicht weiterhelfen, da ich leider kein einziges Snom Telefon habe. Bei Yealink sieht das schon anders aus. Aber bei den Snom hieß es damals, das die mit Spannungsschwankungen nicht so gut klar kommen und eben einige Problemchen haben auf die du wohl gerade gestoßen bist, daher habe ich da direkt einen Bogen rum gemacht.


Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: akironet on June 04, 2018, 11:25:51 am
Hallo Zusammen, ich melde mich aus Wien mit einem Problem mit der richtigen Konfiguration von siproxd:
 wir nutzen einen Kabelinternetzugang von UPC (250/20) sowie seit kurzem den VOIP-Provider Sipit / Sipnal in Wien, mit einer virtuellen PBX bei Sipnal sowie 3 VOIP-Anschlüssen hinter einer OPNSense (18.1.9).
Die 3 Telefone haben fixe IP-Adressen, ich schaffe es 1 Gerät ohne Siproxd erfolgreich laufen zu lassen, alle 3 klappt nicht da ich nicht die gleichen ports an 3 verschiedene IP-Adressen weiterleiten kann - hier wurde mir siproxd als Alternative empfohlen.
Der Provider verwendet in unserem Setup keinen Stunserver, alle 3 Geräte registrieren sich direkt am sipserver des Providers und benutzen den Outbound Proxy des Providers.

Was mir nicht klar ist: wie bekomme ich die 3 Geräte an siproxd zum laufen: ein Variante wäre wohl als Outbound-Proxy siproxd zu verwenden, aber wo trage ich die RTP-Ranges in siproxd richtig ein?
Der Provider verendet wohl Serverseitig die Portrange 8000-9000 das übersetzt dann an den Geräten zu der Range 5004-5204 (ist so erfolgreich bei dem ersten Anschluss als Weiterleitung eingetragen).
Mir fehlt da leider grundlegendes Knowhow wie ich siproxd richtig konfiguriere.
Ohne das Plugin habe ich an den beiden anderen Anschlüssen das Problem dass bei eingehenden Anrufen der Anrufer nicht gehört wird.
Kann  mich da jemand in die richtige Richtung leiten bitte?
Vielen Dank schon mal!
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on June 04, 2018, 12:51:47 pm
Als Portrange im Plugin die Range vom Provider rein und diese an der Firewall freischalten. Ports zwischen Tel und Plugin sind egal. Als Outbound Proxy am Tel die interne IP der Firewall. Wenn deine IP public ist brauchst du weder am Tel noch Plugin Stun.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on June 05, 2018, 02:24:51 am
Hallo Zusammen, ich melde mich aus Wien mit einem Problem mit der richtigen Konfiguration von siproxd:
 wir nutzen einen Kabelinternetzugang von UPC (250/20) sowie seit kurzem den VOIP-Provider Sipit / Sipnal in Wien, mit einer virtuellen PBX bei Sipnal sowie 3 VOIP-Anschlüssen hinter einer OPNSense (18.1.9).
Die 3 Telefone haben fixe IP-Adressen, ich schaffe es 1 Gerät ohne Siproxd erfolgreich laufen zu lassen, alle 3 klappt nicht da ich nicht die gleichen ports an 3 verschiedene IP-Adressen weiterleiten kann - hier wurde mir siproxd als Alternative empfohlen.
Der Provider verwendet in unserem Setup keinen Stunserver, alle 3 Geräte registrieren sich direkt am sipserver des Providers und benutzen den Outbound Proxy des Providers.

Was mir nicht klar ist: wie bekomme ich die 3 Geräte an siproxd zum laufen: ein Variante wäre wohl als Outbound-Proxy siproxd zu verwenden, aber wo trage ich die RTP-Ranges in siproxd richtig ein?
Der Provider verendet wohl Serverseitig die Portrange 8000-9000 das übersetzt dann an den Geräten zu der Range 5004-5204 (ist so erfolgreich bei dem ersten Anschluss als Weiterleitung eingetragen).
Mir fehlt da leider grundlegendes Knowhow wie ich siproxd richtig konfiguriere.
Ohne das Plugin habe ich an den beiden anderen Anschlüssen das Problem dass bei eingehenden Anrufen der Anrufer nicht gehört wird.
Kann  mich da jemand in die richtige Richtung leiten bitte?
Vielen Dank schon mal!

Hallo akironet,

bitte benutze zur Konfiguration diese Bilderanleitung: Anleitung Telekom (https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0)

Du konfigurierst deine OPNsense genau so ähnlich. Bis auf den Telekom Outboundproxy. Und die RTP Port Range setzt du auf eine Portweite von 1000 Ports. RTP Port Low 7000, und RTP Port High auf 8000. Natürlich musst du dann die Port Range auch in den Firewall Freigaben genauso auch anpassen. Ganz im Gegensatz zu dem Hinweis von @mimugmail brauchst du allerdings nicht die gleiche RTP Port Range wie dein Provider benutzen, da die jeweiligen zu Benutzenden Ports beim Verbindungsaufbau über SIP mitgeteilt werden. Richtig ist allerdings, das sofern du eine echte Öffentliche IPv4 Adresse bekommen hast, du kein Stun Plugin im Siproxd eintragen brauchst. Deine Telefone kannst du im Prinzip so konfiguriert lassen wie sie sind. Den Outbound Proxy von deinem Provider, trägst du zusätzlich in dem Outbound Proxy Tab von Siproxd ein. Die Konfiguration wie in der Bilderanleitung hat den Vorteil, dass du keinen Outbound Proxy in deinen SIP Telefonen eintragen musst, Siproxd hängt in diesem Fall transparent dazwischen und verändert den SIP Header jedesmal so, das alles über Siproxd geroutet wird.

Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: akironet on June 08, 2018, 02:18:48 pm
Hallo mimugmail, Hallo NicholasRush, danke für Eure Antworten. Ich habe gestern Abend / heute früh mal einen Versuch gestartet wie von NicholasRush empfohlen nach der Bildanleitung Telekom, war auf Anhieb so leider nicht erfolgreich.
Ich musste aber bald wieder abbrechen, da das Büro voll besetzt war und alle Telefonieren wollten. Ich werde am kommenden Montag Abend nochmal ein wenig testen.

Nur um sicherzugehen: bei der NAT-Umleitung laut Bild1 trage ich die interne IP-Adresse der OPNSense ein, auf der siproxd läuft, oder?
Und bei Outbound Domains im Plugin kann ich den Namen frei vergeben, bei Host habe die IP-Adresse des Proxys eingetragen, wie er auch bei den Telefonen eingetragen ist. Alles andere wurde von mir 1:1 übernommen, die RTP-Ports allerdings im Bereich 7000-8000.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on June 09, 2018, 01:13:33 am
Nur um sicherzugehen: bei der NAT-Umleitung laut Bild1 trage ich die interne IP-Adresse der OPNSense ein, auf der siproxd läuft, oder?
Genau im Bild "NAT_REDR_RULE_Siproxd_Transparent.PNG" trägst du die Interne LAN Adresse von OPNsense ein. Solltest du mehrere VLANs für Intervlan Routing haben und möchtest nicht für jedes VLAN diese Regel erstellen, kannst du auch einfach "127.0.0.1" dort eintragen. Der Vollständigkeit halber, habe ich im Bild allerdings die LAN Adresse genommen.

Und bei Outbound Domains im Plugin kann ich den Namen frei vergeben, bei Host habe die IP-Adresse des Proxys eingetragen, wie er auch bei den Telefonen eingetragen ist. Alles andere wurde von mir 1:1 übernommen, die RTP-Ports allerdings im Bereich 7000-8000.

Im Bild "Sirpoxd_3_Outbound_Domains.PNG", also im Outbound Tab, kannst du den Namen nicht frei vergeben, wie ich sehe ist mir da wohl auch ein Fehler im Bild unterlaufen. Den ich natürlich sofort korrigieren werde. Aber erst einmal zu deiner Frage zurück. Du kannst in der Liste mehrere Provider Proxys angeben wenn du mehrere Provider nutzt oder dein Provider mehrere Proxys zur Verfügung stellt. Der richtige Proxy wird dann anhand des Namens ausgewählt und der ganze SIP Datenverkehr an diesen gesendet.

Beispielsweise werden die im Outbound Tab hinterlegten Proxys so in die Konfigurationsdatei geschrieben:
Code: [Select]
outbound_domain_name = tel.t-online.de
outbound_domain_host = tel.t-online.de
outbound_domain_port = 5060

outbound_domain_name = 1und1.de
outbound_domain_host = sip.1und1.de
outbound_domain_port = 5060


Der Name ist der sogenannte "Realm" und der Host der SIP-Proxy des Providers. Der Port erklärt sich hier ja von selbst. Da ich die Bilder auf die schnelle mal angefertigt habe ist mir dieser Fehler gar nicht aufgefallen, daher Danke für die Nachfrage.
So kann der Siproxd Dienst dann den Sip-Proxy dem Provider Realm zuordnen und das funktioniert dann auch so mit mehreren Providern, ich selbst habe da T-Online und so Sipgate drüber laufen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: MAGIC on July 27, 2018, 08:40:07 pm
Hallo,

Bin nun auf eine OPNSense zuhause umgestiegen, da ich diese schon auf meinen Servern laufen habe. Davor lief eine pfSense zuhause (APU)
Habe die Regeln 1:1 eingestellt, aber wenn ich via normales Telefon auf meinem PC anrufe, klingelt mein Phonerlite, doch ich kann nur die Sounds vom Telefon hören, aber das Telefon nicht die Sounds von Phonerlite...

Grob ist mein Netzwerk so aufgebaut:
ISP (Telekom) -> Fritzbox -> OPNSense -> Desktop
                                |                                       |
                      normales Telefon                Phonerlite



Hier nochmal detailiert:
Code: [Select]
WAN / Internet
             :
             : ISP (Telekom)
             :
       .-----+-----.                  .------------------.
       |  Fritzbox  +-----------------+ normales Telefon |
       '-----+-----'                  '------------------'
             |
LAN Fritzbox | 192.168.178.1
WAN OPNSense | 192.168.178.254
             |
       .-----+------.
       |  OPNSense
       '-----+------'
             |
         LAN | 10.88.0.0/24
             |
       .-----+------.       IP         .------------.
       | Desktop PC  +-----------------+ Phonerlite |
       '-----+------'    10.88.0.1     '------------'

Grüße
MAGIC
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on July 27, 2018, 10:43:53 pm
Dann musst du eine Regel einfügen auf dem Tab wo die Fritzbox ist mit Source Fritzbox und Destination dein Telefon
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: MAGIC on July 27, 2018, 11:27:23 pm
Habe ich
(https://m.mufff.in/18d.png)

Sogar ein Outbound NAT habe ich erstellt:
(https://m.mufff.in/41e.png)
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on July 28, 2018, 01:12:54 am
Und geblockte Pakete gibt's nicht?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on July 28, 2018, 02:21:50 am
Das Problem ist in dem Fall NAT zwischen FritzBox und Phonerlite. Damit das funktioniert musst du Static NAT bei der OPNsense für den Phoner Client einstellen, mit den Ports die in Phoner festgelegt sind. Denn diese müssen eben statisch auf die Adresse des "WAN"-Interfaces gemappt werden. Oder du benutzt Siproxd  ;), dann musst du das alles nicht.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: MAGIC on July 28, 2018, 10:40:22 am
Und geblockte Pakete gibt's nicht?
Nein, die Liveview gibt keine roten Zeilen aus.

Das Problem ist in dem Fall NAT zwischen FritzBox und Phonerlite. Damit das funktioniert musst du Static NAT bei der OPNsense für den Phoner Client einstellen, mit den Ports die in Phoner festgelegt sind. Denn diese müssen eben statisch auf die Adresse des "WAN"-Interfaces gemappt werden.
Habe ich doch eigentlich gemacht oder?


Oder du benutzt Siproxd  ;), dann musst du das alles nicht.
Wie wird der dann eingerichtet?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on July 28, 2018, 12:04:10 pm

Habe ich doch eigentlich gemacht oder?


Oder du benutzt Siproxd  ;), dann musst du das alles nicht.
Wie wird der dann eingerichtet?

Wie er eingerichtet wird findest du hier: https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0 (https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0)

Allerdings brauchst du keine "Outbound Domains" und keinen STUN-Server eintragen. Den rest aber bitte so wie auf den Bildern dargestellt konfigurieren.

Zu dem "Statischen"-NAT: Wenn du kein "Static" konfigurierst ist es auch kein Statisches NAT. Lässt sich in der Einstellungseite bei Outbound NAT nämlich anhaken.

Nachtrag: Entschuldige, ich habe jetzt erst gesehen das du es angehakt hast, aber funktionieren kann das erst wenn du auch Ports dort definierst die 1:1 durchreicht werden sollen.

Mit Siproxd bist du aber flexibler, weil du so viele VOIP Clients ins LAN der OPNsense hängen kannst wie du möchtest ohne etwas umkonfigurieren zu müssen. Du musst bei Phonerlite so auch keinen Outboundproxy einstellen, denn der wird automatisch auf Port 5060 umgeleitet.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: MAGIC on July 29, 2018, 12:14:55 am
Hi,

Danke schonmal, aber jetzt kann das normale Telefon hören, aber nicht senden. Logs geben noch blocks aus.
(https://m.mufff.in/44c.png)
Habe die Siproxd Bilder angeschaut und bei mir eingetragen.

Mir ist aber aufgefallen, dass du eine NAT Regel in Bild 1 anlegst, aber diese nicht in Bild 2 auftaucht. Außerdem nehme ich an, dass 192.168.230.20 die OPNSense WAN Adresse ist oder?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on July 29, 2018, 01:28:31 am
@Magic

Nein, bei mir ist 192.168.230.20 die LAN Adresse. Das ganze habe ich für die Bilder virtuell nachsimuliert. An der WAN Adresse würde die NAT Regel ja auch keinen Sinn machen. Denn es geht ja um die Telefone im LAN. Bild Nr.2 zeigt die Firewallregeln des LAN Interfaces. Bild 3 die des WAN Interfaces. Die NAT Regel in Bild 1 könnte auch als IP 127.0.0.1 eingetragen bekommen. Würde damit auch funktionieren.

Alles in allem scheinst du einen Denkfehler zu machen. Konfiguriere doch einfach alles mal exakt nach den Bildern, mit Ausnahme der Outbound Domains und dem STUN Server. Und in Bild 1, die NAT Regel, legst du exakt so an mit der Zieladresse 127.0.0.1.

Wetten es funktioniert dann?  ;)

Dafür habe ich ja eine Bilderanleitung gemacht damit jeder die Schritte einfach nachvollziehen kann.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: MAGIC on July 29, 2018, 02:05:52 am
Hi,

Also habe die IP auf 127.0.0.1 geändert, ging erst nicht, dann mal die Firewall rebooted, weil 'reboot tut gut' und siehe da es geht
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on July 29, 2018, 05:29:23 am
Hi,

Also habe die IP auf 127.0.0.1 geändert, ging erst nicht, dann mal die Firewall rebooted, weil 'reboot tut gut' und siehe da es geht

Dann wünsche ich dir einen schönen Sonntag mit dem neuen Spielzeug.  ;D
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: mimugmail on July 29, 2018, 11:22:54 am
Hi,

Also habe die IP auf 127.0.0.1 geändert, ging erst nicht, dann mal die Firewall rebooted, weil 'reboot tut gut' und siehe da es geht

Vermutlich weil die SIP schon im Tracking war und dann das NAT nur für neue Verbindungen gilt. Der Reboot hat dann die Verbindung getrennt.

I.d.R braucht die Firewall keinen Reboot :)
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Wired Life on September 16, 2018, 09:14:39 pm
Ich hab jetzt siproxd am Laufen, aber irgendwie möchte meine 7490 den nicht  :'(
Phoner am PC klappt, 7490 nicht.
Einstellungen von Phoner sehen so aus:
Benutzername: 49MEINERUFNUMMER HÄKCHEN
Passwort: MEINPASSWORT
Proxy/Registrar: 192.168.176.1
Registrierung: Aktiviert
Lokaler Port: 5060
STUN Server: 127.0.0.1
Realm: 1und1.de
Telefonnummer: 49MEINERUFNUMMER

Einstellungen an der 7490 sehen so aus:
Benutzername: 49MEINERUFNUMMER
Kennwort: MEINPASSWORT
Registrar: 1und1.de (nicht geändert)
Proxy-Server: 192.168.176.1
STUN-Server: 127.0.0.1 < kann man nicht leer lassen weil sonst immer das drinne steht was vorher drinne war
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on September 17, 2018, 09:41:12 pm
Du musst  in deiner FritzBox dann auch die 1und1 Vorlage auf Benutzerdefiniert umstellen. In der Erweiterten Ansicht. Dann bleibt das Feld leer.

Außerdem beachte bitte die Einstellungen von 1und1: https://hilfe-center.1und1.de/dsl-hardware-c85325/fremd-hardware-c85411/konfigurationsdaten-1und1-telefonie-a796046.html

Der Registrar ist SIP.1und1.de. Nicht 1und1.de.

Den  STUN Server im Phoner leer lassen.
Den Stun Server von Siproxd auf: stun.1und1.de setzen.

Die FritzBox braucht den STUN nicht. Daher ist es egal ob der von 1und1 drinne steht.

Probiere bitte mal diese Einstellungen aus.

Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Wired Life on September 18, 2018, 03:27:43 pm
Alles schon probiert...
Die Fritzbox stellt automatisch auf die 1und1 Vorlage sobald irgendwo was von 1und1 steht, auch wenn ich eine neue Rufnummer anlege und "Anderer Anbieter" auswähle.
Das STUN Feld bleibt nur leer wenn man ein Leerzeichen rein schreibt, ansonsten steht immer wieder das drin, was vor der "Löschung" drin stand.
Das gleiche Phänomen ist auch bei Phoner vorhanden, da funktioniert es aber einfach irgendwas rein zu schreiben, bei der Fritzbox scheinbar nicht.
Bei den von Werk installierten Rufnummern ist übrigens 1und1.de als Registrar eingetragen und nicht sip.1und1.de, habe aber selbstverständlich beides ausprobiert.
Funktioniert leider wie gesagt nur via Phoner, dort aber anscheinend wirklich über siproxd, weil beim Stoppen des Services auf OPNsense keine Verbindung mehr funktioniert.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on September 18, 2018, 09:50:26 pm
Alles schon probiert...
Die Fritzbox stellt automatisch auf die 1und1 Vorlage sobald irgendwo was von 1und1 steht, auch wenn ich eine neue Rufnummer anlege und "Anderer Anbieter" auswähle.
Das STUN Feld bleibt nur leer wenn man ein Leerzeichen rein schreibt, ansonsten steht immer wieder das drin, was vor der "Löschung" drin stand.
Das gleiche Phänomen ist auch bei Phoner vorhanden, da funktioniert es aber einfach irgendwas rein zu schreiben, bei der Fritzbox scheinbar nicht.
Bei den von Werk installierten Rufnummern ist übrigens 1und1.de als Registrar eingetragen und nicht sip.1und1.de, habe aber selbstverständlich beides ausprobiert.
Funktioniert leider wie gesagt nur via Phoner, dort aber anscheinend wirklich über siproxd, weil beim Stoppen des Services auf OPNsense keine Verbindung mehr funktioniert.

Dann probiere doch mal diese Lösung (https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0&subfolder_nav_tracking=1) ist zwar für die Telekom, lässt sich aber im Prinzip genauso für 1und1 nutzen, was geändert werden muss ist der STUN Server in der Konfig, eben auf stun.1und1.de und in den outbound Domains muss als Name="1und1.de" als Realm und als HOST="sip.1und1.de" als Registrar eingetragen werden. In der Fritzbox änderst du jetzt aber nichts. Außer das du bei den Rufnummern alles auf 1und1 Standard belässt in deinem Änderungsfall bitte zurücksetzen. So läuft Siproxd dann Transparent ohne das du etwas in deinen Endgeräten als Proxy eintragen musst.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Wired Life on September 19, 2018, 06:50:15 am
Funktioniert auch nicht  :'(
Wie habt ihr die Fritzbox denn ans Netzwerk angeschlossen?
Ich hab sie als "vorhandener Zugang über LAN" konfiguriert und an LAN 1 das Netzwerk angeschlossen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on September 19, 2018, 10:44:24 pm
Funktioniert auch nicht  :'(
Wie habt ihr die Fritzbox denn ans Netzwerk angeschlossen?
Ich hab sie als "vorhandener Zugang über LAN" konfiguriert und an LAN 1 das Netzwerk angeschlossen.

Eine FritzBox von einem Bekannten habe ich genauso wie du es schreibst an 1und1 mit OPNsense über Siproxd angebunden. Deshalb wundert es mich das es so auch nicht bei dir funktioniert.

Ich kann am Wochenende aber mal bei meinem bekannten in die Konfig schauen, villeicht könntest du mal ein paar Screenshots reinstellen damit ich einen vergleich habe.

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: schnipp on October 16, 2018, 07:47:30 pm
Funktioniert auch nicht  :'(

Hast Du denn hinter der Opnsense mehrere SIP-Endgeräte, welche sich über NAT zum Registrar im Internet verbinden müssen? Falls nicht (z. B. nur eine Fritzbox im LAN), ist der Sipproxy nicht zwingend notwendig. Ich habe ihn bei mir wieder rausgenommen, funktioniert mit der Fritzbox 7490 sowie 1&1 einwandfrei
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: micmon on November 01, 2018, 10:06:45 pm
Erst einmal großen Dank an NicholasRush, deine Bildanleitungen sind super, hat mir sehr geholfen.

Mein Setup: Telekom DSL und VOIP, OPNsense hinter einem DSL-Modem im Bridge-Modus, Fritz!Box 7320 (nur für VoIP) mit zwei Fritz!Fons direkt hinter der OPNsense. Ich kann sowohl raus telefonieren als auch angerufen werden: so weit so gut!

Einziges Problem: eingehende Nummern haben das falsche Format. Statt 049111111 werden die Nummern als 49111111 angezeigt. Telefonieren klappt, man kann aber logischerweise nicht zurück rufen und die Nummern werden auch nicht gegen das hinterlegte Telefonbuch gematcht.

Da die Nummern ohne SIPROXD (static NAT auf der OPNsense box) korrekt durch kamen, gehe ich davon aus, dass hier SIPROXD den Fehler verursacht. Ich finde aber keine passende Option. Hat jemand eine Idee?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on November 02, 2018, 12:06:59 am

Einziges Problem: eingehende Nummern haben das falsche Format. Statt 049111111 werden die Nummern als 49111111 angezeigt. Telefonieren klappt, man kann aber logischerweise nicht zurück rufen und die Nummern werden auch nicht gegen das hinterlegte Telefonbuch gematcht.


Tritt dieses Problem denn bei jedem Anruf auf, oder nur partiell. Und wo taucht das in der FritzBox auf, im Telefonbuch oder auf der Diagnose Seite?

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: micmon on November 02, 2018, 07:37:59 am
>> Tritt dieses Problem denn bei jedem Anruf auf, oder nur partiell.

Es tritt zumindest bei den beiden Mobilnummern (Telekom und O2) auf, mit denen ich es gestern testen konnte. Beide Nummern hatten das Verhalten vor Umstellung auf SIPROXD nicht gezeigt.

>> Und wo taucht das in der FritzBox auf, im Telefonbuch oder auf der Diagnose Seite?

Die Nummern werden so auf den Mobilteilen angezeigt. Dort wird ja normalerweise für bekannte Nummern der hinterlegte Name aus dem Telefonbuch der Fritz!Box angezeigt. Auch auf der Fritz!Box in der Anrufshistorie sieht man die Nummern "falsch" in der Anrufsübersicht auf der Übersichtsseite (siehe Screenshot). Unter Diagnose finde ich nichts passendes, dort habe ich nur die Unterseiten "Funktion" und "Sicherheit"...
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on November 02, 2018, 10:45:57 pm
"Diagnose" war von mir blöd ausgedrückt... Ich meinte Tatsächlich "Telefonie -> Eigene Rufnummer -> Sprachübertragung". Da ich keine FritzBox mehr nutze, kenne ich die Menüstruktur leider nicht mehr so auswendig.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: micmon on November 03, 2018, 11:51:06 am
Dort wird +49xxxx angezeigt... siehe Anhang. Auf der Übersichtsseite wieder nur 49xxxx :/
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on November 03, 2018, 10:58:04 pm
Dort wird +49xxxx angezeigt... siehe Anhang. Auf der Übersichtsseite wieder nur 49xxxx :/

Sieht so aus als wenn Siproxd die CallerID umschreibt. Denn das ist die Rufnummer die auch im Fbox Telefonbuch auftaucht.

Du könntest einfach mal versuchen bei allen Plugins vom Siproxd "Enable fix_bogus_via plugin", "Enable fix_DTAG_networks plugin" und "Enable fbox_anoncall_networks plugin" den Haken wegzunehmen und die Plugins damit zu deaktivieren. Evtl. bearbeitet eines dieser Plugins den Sip Header mehr als er sollte. Auch wenn das Rufnummernformat ohne "0" also "49xxx" eigentlich richtig ist und ein "049xx" dagegen falsch wäre. Also was Siproxd hier korrigiert ist eigentlich richtig. Wenn du eine Nummer wählst Signalisierst du mit "00" das jetzt eine Rufnummer im Internationalen Format kommt. Bei einer Landesweiten Vorwahl dagegen nur mit "0". Und eine Ortsrufnummer beginnt direkt mit "1-9" und nicht mit "0". Und hier ist auch richtig das die Rufnummer umformatiert wird:

Beispiel:
Code: [Select]
Rufnummer: 1234567
Ort: 0211 (211)
Land: 0049 (49)
Du wählst jetzt innerhalb des Ortes: 1234567
Der Angerufene dagegen hat die wirkliche Nummer: 492111234567

Hoffe das das so verständlich erklärt ist. Also eigentlich wäre das Format so sogar das Richtige.
Der Unterschied damals zu heute ist ja, das es damals noch wirklich Ortsnetze gab. Heute ist alles Länder bezogen und so hat die Rufnummer in Wirklichkeit auch immer ein Internationales Format. Man kann notfalls aber bestimmt das Verhalten der FritzBox daran anpassen. Es ist halt auch von VOIP Anbieter zu Anbieter verschieden wie das Rufnummernformat übertagen wird. Die einen Schreiben innerhalb des Ortes wirklich nur "1234567" und andere eben das Standardisierte Internationale Format.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: micmon on November 04, 2018, 09:03:21 am
Sieht so aus als wenn Siproxd die CallerID umschreibt. [...]

Danke für die ausführliche Erklärung!

Ich habe gestern noch etwas recherchiert und probiert. Die Plugins habe ich in verschiedenen Kombinationen aus und an geschaltet, halt aber nichts. Im Endeffekt habe ich einen dann einen alten Eintrag im ip-hone-forum gefunden, in dem mit der Zeichenkette 00*;0*49;0*0;00*00 als Suffix ein Workaround beschrieben wurde. Und zumindest in meinen Testfällen funktioniert das.

Ich frage mich jetzt, ob tatsächlich SIPROXD die Nummer abändert oder ob der Effekt nun auftaucht, weil ich in der Fritz!Box nun das "Benutzerdefiniert" Profil statt "Telekom" benutze. Evtl. Hat "Telekom" ja diese oder eine andere Tauschregel eingebraut?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on November 04, 2018, 10:54:22 pm

Ich frage mich jetzt, ob tatsächlich SIPROXD die Nummer abändert oder ob der Effekt nun auftaucht, weil ich in der Fritz!Box nun das "Benutzerdefiniert" Profil statt "Telekom" benutze. Evtl. Hat "Telekom" ja diese oder eine andere Tauschregel eingebraut?

Es scheint genauso zu sein, wie du festgestellt hast. siehe hier: https://telekomhilft.telekom.de/t5/Telefonie-Internet/Eingehende-Rufnummernanzeige-falsch/td-p/875969 (https://telekomhilft.telekom.de/t5/Telefonie-Internet/Eingehende-Rufnummernanzeige-falsch/td-p/875969)

https://avm.de/service/fritzbox/fritzbox-7530/wissensdatenbank/publication/show/3390_Bei-ankommenden-Anrufen-wird-der-Name-des-Anrufers-nicht-angezeigt/ (https://avm.de/service/fritzbox/fritzbox-7530/wissensdatenbank/publication/show/3390_Bei-ankommenden-Anrufen-wird-der-Name-des-Anrufers-nicht-angezeigt/)

Ist zwar hier für die 7530 beschrieben, sollte aber auch für die Vormodelle mit VOIP gelten.

Anleitung:

Unter "Telefonie -> Eigene Rufnummer" in den jeweiligen Telekom Rufnummern die Vorlage von "Telekom" auf "anderer Anbieter" ändern, damit alle Felder angezeigt werden. Unter "Rufnummernformat anpassen" befindet sich ein Feld namens "Suffix für Internetrufnummern", dort bitte folgendes eintragen:
Code: [Select]
00*;0*49;0*0;00*00 Danach sollten die Rufnummern richtig angezeigt werden.
Bitte auch den oben verlinkten AVM Artikel dazu beachten, denn dort steht welches Rufnummernformat das Telefonbuch der FritzBox unterstützt.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on March 26, 2019, 09:59:34 am
Hallo zusammen,

leider komme ich hier nicht weiter, und bin mir ziemlich unsicher, ob es die OPNsense ist oder es auf Providerseite Probleme gibt.

Den SIPproxy habe ich hier nach den Anleitungen und Bildern aus diesem Thread eingerichtet. Telefon funktioniert auch. WIr haben 3 Nummern die registriert werden müssen. Dabei kommt es immer wieder zu Problemen. unter anderen meldet die Fritz!Box immer wieder "Anmeldung der Internetrufnummer [Rufnummer] war nicht erfolgreich. Gegenstelle meldet Ursache: [404].". Meist hilft da ein Neustart der OPNsense. Wenn dann die Rufnummer regestriert werden können, fällt nach kuzer Zeit 1 der 3 Nummern wieder aus. DIe anderen bleiben bestehen, man kann raus und reintelefonieren. Woran kann es liegen?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on March 30, 2019, 09:34:21 pm
Hast du in der FritzBox das Telekom Profil benutzt oder den Zugang Manuell konfiguriert?

Auch sollte der Sipproxd Transparent laufen, sodass in der FritzBox kein Eintrag gemacht werden muss um diesen zu nutzen.

Den SIPproxy habe ich hier nach den Anleitungen und Bildern aus diesem Thread eingerichtet. Telefon funktioniert auch. WIr haben 3 Nummern die registriert werden müssen. Dabei kommt es immer wieder zu Problemen. unter anderen meldet die Fritz!Box immer wieder "Anmeldung der Internetrufnummer [Rufnummer] war nicht erfolgreich. Gegenstelle meldet Ursache: [404].". Meist hilft da ein Neustart der OPNsense. Wenn dann die Rufnummer regestriert werden können, fällt nach kuzer Zeit 1 der 3 Nummern wieder aus. DIe anderen bleiben bestehen, man kann raus und reintelefonieren. Woran kann es liegen?
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 05, 2019, 03:17:50 pm
Also so richtig schlau werde ich daraus nicht. Ich habe alle möglichen Konfigurationen versucht, es bleibt dabei: Die Nummern sind alle hinterlegt und angemeldet in der Fritz!Box. Anschließend habe ich mich strikt an diesen Thread und die verlinkten Bildern gehalten. Dabei stoße ich immer wieder auf ein Problem; und zwar wenn ich in den Outbound NAT Regeln als NAT Adresse das WAN Interface angeben möchte, bekomme ich die Fehlermeldung, dass ich ein gültige IP Adresse angeben muss.

Telefon funktioniert für 10 Minuten samt Stimme, danach kommt bei anrufen immer direkt die Mailbox.

In der Fritz!Box habe ich beide Optionen schon versucht, also mit der Telekom Konfiguration und mit der Manuellen.

Könnt ihr nochmal die Schritte im Detail erklären? Ich weiß nicht wo ich einen Denkfehler habe.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 07, 2019, 12:45:31 am
Also so richtig schlau werde ich daraus nicht. Ich habe alle möglichen Konfigurationen versucht, es bleibt dabei: Die Nummern sind alle hinterlegt und angemeldet in der Fritz!Box. Anschließend habe ich mich strikt an diesen Thread und die verlinkten Bildern gehalten. Dabei stoße ich immer wieder auf ein Problem; und zwar wenn ich in den Outbound NAT Regeln als NAT Adresse das WAN Interface angeben möchte, bekomme ich die Fehlermeldung, dass ich ein gültige IP Adresse angeben muss.

Telefon funktioniert für 10 Minuten samt Stimme, danach kommt bei anrufen immer direkt die Mailbox.

In der Fritz!Box habe ich beide Optionen schon versucht, also mit der Telekom Konfiguration und mit der Manuellen.

Könnt ihr nochmal die Schritte im Detail erklären? Ich weiß nicht wo ich einen Denkfehler habe.

Also die Outbound NAT Regel brauchst du nur dann, wenn du Siproxd nicht benutzt.

Wenn du Siproxd benutzt und Transparent einsetzt, wie in meiner Bilderanleitung beschrieben, dann musst du das https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0&preview=NAT_REDR_RULE_Siproxd_Transparent.PNG&subfolder_nav_tracking=1 (https://www.dropbox.com/sh/o5px7n1aww42tl6/AADGtRWHAeW-ap3ptt_t4ZO9a/Deutsche_Telekom_Privatkunden?dl=0&preview=NAT_REDR_RULE_Siproxd_Transparent.PNG&subfolder_nav_tracking=1)

Als Portweiterleitung eintragen, also "Port Forwarding". Dann werden automatisch alle ausgehenden SIP Anfragen aus deinem Netz über den Siproxd abgewickelt ohne das du das deinen Endgeräten extra bekanntgeben musst.

Die Ziel IP ist in diesem Falle deine Adresse der LAN Schnittelle deiner OPNsense oder "127.0.0.1". Beides sollte funktionieren.

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: rantwolf on April 07, 2019, 11:50:10 pm
Grüße.

Ich versuche seit zwei Tagen bei nem Kumpel auch Telekom VoIP bei zum Laufen zu bekommen.
Aber irgendwie scheitert es zum Teil.
Ich hab den SIPproxd nicht ganz verstanden...
Was soll denn beim Reiter "users" rein?
Wenn ich den dann aktiviere, steht bei 'current registrations' viele Zeilen mit ****:0:0

Die Telekom hat doch die RTP Geschichte auf Port 10000:10100 laufen oder?

Und wenn der SIPproxd aktiviert ist, was muß dann in den Telefonieserver/SIPClient rein?
Die IP vom SIPproxd oder weiterhin Telekom?

Ich habs mal mit nem PortForward versucht.
Es kommen alle Gespräche rein und laufen auch durch, aber nur jeder "vierte" Anruf nach draußen hat ne Sprachübertragung.
Weiterhin glaube ich , daß da Angriffe drüber kommen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 08, 2019, 12:28:39 am
Grüße.

Ich versuche seit zwei Tagen bei nem Kumpel auch Telekom VoIP bei zum Laufen zu bekommen.
Aber irgendwie scheitert es zum Teil.
Ich hab den SIPproxd nicht ganz verstanden...
Was soll denn beim Reiter "users" rein?
Wenn ich den dann aktiviere, steht bei 'current registrations' viele Zeilen mit ****:0:0

Die Telekom hat doch die RTP Geschichte auf Port 10000:10100 laufen oder?

Und wenn der SIPproxd aktiviert ist, was muß dann in den Telefonieserver/SIPClient rein?
Die IP vom SIPproxd oder weiterhin Telekom?

Ich habs mal mit nem PortForward versucht.
Es kommen alle Gespräche rein und laufen auch durch, aber nur jeder "vierte" Anruf nach draußen hat ne Sprachübertragung.
Weiterhin glaube ich , daß da Angriffe drüber kommen.

Wenn du die Bilderanleitung 1:1 befolgt hast, sollte alles ohne Probleme funktionieren. Der Siproxd ist ein Sicherheitsgewinn, da einkommende SIP Pakete, die über die WAN Schnittelle empfangen werden, so am Siproxd münden und eben nicht zum Endgerät (FritzBox) etc. weitergleitet werden, außer ein Endgerät authentifiziert sich an einem Sip-Server im Internet. Und man wird über diesen Server angerufen. Diese Verbindung kann Siproxd dann zuordnen. Alle anderen nicht. Diese werden vom Siproxd dann ignoriert.
Die ganze Konstellation ist also definitiv ein Sicherheitsgewinn.

Dadurch das du den Siproxd Transparent konfiguriert hast mit der Portforwarding Regel, musst  du auch in den Clients nichts eintragen.

Die NAT Adresse in der Port Forwarding Regel ist außerdem die Adresse deines LAN Interfaces. Oder der Localhost "127.0.0.1". Das kannst du dir aussuchen. Falls du dort die Adresse eingetragen hast die ich in die Bilderanleitung geschrieben habe. Wundern mich deine Probleme nicht, denn so gehen alle Anrufe momentan am Siproxd vorbei.

Den "users" Tab benötigst du gar nicht. Denn sonst muss sich dein Endgerät noch am Siproxd authentifizieren. Aber das muss dein Endgerät auch unterstützen, ist aber bei den meisten nicht der Fall daher kannst du den ignorieren.

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Amari on April 09, 2019, 12:42:38 pm
Hat jemand Erfahrungen mit den VOIP Einstellungen bei Vodafone / Kabel Deutschland?
Stehe vor der Einrichtung und bin quasi noch ganz am Anfang.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 09, 2019, 09:52:15 pm
Hat jemand Erfahrungen mit den VOIP Einstellungen bei Vodafone / Kabel Deutschland?
Stehe vor der Einrichtung und bin quasi noch ganz am Anfang.

Noch nicht, wenn hast du mal bei Vodafone selber geschaut?
Was OPNsense betrifft sind es ja nur die VOIP Ports die geöffnet und weitergleitet werden müssen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: Amari on April 12, 2019, 06:32:03 pm
Noch nicht, wenn hast du mal bei Vodafone selber geschaut?
Was OPNsense betrifft sind es ja nur die VOIP Ports die geöffnet und weitergleitet werden müssen.

Vodafone bringt mich leider echt auf die Palme. Die geben die SIP Daten nur raus, wenn man am Anschluss ein Fremdgerät anschließt und aktiviert. Da ich aber deren Router benutze geben die mir die Daten nicht raus.
Die Sagen einem in der Hotline leider nur, das es technisch nicht möglich ist, was halt auch Schwachsinn ist. :(
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 13, 2019, 02:53:21 am
Das ist zwar schade, aber sage den doch einfach das du ein Fremdgerät nutzen möchtest. Denn wenn du die Zugangsdaten einmal hast, solltest du doch keine Probleme mehr haben.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: blodo176 on April 13, 2019, 09:01:00 pm
Hallo zusammen,

ich bin auch gerade dabei VOIP einzurichten. Funktioniert mit siproxd bis auf die doppelte Sprache.
Ich höre mich am Telefon selbst.
Das passiert nicht nur an meinem Telefon, sondern auch beim Empfänger. Die Sprache wird sozusagen an den Empfänger geschickt und auch an mich selbst. Genauso hört sich der Angerufene selbst. Wenn extern ein Gespräch eingeht, hört sich der Anrufer auch selbst.
Ich habe ein Gigaset 530 IP und einen Anschluss bei 1und1. Eine Fritzbox hängt nicht im System.
Den Outbound Proxy habe ich nicht im Telefon eingetragen. Alle Einstellung für die OPNsene stammen aus den Vorgaben der Bilder.
Evtl. hat jemand eine Idee.



 
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 13, 2019, 09:48:49 pm
Hallo zusammen,

ich bin auch gerade dabei VOIP einzurichten. Funktioniert mit siproxd bis auf die doppelte Sprache.
Ich höre mich am Telefon selbst.
Das passiert nicht nur an meinem Telefon, sondern auch beim Empfänger. Die Sprache wird sozusagen an den Empfänger geschickt und auch an mich selbst. Genauso hört sich der Angerufene selbst. Wenn extern ein Gespräch eingeht, hört sich der Anrufer auch selbst.
Ich habe ein Gigaset 530 IP und einen Anschluss bei 1und1. Eine Fritzbox hängt nicht im System.
Den Outbound Proxy habe ich nicht im Telefon eingetragen. Alle Einstellung für die OPNsene stammen aus den Vorgaben der Bilder.
Evtl. hat jemand eine Idee.

Evtl. liegt es am STUN Server und die Outbound Proxy Einstellungen solltest du auf automatisch stellen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: blodo176 on April 14, 2019, 12:52:50 pm
Das Problem sitz vor der OPNsense, wie schon die letzten 2 Wochen seit ich die Firewall habe. Alles funzt perfekt.
Für 1und1 können deine Voreinstellungen der Telekom ohne Änderungen übernommen werden. Ich habe auch noch den Voice Dienst von nexxtmobile eingebunden.

Würde es eigentlich gehen die Telefonie vom LAN in ein VLAN zu verlegen ?
Die offenen Ports im LAN gefallen mir gar nicht, auch wenn siproxd noch eine Sicherheitsschicht darstellt.


Für alle die vor der gleichen Aufgabe stehen noch ein paar Bilder zu den Einstellungen in siproxd und im Gigaset.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 14, 2019, 11:44:50 pm
Das Problem sitz vor der OPNsense, wie schon die letzten 2 Wochen seit ich die Firewall habe. Alles funzt perfekt.
Für 1und1 können deine Voreinstellungen der Telekom ohne Änderungen übernommen werden. Ich habe auch noch den Voice Dienst von nexxtmobile eingebunden.

Würde es eigentlich gehen die Telefonie vom LAN in ein VLAN zu verlegen ?
Die offenen Ports im LAN gefallen mir gar nicht, auch wenn siproxd noch eine Sicherheitsschicht darstellt.


Für alle die vor der gleichen Aufgabe stehen noch ein paar Bilder zu den Einstellungen in siproxd und im Gigaset.

In ein VLAN verlegen kannst  du das natürlich ohne Probleme wenn du möchtest. Evtl. kannst du bei dann bei 1und1 auch den siproxd immer als Outbound Proxy eintragen. Das unterstützt nur leider nicht direkt jedes Endgerät deins schon. So brauchst du auch keine Transparent regel. Auch wenn ich immer empfehle die drin zu lassen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 15, 2019, 03:48:25 pm
Leider funktioniert es immer noch nicht. Ich habe bereits die Firewall einmal auf factoy default zurückgesetzt und habe ganz genau die Anleitung befolgt. Ohne Erfolg. Die Nummern werden nicht registriert und wenn man versucht anzurufen, dann kommt nur die Ansage vom Anrufbeantworter. Wenn ich auch versuche in der Fritz!Box 7530 (Version 7.03) den STUN-Server Eintrag zu löschen, wird ein Kennwort gefordert. Somit stellt sich das System auch immer wieder zurück. Port Forward, LAN + WAN Rules habe ich alles nach der Anleitung eingestellt.Wie ich es auch versuche, VoIP funktionert leider nicht. Ich möchte euch bitten , dass ihr mir eine detailierte Anleitung samt Bilder noch einmal zur Verfügung zu stellt.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 16, 2019, 12:43:08 am
Leider funktioniert es immer noch nicht. Ich habe bereits die Firewall einmal auf factoy default zurückgesetzt und habe ganz genau die Anleitung befolgt. Ohne Erfolg. Die Nummern werden nicht registriert und wenn man versucht anzurufen, dann kommt nur die Ansage vom Anrufbeantworter. Wenn ich auch versuche in der Fritz!Box 7530 (Version 7.03) den STUN-Server Eintrag zu löschen, wird ein Kennwort gefordert. Somit stellt sich das System auch immer wieder zurück. Port Forward, LAN + WAN Rules habe ich alles nach der Anleitung eingestellt.Wie ich es auch versuche, VoIP funktionert leider nicht. Ich möchte euch bitten , dass ihr mir eine detailierte Anleitung samt Bilder noch einmal zur Verfügung zu stellt.

Hast du auch beachtet das die Port Forward Regel mit Zielport 5060 auf die LAN IP deiner OPNsense zeigt?
Ansonsten kann ich mir solche Probleme wie du hier beschreibst nicht vorstellen.

Auch bekommst du keine Fehlermeldung 404 von deiner Gegenstelle wenn es an Siproxd läge. Da muss etwas mit deinem Benutzernamen oder Kennwort falsch gelaufen sein.

Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 18, 2019, 05:02:13 pm
Also ich schaffe es zwar, dass sich die Nummer registrieren - hier im Bild (1), dennoch kann ich nicht anrufen oder angerufen werden. Es meldet sich direkt die Mailbox ohne ein Rufzeichen. Wenn ich nach den Bildern die OPNsense konfiguriert, erhalte ich bspw. bei den LAN Rules automatisch den Rule Eintrag für die NAT konfiguration. Das ist auf deinen Bildern auch nicht zu sehen. Hier im Bild (2). Die Destination IP ist die selbe, mit der ich aus dem LAN auf die OPNsense zugreife (192.168.X.X / Standart wäre 192.168.1.1). Noch einmal auf deine Eingangsfrage bezogen: in der Fritz!Box 7530 nutze ich unter Telefonie -> Eigene Rufnummern -> Rufnummer bearbeiten die Anmeldedaten der Telekom. Diese lassen sich auch nicht ändern. Wenn ich den Telefonanbieter auf Anderen Anbieter umstelle, den STUN-Server ändere, dann verlangt die Fritz!Box von mir ein Kennwort. Hier im Bild (3). Das Kennwort bzw. den Benutzername kann ich den Zugangsdaten der Telekom entnehmen; soweit ich das richtig verstanden habe. Dazu habe ich mir das hier angeschaut:https://telekomhilft.telekom.de/t5/All-IP-das-digitale-Netz/Zugangsdaten-fuer-die-Einrichtung-von-SIP-Geraeten/td-p/2585255 (https://telekomhilft.telekom.de/t5/All-IP-das-digitale-Netz/Zugangsdaten-fuer-die-Einrichtung-von-SIP-Geraeten/td-p/2585255). Wenn ich Daten dann eingebe und bestätige, dann wechselt die Fritz!Box die Daten wieder und der STUN-Server bleibt hinterlegt.

Kannst du mir da weiterhelfen? Vielen Dank an dieser Stelle für die ganze Mühe und die schnellen Rückmeldungen!

Beste Grüße,

david
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 18, 2019, 05:02:40 pm
Bild 2
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 18, 2019, 05:03:04 pm
Bild 3
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 18, 2019, 09:28:40 pm
Mal eine andere frage, wie kommt die OPNsense bei dir ins Internet über direkte PPPoE Einwahl oder mit vorgeschaltetem Router? Wenn du einen vorgeschalteten Router hast könnte das wegen den beiden Firewalls ebenso ein Problem sein.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 20, 2019, 12:04:09 pm
Über PPPoE. Hab nur ein Modem davor. Die OPNsense geht dann in die Switch und von da aus dann an die Clienten. Wäre es sinnvoll die Fritz!Box als TK-Anlage und AP direkt an die OPNsense zu verbinden? Liegt da das Problem unter umständen? Die Switch ist eine Managed Switch.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 20, 2019, 11:58:01 pm
Hast du den Managed Switch konfiguriert? Oder ist dieser in irgendeiner Form konfiguriert? Das Problem könnten hier Port basierte ACLs sein. Muss nicht, gehe davon auch nicht aus. Soll dir nur helfen den Fehler mal einzugrenzen.

Denn du bist der Einzige hier im Forum der bisher diese immensen Probleme mit der OPNsense und Siproxd und VOIP von der Telekom hat. Macht zumindest bei mir so den Eindruck. Tut mir allerdings auch leid das ich bisher auf keine Lösung bei dir komme. Sollte es allerdings doch an Siproxd liegen, dann müssten hier im Forum wohl noch mehr Leute Probleme haben, die Sie nicht melden und von denen ich dann nichts wissen kann.

Alternativ reichst du die Ports die die FritzBox für VOIP benötigt einfach komplett durch. Dann würde es sich aber anbieten die FritzBox an ein eigenes Interface der Sense zu hängen und sie von deinem LAN zu isolieren. Ob VLAN Interface oder Physikalisches (sofern vorhanden überlasse ich dann dir). Evtl. wäre das für dich dann sogar die beste Lösung.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: HomeWire on April 22, 2019, 09:21:14 pm
Also ich habe als Modem ein Netgear DM200 im Bridge Mode. Dort gibt esdie Möglichkeit "Passtrough VLAN" auszuwählen. Das habe ich bisher nicht aktiviert gehabt Leider funktioniert die PPPoE Einwahl dann nicht mehr wie gewünscht, wenn ich das Häckchen setze. Liegt es vielleicht daran? Ich werde mir jetzt erst einmal die Abhilfe schaffen, indem ich die Fritz!box als DMZ für VoIP und WLAN (bisher keine anderen APs im Haus) vor die OPNsense schalte und einige Clienten per Kabel an die Switch hinter der Firewall. Ist nicht die eleganteste Lösung aber ich probiere es natürlich weiterhin mit siprox und der Fritz!Box hinter der Firewall.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on April 25, 2019, 01:05:22 am
Also ich habe als Modem ein Netgear DM200 im Bridge Mode. Dort gibt esdie Möglichkeit "Passtrough VLAN" auszuwählen. Das habe ich bisher nicht aktiviert gehabt Leider funktioniert die PPPoE Einwahl dann nicht mehr wie gewünscht, wenn ich das Häckchen setze. Liegt es vielleicht daran? Ich werde mir jetzt erst einmal die Abhilfe schaffen, indem ich die Fritz!box als DMZ für VoIP und WLAN (bisher keine anderen APs im Haus) vor die OPNsense schalte und einige Clienten per Kabel an die Switch hinter der Firewall. Ist nicht die eleganteste Lösung aber ich probiere es natürlich weiterhin mit siprox und der Fritz!Box hinter der Firewall.

Hallo Homewire, nein so wie du die Einwahl konfiguriert hast ist das schon OK. VLAN kann dein Modem automatisch erkennen. Am besten wäre du würdest dir einen WLAN AP zulegen und die FritzBox nur noch für VOIP nutzen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: ojessie on May 04, 2019, 08:33:26 pm
Guten Abend,
ich bin ein wenig am verzweifeln aber vielleicht kann mir hier jemand helfen. Ich hab schon ein Posting hier https://forum.opnsense.org/index.php?topic=12623.0 bin aber mit Siproxed ein Stück weiter. Mein Problem als Anfänger ist, dass ich nur teilweise die einzelnen Aktionen nachvollziehen kann .... aber ich bin am Lernen ;-)
Status:

Siproxd:
Unter Current registrations sehe ich 5 Einträge:
0:13413443 (als Beispiel)
1: 123413434,
sip:meine Rufnummer@meine IP Fritzbox;uniy=134141234,
sip:meine Rufnummer@WAN IP Opnsense,
sip:meine Rufnummer@telekom.at

Somit glaube ich, dass sich Siproxd erfolgreich mit den Anmeldedaten der FB VoIP registriert hat.
Die FB hat sich allerdings nicht registriert.
Unter "anderer VOIP Anbieter" habe ich 4 Anmeldefelder:
Benutzername: meine Rufnummer
Kennwort: mein Kennwort
Registrar: *.telekom.at
Proxy-Server: meine IP der OPNsense

wenn ich nun beim Registrat "meine IP der OPNsense" eintrage registriert sich interessanterweise die FB Nummer aber ich kann weder wegrufen noch angerufen werden.
Warum registriert sich die FB? Es gibt keinen Hinweis auf die IP Adresse des Registrar bei der Telekom.
Port Forwarding habe ich wie beschrieben eingetragen:
Interface: LAN
Protocol: UDP
Address: LAN net
Ports: *
Destination: IP OPNSense
Ports: 5060 (SIP)
NAT: IP OPNSense
Ports: 5060 (SIP)

Jede Hilfe / Hinweis ist herzlich willkommen.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: NicholasRush on May 05, 2019, 10:37:42 pm
Hallo ojessie,

du hast einen sehr einfachen Fehler gemacht, du versuchst mit deiner Konfiguration der FritzBox deine VOIP Accounts am Siproxd zu registrieren statt über diesen den Anbieter Server zu kontaktieren.

Denn der Sipproxd nimmt intern vom LAN deiner Sense jede Art von Registration entgegen, was nicht gleich bedeutet, das man nachher auch telefonieren kann.

Richtig wäre in deinem falle alles nach der Bildanleitung von mir zu konfigurieren und in den Telekom Einstellungen der FritzBox nichts zu ändern. Das brauchst du nämlich dann gar nicht mehr.

Gruß
NR
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: ojessie on May 08, 2019, 04:53:44 pm
Hallo Nicholas,

Danke für deine Unterstützung ... leider funktioniert das nicht bei mir. Es funktioniert nicht mit der "standard" Anmeldung der FB für A1 noch mit der "anderer Anbieter". Mike hat mir auch schon versucht zu helfen bis jetzt ohne Erfolg.
Es scheint, das ich die SIP Ports nicht nach außen krieg ... meine States

all    udp    127.0.0.1:5060 (192.168.1.1:5060) <- 192.168.1.6:5060    NO_TRAFFIC:SINGLE

127.0.0.1 ist die OPNsense und 192.168.1.6 ist die FB

lg
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: ojessie on May 08, 2019, 05:01:19 pm
Update das sind meine aktuellen udp States

all    udp    10.0.0.1:5060 -> 193.81.4.68:5060    MULTIPLE:MULTIPLE    
all    udp    127.0.0.1:5060 (193.81.4.68:5060) <- 192.168.1.6:5060    NO_TRAFFIC:SINGLE    
all    udp    192.168.1.1:5060 -> 192.168.1.6:5060    MULTIPLE:MULTIPLE

10.0.0.1 ist die OPNSense, WAN
127.0.01 und 192.168.1.1 OPNsense LAN
192.168.1.6 FB
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: ojessie on May 08, 2019, 05:15:17 pm
Der einzige Unterschied der mir auffällt ist dein Port Forward startet mit einem Doppel Pfeil meine mit einem Pfeil nach rechts? Kann es das sein? und falls ja was bedeutet das und wie kann ich das ändern.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: norg on May 09, 2019, 02:54:04 am
Ich verzweifel auch noch Telekom VOIP. Danke für die Anleitung aber evtl. ist noch ein Wurm drin.

Kurz zu meinem Setup: Draytek Vigor VDSL Modem (250/40 Mbit/s Telekom Business) -> OPNSense -> Netzwerk (u.a. mit einer Fritzbox 7390 als Telefonanlage).

Ich hab es nun auch so wie in deinen Bildern eingerichtet, statt der 192.168.230.20 eben 127.0.0.1 eingetragen beim Port Forward.

Der Port Forward ist ja dazu da, dass transparent alle Anfragen ausm LAN an Port 5060 umgebogen werden und direkt auf der OPNSense landen und nicht rausgehen, korrekt?

Die LAN Firewall Reglen im zweiten Bild sollten nur notwendig sein wenn man sonst gewisse Zugriffe sperrt oder?
Zumal bei mir durch die Port Forward Regel auch noch eine weitere Regel mit Description NAT hinzugefügt wurde (automatisch):

Code: [Select]
IPv4 UDP LAN net * 127.0.0.1 5060 (SIP) * NAT
Bild 3 regelt, dass Anfragen auf die Ports SIP und RTP auch eingehend von der OPNSense akzeptiert werden.

Siproxd Settings 1:1 übernommen aber die DTAG Netze noch erweitert, da ich im tcpdump gesehen hab, dass auch mit anderne IPs aus 217.0.x.x kommuniziert wird per 5060.

In der Fritzbox hab ich "andere Anbieter" genommen.
Benutzername und Kennwort ausgefüllt. Registrat tel.t-online.de und Proxy und Stun Server freigelassen.
Laut Fritzbox auch registriert und ich kann raustelefonieren, komischerweise stürzt mein Android Phone nach dem 2. klingeln reproduzierbar ab.
Angerufen werden kann ich aber trotzdem nicht.

Hab ich evtl. noch irgendwas übersehen?

Wenn ich es ohne siproxd mache und ohne besondere Firewallregeln geht Anrufen und Angerufen werden, aber weder ich höre meinen Gegenüber noch er mich. Es  scheitern also aktuell bei mir noch beide Varianten.

Bin um jeden Hinweis dankbar.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: ojessie on May 09, 2019, 10:26:02 am
du bist zumindest schon um einige Schritte weiter ... ich schaffe es nicht, dass sich die FB VoIP registriert ... wie gesagt Registrierung ist nur möglich wenn die FB direkt hinter dem A1 Modem hängt.
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: norg on May 09, 2019, 01:54:31 pm
Ich hab nun erstmal doch wieder siproxd entfernt und lediglich folgendes getan:

- ein Alias RTP angelegt mit den Ports 7078-7097 (die nutzt die Fritzbox)
- ein Alias mit dem IP Range der Telekom SIP/RTP Server

- NAT Outbound eine Regel erstellt mit SIP und RTP (s.o.) die Static Port setzt, im Gegensatz zum Default
- NAT Port Forwards UDP mit den Protokollen SIP und RTP (s.o.), Quelle Telekom Range und leite das direkt zu meiner FB weiter.

Damit geht raus- und reintelefonieren und hab hier zwei Telefone seit 24 Minuten verbunden (das eine  ist mein Vodafone Anschluss mit eigenem Telefon).

Noch nicht ganz happy bin ich mit der Tatsache, dass das Port Forwarding meine Firewall etwas aufmacht und hoffe den IP Bereich noch weiter einzugrenzen, habe aber auch Angst, dass dann mal nix mehr geht wenn die Telekom die IPs anpasst.

Was mich noch wundert, dass bei meinem alten Arbeitgeber Sipgate genutzt wurde und mit Linphone SIP genutzt wurde ohne den ganzen Aufwand mit Port Forwarding.

Update: stellt sich raus ist evtl. alles nicht notwendig, seit ich bei der Fritzbox eingestellt habe, dass sie die Portweiterleitung aufrecht erhalten soll alle 30 sekunden geht es auch ohne die ganzen Einstellungen.

Update 2: Zu früh gefreut, heute morgen wurden die Pakete wieder  nicht korrekt weitergeleitet :(
Title: Re: [Siproxd & VOIP Support] Problem- und Lösungsthread
Post by: norg on May 10, 2019, 02:25:43 pm
Habe nun mal die Firewall auf conservative gestellt und das Port Forwarding wieder raus. Tut aktuell, mal sehen ob doch mal ein Telefonat nicht reinkommt.

@ojessie: kannst mal nen Screenshot von deiner Konfiguration auf Seiten der FB posten oder auch mal mit tcpdump mitsniffen auf beiden Interfaces, der SIP traffic ist da gut zu erkennen.