English Forums > 22.7 Legacy Series

22.7.6 to 22.7.7 failed update

(1/4) > >>

sonetoq:
I have been failing upgrading form 22.7.6 to 22.7.7 and it has happened a couple of times, this is the latest attempt of doing it, if someone can help me out that would be great

***GOT REQUEST TO UPDATE***
Currently running OPNsense 22.7.6 (amd64/OpenSSL) at Mon Nov 21 01:43:01 UTC 2022
Updating OPNsense repository catalogue...
OPNsense repository is up to date.
All repositories are up to date.
Updating OPNsense repository catalogue...
OPNsense repository is up to date.
All repositories are up to date.
Checking for upgrades (52 candidates): .......... done
Processing candidates (52 candidates): .......... done
The following 52 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
   bash: 5.2.2 -> 5.2.9
   dbus: 1.14.0,1 -> 1.14.4,1
   expat: 2.4.9 -> 2.5.0
   glib: 2.74.0,2 -> 2.74.1,2
   krb5: 1.20 -> 1.20.1
   libedit: 3.1.20210910,1 -> 3.1.20221030,1
   libgd: 2.3.3_1,1 -> 2.3.3_2,1
   libgpg-error: 1.45 -> 1.46
   libidn2: 2.3.3 -> 2.3.3_1
   libimagequant: 2.17.0 -> 4.0.4
   libpsl: 0.21.1_4 -> 0.21.1_6
   libunistring: 1.0 -> 1.1
   libxml2: 2.10.2 -> 2.10.3_1
   mpd5: 5.9_11 -> 5.9_12
   neon: 0.32.2 -> 0.32.4
   nss: 3.83 -> 3.85
   nut: 2.8.0_11 -> 2.8.0_13
   openssl: 1.1.1q,1 -> 1.1.1s,1
   openvpn: 2.5.7 -> 2.5.8
   opnsense: 22.7.6 -> 22.7.8
   opnsense-update: 22.7.5 -> 22.7.7
   os-nut: 1.8.1 -> 1.8.1_1
   os-wireguard: 1.12 -> 1.13_1
   pcre: 8.45_1 -> 8.45_3
   php80: 8.0.24 -> 8.0.25
   php80-ctype: 8.0.24 -> 8.0.25
   php80-curl: 8.0.24 -> 8.0.25
   php80-dom: 8.0.24 -> 8.0.25
   php80-filter: 8.0.24 -> 8.0.25
   php80-gettext: 8.0.24 -> 8.0.25
   php80-ldap: 8.0.24 -> 8.0.25
   php80-mbstring: 8.0.24 -> 8.0.25
   php80-pdo: 8.0.24 -> 8.0.25
   php80-phalcon: 5.0.3 -> 5.1.1
   php80-session: 8.0.24 -> 8.0.25
   php80-simplexml: 8.0.24 -> 8.0.25
   php80-sockets: 8.0.24 -> 8.0.25
   php80-sqlite3: 8.0.24 -> 8.0.25
   php80-xml: 8.0.24 -> 8.0.25
   php80-zlib: 8.0.24 -> 8.0.25
   png: 1.6.37_1 -> 1.6.38
   py39-Jinja2: 3.0.1 -> 3.1.2
   py39-cryptography: 3.4.8 -> 3.4.8,1
   py39-pytz: 2022.2.1,1 -> 2022.5,1
   py39-sqlite3: 3.9.14_7 -> 3.9.15_7
   python39: 3.9.14 -> 3.9.15_1
   sqlite3: 3.39.3,1 -> 3.39.3_1,1
   strongswan: 5.9.8 -> 5.9.8_1
   sudo: 1.9.11p3 -> 1.9.12p1
   suricata: 6.0.8 -> 6.0.8_1
   unbound: 1.16.3 -> 1.17.0

Installed packages to be REINSTALLED:
   openldap24-client-2.4.59_4 (options changed)

Number of packages to be upgraded: 51
Number of packages to be reinstalled: 1

The process will require 15 MiB more space.
55 MiB to be downloaded.
[1/52] Fetching unbound-1.17.0.pkg: .......... done
[2/52] Fetching suricata-6.0.8_1.pkg: .......... done
[3/52] Fetching sudo-1.9.12p1.pkg: .......... done
[4/52] Fetching strongswan-5.9.8_1.pkg: .......... done
[5/52] Fetching sqlite3-3.39.3_1,1.pkg: .......... done
[6/52] Fetching python39-3.9.15_1.pkg: .......... done
[7/52] Fetching py39-sqlite3-3.9.15_7.pkg: .... done
[8/52] Fetching py39-pytz-2022.5,1.pkg: .......... done
[9/52] Fetching py39-cryptography-3.4.8,1.pkg: .......... done
[10/52] Fetching py39-Jinja2-3.1.2.pkg: .......... done
[11/52] Fetching png-1.6.38.pkg: .......... done
[12/52] Fetching php80-zlib-8.0.25.pkg: ... done
[13/52] Fetching php80-xml-8.0.25.pkg: ... done
[14/52] Fetching php80-sqlite3-8.0.25.pkg: ... done
[15/52] Fetching php80-sockets-8.0.25.pkg: ..... done
[16/52] Fetching php80-simplexml-8.0.25.pkg: ... done
[17/52] Fetching php80-session-8.0.25.pkg: ..... done
[18/52] Fetching php80-phalcon-5.1.1.pkg: .......... done
[19/52] Fetching php80-pdo-8.0.25.pkg: ...... done
[20/52] Fetching php80-mbstring-8.0.25.pkg: .......... done
[21/52] Fetching php80-ldap-8.0.25.pkg: .... done
[22/52] Fetching php80-gettext-8.0.25.pkg: . done
[23/52] Fetching php80-filter-8.0.25.pkg: ... done
[24/52] Fetching php80-dom-8.0.25.pkg: ....... done
[25/52] Fetching php80-curl-8.0.25.pkg: ..... done
[26/52] Fetching php80-ctype-8.0.25.pkg: . done
[27/52] Fetching php80-8.0.25.pkg: .......... done
[28/52] Fetching pcre-8.45_3.pkg: .......... done
[29/52] Fetching os-wireguard-1.13_1.pkg: .. done
[30/52] Fetching os-nut-1.8.1_1.pkg: . done
[31/52] Fetching opnsense-update-22.7.7.pkg: ..... done
[32/52] Fetching opnsense-22.7.8.pkg: .......... done
[33/52] Fetching openvpn-2.5.8.pkg: .......... done
[34/52] Fetching openssl-1.1.1s,1.pkg: .......... done
[35/52] Fetching openldap24-client-2.4.59_4.pkg: .......... done
[36/52] Fetching nut-2.8.0_13.pkg: .......... done
[37/52] Fetching nss-3.85.pkg: .......... done
[38/52] Fetching neon-0.32.4.pkg: .......... done
[39/52] Fetching mpd5-5.9_12.pkg: .......... done
[40/52] Fetching libxml2-2.10.3_1.pkg: .......... done
[41/52] Fetching libunistring-1.1.pkg: .......... done
[42/52] Fetching libpsl-0.21.1_6.pkg: ........ done
[43/52] Fetching libimagequant-4.0.4.pkg: .......... done
[44/52] Fetching libidn2-2.3.3_1.pkg: .......... done
[45/52] Fetching libgpg-error-1.46.pkg: .......... done
[46/52] Fetching libgd-2.3.3_2,1.pkg: .......... done
[47/52] Fetching libedit-3.1.20221030,1.pkg: .......... done
[48/52] Fetching krb5-1.20.1.pkg: .......... done
[49/52] Fetching glib-2.74.1,2.pkg: .......... done
[50/52] Fetching expat-2.5.0.pkg: .......... done
[51/52] Fetching dbus-1.14.4,1.pkg: .......... done
[52/52] Fetching bash-5.2.9.pkg: .......... done
Checking integrity... done (0 conflicting)
[1/52] Upgrading openssl from 1.1.1q,1 to 1.1.1s,1...
[1/52] Extracting openssl-1.1.1s,1: .......... done
[2/52] Upgrading python39 from 3.9.14 to 3.9.15_1...
[2/52] Extracting python39-3.9.15_1: .......... done
[3/52] Upgrading libunistring from 1.0 to 1.1...
[3/52] Extracting libunistring-1.1: .......... done
[4/52] Upgrading png from 1.6.37_1 to 1.6.38...
[4/52] Extracting png-1.6.38: .......... done
[5/52] Upgrading libxml2 from 2.10.2 to 2.10.3_1...
[5/52] Extracting libxml2-2.10.3_1: .......... done
[6/52] Upgrading libidn2 from 2.3.3 to 2.3.3_1...
[6/52] Extracting libidn2-2.3.3_1: .......... done
[7/52] Upgrading expat from 2.4.9 to 2.5.0...
[7/52] Extracting expat-2.5.0: .......... done
[8/52] Upgrading py39-cryptography from 3.4.8 to 3.4.8,1...
[8/52] Extracting py39-cryptography-3.4.8,1: .......... done
[9/52] Upgrading libpsl from 0.21.1_4 to 0.21.1_6...
[9/52] Extracting libpsl-0.21.1_6: .......... done
[10/52] Upgrading libgpg-error from 1.45 to 1.46...
[10/52] Extracting libgpg-error-1.46: .......... done
[11/52] Upgrading libedit from 3.1.20210910,1 to 3.1.20221030,1...
[11/52] Extracting libedit-3.1.20221030,1: .......... done
[12/52] Upgrading krb5 from 1.20 to 1.20.1...
[12/52] Extracting krb5-1.20.1: .......... done
[13/52] Upgrading glib from 2.74.0,2 to 2.74.1,2...
[13/52] Extracting glib-2.74.1,2: .......... done
[14/52] Upgrading dbus from 1.14.0,1 to 1.14.4,1...
===> Creating groups.
Using existing group 'messagebus'.
===> Creating users
Using existing user 'messagebus'.
[14/52] Extracting dbus-1.14.4,1: ......... done
[15/52] Upgrading sqlite3 from 3.39.3,1 to 3.39.3_1,1...
[15/52] Extracting sqlite3-3.39.3_1,1: .......... done
[16/52] Upgrading py39-pytz from 2022.2.1,1 to 2022.5,1...
[16/52] Extracting py39-pytz-2022.5,1: .......... done
[17/52] Upgrading php80 from 8.0.24 to 8.0.25...
[17/52] Extracting php80-8.0.25: .......... done
[18/52] Upgrading libimagequant from 2.17.0 to 4.0.4...
[18/52] Extracting libimagequant-4.0.4: ......... done
[19/52] Upgrading bash from 5.2.2 to 5.2.9...
[19/52] Extracting bash-5.2.9: .......... done
pkg-static: Failed to execute lua script: [string "shell_path = pkg.prefixed_path("bin/bash")..."]:13: Integrity check failed
pkg-static: lua script failed
pkg-static: Failed to execute lua script: [string "shell_path = pkg.prefixed_path("bin/rbash")..."]:13: Integrity check failed
pkg-static: lua script failed
[20/52] Upgrading php80-session from 8.0.24 to 8.0.25...
[20/52] Extracting php80-session-8.0.25: .......... done
[21/52] Upgrading php80-pdo from 8.0.24 to 8.0.25...
[21/52] Extracting php80-pdo-8.0.25: .......... done
[22/52] Upgrading php80-mbstring from 8.0.24 to 8.0.25...
[22/52] Extracting php80-mbstring-8.0.25: .......... done
[23/52] Upgrading pcre from 8.45_1 to 8.45_3...
[23/52] Extracting pcre-8.45_3: .......... done
[24/52] Reinstalling openldap24-client-2.4.59_4...
[24/52] Extracting openldap24-client-2.4.59_4: .......... done
[25/52] Upgrading nss from 3.83 to 3.85...
[25/52] Extracting nss-3.85: .......... done
[26/52] Upgrading neon from 0.32.2 to 0.32.4...
[26/52] Extracting neon-0.32.4: .......... done
[27/52] Upgrading libgd from 2.3.3_1,1 to 2.3.3_2,1...
[27/52] Extracting libgd-2.3.3_2,1: .......... done
[28/52] Upgrading unbound from 1.16.3 to 1.17.0...
===> Creating groups.
Using existing group 'unbound'.
===> Creating users
Using existing user 'unbound'.
[28/52] Extracting unbound-1.17.0: .......... done
[29/52] Upgrading suricata from 6.0.8 to 6.0.8_1...
[29/52] Extracting suricata-6.0.8_1: .......... done
[30/52] Upgrading sudo from 1.9.11p3 to 1.9.12p1...
[30/52] Extracting sudo-1.9.12p1: .......... done
[31/52] Upgrading strongswan from 5.9.8 to 5.9.8_1...
[31/52] Extracting strongswan-5.9.8_1: .......... done
[32/52] Upgrading py39-sqlite3 from 3.9.14_7 to 3.9.15_7...
[32/52] Extracting py39-sqlite3-3.9.15_7: ........ done
[33/52] Upgrading py39-Jinja2 from 3.0.1 to 3.1.2...
[33/52] Extracting py39-Jinja2-3.1.2: .......... done
[34/52] Upgrading php80-zlib from 8.0.24 to 8.0.25...
[34/52] Extracting php80-zlib-8.0.25: ........ done
[35/52] Upgrading php80-xml from 8.0.24 to 8.0.25...
[35/52] Extracting php80-xml-8.0.25: ......... done
[36/52] Upgrading php80-sqlite3 from 8.0.24 to 8.0.25...
[36/52] Extracting php80-sqlite3-8.0.25: ......... done
[37/52] Upgrading php80-sockets from 8.0.24 to 8.0.25...
[37/52] Extracting php80-sockets-8.0.25: .......... done
[38/52] Upgrading php80-simplexml from 8.0.24 to 8.0.25...
[38/52] Extracting php80-simplexml-8.0.25: ......... done
[39/52] Upgrading php80-phalcon from 5.0.3 to 5.1.1...
[39/52] Extracting php80-phalcon-5.1.1: ........ done
[40/52] Upgrading php80-ldap from 8.0.24 to 8.0.25...
[40/52] Extracting php80-ldap-8.0.25: ........ done
[41/52] Upgrading php80-gettext from 8.0.24 to 8.0.25...
[41/52] Extracting php80-gettext-8.0.25: ........ done
[42/52] Upgrading php80-filter from 8.0.24 to 8.0.25...
[42/52] Extracting php80-filter-8.0.25: ......... done
[43/52] Upgrading php80-dom from 8.0.24 to 8.0.25...
[43/52] Extracting php80-dom-8.0.25: .......... done
[44/52] Upgrading php80-curl from 8.0.24 to 8.0.25...
[44/52] Extracting php80-curl-8.0.25: .......... done
[45/52] Upgrading php80-ctype from 8.0.24 to 8.0.25...
[45/52] Extracting php80-ctype-8.0.25: ........ done
[46/52] Upgrading opnsense-update from 22.7.5 to 22.7.7...
[46/52] Extracting opnsense-update-22.7.7: .......... done
[47/52] Upgrading openvpn from 2.5.7 to 2.5.8...
===> Creating groups.
Using existing group 'openvpn'.
===> Creating users
Using existing user 'openvpn'.
[47/52] Extracting openvpn-2.5.8: .......... done
[48/52] Upgrading nut from 2.8.0_11 to 2.8.0_13...
[48/52] Extracting nut-2.8.0_13: .......... done
[49/52] Upgrading mpd5 from 5.9_11 to 5.9_12...
[49/52] Extracting mpd5-5.9_12: .......... done
[50/52] Upgrading os-wireguard from 1.12 to 1.13_1...
[50/52] Extracting os-wireguard-1.13_1: .......... done
Stopping configd...done
Starting configd.
Reloading plugin configuration
Configuring system logging...done.
Reloading template OPNsense/Wireguard: OK
[51/52] Upgrading os-nut from 1.8.1 to 1.8.1_1...
[51/52] Extracting os-nut-1.8.1_1: .......... done
Stopping configd...done
Starting configd.
Reloading plugin configuration
Configuring system logging...done.
Reloading template OPNsense/Nut: OK
[52/52] Upgrading opnsense from 22.7.6 to 22.7.8...
[52/52] Extracting opnsense-22.7.8: .......... done
Stopping configd...done
Resetting root shell
pwd_mkdb: warning, unknown root shell
pwd_mkdb: warning, unknown root shell
Updating /etc/shells
cp: /etc/shells.bak: Bad address
Unhooking from /etc/rc
Unhooking from /etc/rc.shutdown
Updating /etc/shells
Registering root shell
pwd_mkdb: warning, unknown root shell
Hooking into /etc/rc
Hooking into /etc/rc.shutdown
Starting configd.
>>> Invoking update script 'refresh'
Migrated OPNsense\Unbound\Unbound from 1.0.3 to 1.0.4
Writing firmware setting...done.
Writing trust files...done.
Configuring login behaviour...done.
Configuring system logging...done.
Compiling glib schemas
No schema files found: doing nothing.
=====
Message from openldap24-client-2.4.59_4:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

No longer supported by upstream.  Please use a newer version of OpenLDAP instead.

It is scheduled to be removed on or after 2022-12-31.
You may need to manually remove /usr/local/etc/suricata/classification.config if it is no longer needed.
You may need to manually remove /usr/local/etc/suricata/reference.config if it is no longer needed.
You may need to manually remove /usr/local/etc/suricata/suricata.yaml if it is no longer needed.
=====
Message from strongswan-5.9.8_1:

--
The default strongSwan configuration interface have been updated to vici.
To use the stroke interface by default either compile the port without the vici option or
set 'strongswan_interface="stroke"' in your rc.conf file.
=====
Message from openvpn-2.5.8:

--
Note that OpenVPN now configures a separate user and group "openvpn",
which should be used instead of the NFS user "nobody"
when an unprivileged user account is desired.

It is advisable to review existing configuration files and
to consider adding/changing user openvpn and group openvpn.
You may need to manually remove /usr/local/etc/nut/nut.conf if it is no longer needed.
You may need to manually remove /usr/local/etc/nut/ups.conf if it is no longer needed.
You may need to manually remove /usr/local/etc/nut/upsd.conf if it is no longer needed.
You may need to manually remove /usr/local/etc/nut/upsd.users if it is no longer needed.
You may need to manually remove /usr/local/etc/nut/upsmon.conf if it is no longer needed.
=====
Message from opnsense-22.7.8:

--
Yes, I'm back in black
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 2 packages:

Installed packages to be REMOVED:
   bash-completion: 2.11_1,2
   cyrus-sasl-gssapi: 2.1.28

Number of packages to be removed: 2

The operation will free 1 MiB.
[1/2] Deinstalling bash-completion-2.11_1,2...
[1/2] Deleting files for bash-completion-2.11_1,2: .......... done
[2/2] Deinstalling cyrus-sasl-gssapi-2.1.28...
[2/2] Deleting files for cyrus-sasl-gssapi-2.1.28: .......... done
Checking all packages: .......... done
The following package files will be deleted:
   /var/cache/pkg/py39-pytz-2022.5,1.pkg
   /var/cache/pkg/pcre-8.45_3~6a14545e86.pkg
   /var/cache/pkg/bash-5.2.9~06888aaa99.pkg
   /var/cache/pkg/nss-3.85~5508b8e752.pkg
   /var/cache/pkg/os-nut-1.8.1_1~f0a7355d1c.pkg
   /var/cache/pkg/php80-gettext-8.0.25.pkg
   /var/cache/pkg/php80-sockets-8.0.25~267f3b6b2c.pkg
   /var/cache/pkg/php80-zlib-8.0.25.pkg
   /var/cache/pkg/opnsense-22.7.8~f5453cb6b8.pkg
   /var/cache/pkg/unbound-1.17.0~d22d663500.pkg
   /var/cache/pkg/bash-5.2.9.pkg
   /var/cache/pkg/php80-pdo-8.0.25.pkg
   /var/cache/pkg/libxml2-2.10.3_1~fcef15a1ef.pkg
   /var/cache/pkg/expat-2.5.0.pkg
   /var/cache/pkg/py39-Jinja2-3.1.2.pkg
   /var/cache/pkg/libedit-3.1.20221030,1~0296bd9b13.pkg
   /var/cache/pkg/py39-cryptography-3.4.8,1.pkg
   /var/cache/pkg/mpd5-5.9_12~a9e98d4828.pkg
   /var/cache/pkg/libunistring-1.1.pkg
   /var/cache/pkg/php80-session-8.0.25~710b276881.pkg
   /var/cache/pkg/libgpg-error-1.46~0f49b4ea2a.pkg
   /var/cache/pkg/opnsense-update-22.7.7~cd789ec08a.pkg
   /var/cache/pkg/libgpg-error-1.46.pkg
   /var/cache/pkg/python39-3.9.15_1~0b578c3415.pkg
   /var/cache/pkg/libidn2-2.3.3_1.pkg
   /var/cache/pkg/php80-dom-8.0.25~ab872015b0.pkg
   /var/cache/pkg/nut-2.8.0_13.pkg
   /var/cache/pkg/php80-sqlite3-8.0.25~a69292a805.pkg
   /var/cache/pkg/libgd-2.3.3_2,1~56cf0c6b49.pkg
   /var/cache/pkg/php80-simplexml-8.0.25~4f8795a7d1.pkg
   /var/cache/pkg/opnsense-update-22.7.7.pkg
   /var/cache/pkg/php80-filter-8.0.25~177dd52327.pkg
   /var/cache/pkg/php80-sockets-8.0.25.pkg
   /var/cache/pkg/neon-0.32.4.pkg
   /var/cache/pkg/png-1.6.38~5f0a3d29e6.pkg
   /var/cache/pkg/php80-ldap-8.0.25.pkg
   /var/cache/pkg/php80-curl-8.0.25.pkg
   /var/cache/pkg/libpsl-0.21.1_6~a57a840f11.pkg
   /var/cache/pkg/py39-sqlite3-3.9.15_7~a4203d795f.pkg
   /var/cache/pkg/suricata-6.0.8_1~96eafaa72b.pkg
   /var/cache/pkg/php80-ldap-8.0.25~0434ecf532.pkg
   /var/cache/pkg/py39-Jinja2-3.1.2~52e9d796f7.pkg
   /var/cache/pkg/php80-phalcon-5.1.1~6256c226a8.pkg
   /var/cache/pkg/openldap24-client-2.4.59_4~c8e1bcc203.pkg
   /var/cache/pkg/php80-gettext-8.0.25~a59ecd4bb3.pkg
   /var/cache/pkg/python39-3.9.15_1.pkg
   /var/cache/pkg/krb5-1.20.1~de6c7f5905.pkg
   /var/cache/pkg/sqlite3-3.39.3_1,1.pkg
   /var/cache/pkg/php80-phalcon-5.1.1.pkg
   /var/cache/pkg/expat-2.5.0~103a148b81.pkg
   /var/cache/pkg/nut-2.8.0_13~25407555ee.pkg
   /var/cache/pkg/php80-mbstring-8.0.25~cee2ecd83e.pkg
   /var/cache/pkg/unbound-1.17.0.pkg
   /var/cache/pkg/suricata-6.0.8_1.pkg
   /var/cache/pkg/libimagequant-4.0.4.pkg
   /var/cache/pkg/png-1.6.38.pkg
   /var/cache/pkg/py39-cryptography-3.4.8,1~c0d2e1a7a9.pkg
   /var/cache/pkg/dbus-1.14.4,1.pkg
   /var/cache/pkg/php80-xml-8.0.25~17b549f0d5.pkg
   /var/cache/pkg/php80-8.0.25~b6ddddb31c.pkg
   /var/cache/pkg/krb5-1.20.1.pkg
   /var/cache/pkg/strongswan-5.9.8_1.pkg
   /var/cache/pkg/php80-xml-8.0.25.pkg
   /var/cache/pkg/openvpn-2.5.8.pkg
   /var/cache/pkg/libedit-3.1.20221030,1.pkg
   /var/cache/pkg/glib-2.74.1,2.pkg
   /var/cache/pkg/sudo-1.9.12p1~a33a4043fd.pkg
   /var/cache/pkg/glib-2.74.1,2~4246ef30c1.pkg
   /var/cache/pkg/openvpn-2.5.8~14b14fb2de.pkg
   /var/cache/pkg/py39-pytz-2022.5,1~ac70b7049a.pkg
   /var/cache/pkg/os-wireguard-1.13_1.pkg
   /var/cache/pkg/php80-zlib-8.0.25~930ca74834.pkg
   /var/cache/pkg/py39-sqlite3-3.9.15_7.pkg
   /var/cache/pkg/strongswan-5.9.8_1~cd9cb0c222.pkg
   /var/cache/pkg/pcre-8.45_3.pkg
   /var/cache/pkg/mpd5-5.9_12.pkg
   /var/cache/pkg/php80-session-8.0.25.pkg
   /var/cache/pkg/php80-curl-8.0.25~4a01653dd2.pkg
   /var/cache/pkg/php80-8.0.25.pkg
   /var/cache/pkg/libidn2-2.3.3_1~8e719a91b5.pkg
   /var/cache/pkg/libunistring-1.1~6337b25a9e.pkg
   /var/cache/pkg/dbus-1.14.4,1~1120e5ee15.pkg
   /var/cache/pkg/libpsl-0.21.1_6.pkg
   /var/cache/pkg/php80-filter-8.0.25.pkg
   /var/cache/pkg/os-wireguard-1.13_1~d0294c515a.pkg
   /var/cache/pkg/neon-0.32.4~fb9e424e74.pkg
   /var/cache/pkg/libimagequant-4.0.4~11df094ecb.pkg
   /var/cache/pkg/openssl-1.1.1s,1.pkg
   /var/cache/pkg/php80-ctype-8.0.25~0619e3c89b.pkg
   /var/cache/pkg/libxml2-2.10.3_1.pkg
   /var/cache/pkg/php80-mbstring-8.0.25.pkg
   /var/cache/pkg/os-nut-1.8.1_1.pkg
   /var/cache/pkg/php80-dom-8.0.25.pkg
   /var/cache/pkg/openldap24-client-2.4.59_4.pkg
   /var/cache/pkg/opnsense-22.7.8.pkg
   /var/cache/pkg/sudo-1.9.12p1.pkg
   /var/cache/pkg/php80-sqlite3-8.0.25.pkg
   /var/cache/pkg/sqlite3-3.39.3_1,1~6d586092fb.pkg
   /var/cache/pkg/php80-pdo-8.0.25~eb3a7e756c.pkg
   /var/cache/pkg/libgd-2.3.3_2,1.pkg
   /var/cache/pkg/nss-3.85.pkg
   /var/cache/pkg/openssl-1.1.1s,1~6ea11cf9b4.pkg
   /var/cache/pkg/php80-simplexml-8.0.25.pkg
   /var/cache/pkg/php80-ctype-8.0.25.pkg
The cleanup will free 55 MiB
Deleting files: .......... done
All done
Nothing to do.
Starting web GUI...done.
Generating RRD graphs...done.
Fetching base-22.7.7-amd64.txz: ... done
Fetching kernel-22.7.7-amd64.txz: ... done
!!!!!!!!!!!! ATTENTION !!!!!!!!!!!!!!!
! A critical upgrade is in progress. !
! Please do not turn off the system. !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Installing kernel-22.7.7-amd64.txz... done
Installing base-22.7.7-amd64.txz..../usr/share/openssl/man/mandoc.db: Can't unlink already-existing object: Integrity check failed
./usr/share/man/mandoc.db: Can't unlink already-existing object: Integrity check failed
./etc/ssl/openssl.cnf: Can't unlink already-existing object: Integrity check failed
./boot/lua/cli.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/color.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/config.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/core.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/drawer.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/hook.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/loader.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/gfx-beastie.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/gfx-beastiebw.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/gfx-fbsdbw.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/gfx-orb.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/gfx-orbbw.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/menu.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/password.lua: Can't unlink already-existing object: Integrity check failed
./boot/lua/screen.lua: Can't unlink already-existing object: Integrity check failed
tar: Error exit delayed from previous errors.
 failed, tar error 0
***DONE***

sonetoq:
bump

franco:
I've seen these issues before but unsure why they happen. All other files should be rewritten cleanly for the base system... in any case try a health audit to see how the system is currently doing.


Cheers,
Franco

sonetoq:
just a couple of version mismatches

***GOT REQUEST TO AUDIT HEALTH***
Currently running OPNsense 22.7.6 (amd64/OpenSSL) at Wed Nov 30 22:23:36 UTC 2022
>>> Check installed kernel version
Version 22.7.5 is correct.
>>> Check for missing or altered kernel files
No problems detected.
>>> Check installed base version
Version 22.7.5 is correct.
>>> Check for missing or altered base files
No problems detected.
>>> Check installed repositories
OPNsense
>>> Check installed plugins
os-dyndns 1.27_3
os-nut 1.8.1
os-theme-cicada 1.29
os-upnp 1.4_2
os-wireguard 1.12
>>> Check locked packages
No locks found.
>>> Check for missing package dependencies
Checking all packages: .......... done
>>> Check for missing or altered package files
Checking all packages: .......... done
>>> Check for core packages consistency
Core package "opnsense" has 63 dependencies to check.
Checking packages: ...................
mpd5-5.9_11 version mismatch, expected 5.9_12
Checking packages: ...
openssl-1.1.1q,1 version mismatch, expected 1.1.1s,1
Checking packages: .
openvpn-2.5.7 version mismatch, expected 2.5.8
Checking packages: .
opnsense-22.7.6 version mismatch, expected 22.7.8
Checking packages: ...
opnsense-update-22.7.5 version mismatch, expected 22.7.7
Checking packages: ...
php80-ctype-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-curl-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-dom-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-filter-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-gettext-8.0.24 version mismatch, expected 8.0.25
Checking packages: ..
php80-ldap-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-pdo-8.0.24 version mismatch, expected 8.0.25
Checking packages: ..
php80-phalcon-5.0.3 version mismatch, expected 5.1.1
Checking packages: ..
php80-session-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-simplexml-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-sockets-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-sqlite3-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-xml-8.0.24 version mismatch, expected 8.0.25
Checking packages: .
php80-zlib-8.0.24 version mismatch, expected 8.0.25
Checking packages: ..
py39-Jinja2-3.0.1 version mismatch, expected 3.1.2
Checking packages: ....
py39-sqlite3-3.9.14_7 version mismatch, expected 3.9.15_7
Checking packages: .......
strongswan-5.9.8 version mismatch, expected 5.9.8_1
Checking packages: .
sudo-1.9.11p3 version mismatch, expected 1.9.12p1
Checking packages: .
suricata-6.0.8 version mismatch, expected 6.0.8_1
Checking packages: ..
unbound-1.16.3 version mismatch, expected 1.17.0
Checking packages: .. done
***DONE***

franco:
The health audit is correct, but then your updated packages are not registered as updated or did not install even though it said they would?

Maybe try this from the command line first:

# opnsense-update -p

It should update all the packages. The health audit will confirm or deny... we can always use more force later.

But prepare for the possibility that the hard disk is not in pristine condition.


Cheers,
Franco

Navigation

[0] Message Index

[#] Next page

Go to full version