English Forums > 21.7 Production Series

Wireguard Site-to-site issue

(1/1)

basn:
Hi there,

I have a problem with my Wireguard site-to-site setup. I have succesfully created a Wireguard connection between two sites. Site A's LAN is 192.168.0.0/24 and site B's LAN is 192.168.1.0/24. On a device connected at site A or site B, I am able to access systems on the other site without problems. For example, a NAS at site B is able to send rsyslog messages to a server at site A using address 192.168.0.10.

So now the issue. I would also like the OPNsense router at site B te send it's logging to 192.168.0.10. I entered that address in de OPNsense configuration (in System, Settings, Logging/targets) but no log messages arrive on the site A server. I tried Interfaces, Diagnostics, Ping on the site B router, but this fails. When I ping from a laptop at site B it works fine.

Can someone help me please?

Thanks, Bas Nijhuis.

basn:
I have solved it myself. It was a Wireguard misconfiguration. When I logged into the router using SSH and used "ifconfig" I noticed that both routers used 192.169.196.1 as interface address. This must have caused the issue somehow. After I used 192.168.196.1/24 as "Tunnel Address" on site A and 192.168.196.2/24 on site B the issue was solved.

Navigation

[0] Message Index

Go to full version