Okay, so I figured out I haven't looked at, perhaps, the most important place - the general log files.
Where, quite clearly, was sitting an error, stating "Certificate subject does not match configured hostname" .. which was the culprit.
Re-issued the server certs and everything started working. Even went back to TLS 1.3 (turns out, it's not a problem with the MAC check).
tl;dr - no issue with opnsense, but rather, a major issue with me :D At least, I learned a few new things.
Where, quite clearly, was sitting an error, stating "Certificate subject does not match configured hostname" .. which was the culprit.
Re-issued the server certs and everything started working. Even went back to TLS 1.3 (turns out, it's not a problem with the MAC check).
tl;dr - no issue with opnsense, but rather, a major issue with me :D At least, I learned a few new things.
"