Dynamic DNS ddclient config file backslash and commas causing issues

Started by Styx13, Today at 04:06:14 AM

Previous topic - Next topic
Hello,

I did open a topic a while back because ddclient config file is being generated with backslashes and commas at the end of most lines except the last two.

While this apparently work for a certain number of config for ddclient, it does not work for all.

Especially, if using a cmd to retrieve the IP (from freedns, or noip, ...), it will fail with the following warnings:

WARNING: Could not determine an IP for my.domain.com
WARNING: my.domain.com: unable to determine IP address with strategy use=cmd
WARNING: found neither IPv4 nor IPv6 address

If I remove all the backslashes and commas on the lines that have them in the config, then it all works:

UPDATE: updating my.domain.com
INFO: setting ipv4 address to 1.2.3.4 for my.domain.com
[...]
SUCCESS: updating ipv4: good: my.domain.com  address set to 1.2.3.4.

The configuration backslashes and comma seem to be a known problem in some cases: https://github.com/ddclient/ddclient/issues/738

Would it be possible to add an option/checkbox on the plugin which when it is not selected it does not add the blackslashes and commas, and when it is selected it adds them?

Thank you