Archive > 20.1 Legacy Series

please help on wireguard

<< < (2/2)

Same issue here. Similar/same behavior. Traffic seems to be getting to/from wg client but no handshake?

Where does wg put its logs?

All help appreciated!


I had the same problem, but my setup is working now.

WireGuard Local: Tunnel Address
WireGuard Endpoint1: Allowed IPs

Firewall > Rules > WAN > Add a rule with protocol UDP, Destination port range 'other' 51820
Firewall > NAT > Outbound > Set to Hybrid > Add a rule: Interface WAN, Source address WireGuard net, Translation / target WAN address
Firewall > Rules > WireGuard > Add a rule: Source = Single host or network >

I restarted WireGuard service and then it worked.

Hope this helps.


Thanks for sharing your setup. I got it working too by starting from scratch and following step by step instead of the original instruction I posted.

I've the same problem using "OPNsense 21.1.4-amd64" with "os-wireguard v1.5".

I can establish a working connection to wireguard with ease when connecting via LAN but not via WAN coming from the internet (tested with muliple devices). I see the connection initialisation package from the remote client on my WAN Interface when capturing packages. I see something happening on server-side, but internet-clients do not recieve a single package in response and thus there is no handshake - also no traffic on the wireguard interface. I triple-checked the inbound rule on the WAN-interface with the port in use, but I don't find the issue. Debug/logging capabilities on wireguard are somewhere between bad and non-existent.

Has anyone found the root cause of this problem? I don't want to start from scratch without indication to succeed.

EDIT: Problem solved. Outbound traffic was routed through wrong/different WAN interface and couldn't reach target.


[0] Message Index

[*] Previous page

Go to full version