Archive > 20.1 Legacy Series

OpenVPN "Force all client generated traffic through the tunnel." IPv4 only


I'm running OpenVPN on 20.1-RC1.  I select "Force all client generated traffic through the tunnel" in my OpenVPN Remote Access server config.  I use the client export utility.  I can connect fine from my laptop, and I get assigned a working IPv4 and IPv6 address.  However, only the and routes through the VPN tunnel are added when I connect.  No IPv6 routing table entries are made, and none of my IPv6 traffic goes over the VPN.   Shouldn't ::/1 and 8000::/1 routes be added when I connect?  If I manually add the routes on my laptop, it can access the internet fine over the IPv6 OpenVPN link, but by default, no IPv6 traffic goes over the tunnel.

Not sure if it is the same with 20.1-RC1 (I'm not brave enough) but on 19.7 I've added this option under 'Advanced' in my OpenVPN server:

push "route-ipv6 2000::/3"

This allows the clients to access public IPv6 addresses through the tunnel. You can add any ULA ranges that you have on the server end, if required.



[0] Message Index

Go to full version