Archive > 15.1 Legacy Series

IP setup problem



I have interesting problem. Fresh installation of OPNsense in VMWare environment. VM has 2 interfaces, one on public internet, second on private network.

After successful installation I have tried to setup IP for WAN interface.
WAN interface is em0, LAN is em1.

IP setup should be:
Mask: = /27

DHCP disabled, IPv6 disabled.

When IP setup is over I see that the IP was not assigned and machine is not reachable on net.

Any idea ?

Hi orpheus,

It may have to do with the default being em0: LAN em1: WAN.. did you reboot after changing that order?

I tried it on a live system with the latest 15.1.1 version that will be released later today as we did have some issues with setting static ip adresses on WAN.. so its likely the issue has been resolved.

Perhaps you can retry with the latest version?
If you keep running into issues, please let me know so we can find the cause and fix it asap.

The latest version should be on sourceforge in a few hours.


I currently have a similar configuration however mine is running on Hyper-V 2012 R2, two Virtual switches one for WAN and one for LAN. Below are settings that are currently on mine, do you have your virtual switches setup correctly?

Also something else to watch is make sure your WAN and LAN interface is set to the correct adapter, the first installation I had, I put EN0 as WAN and EN1 as LAN when it needed to be EN0 LAN and EN1 WAN, I'm assuming that's how the OS read the adapters presented to it even though EN0 should have been the adapter as WAN. (Confusing yet?)

Last weird thing I encountered, when I accidently set the wrong interface and I was doing so from the Virtual Console to the server, it would never correctly assign the IP address. I found out that when changing the IP address it asks you one more question at the end, something like "switch to HTTP", answer yes on this if you are attempting these changes from the Virtual Console, and once its working from the web interface switch it back over to https. I have no idea why this was occurring but it snapped out of it and I never had the issue again.

DHCP: Disabled
IPv4 Configuration Type: DHCP
IPv6 Configuration Type: None
Block private networks: True
Block bogon networks: True

Every other setting remained blank.

DHCP: Disabled
IPv4 Configuration Type: Static IPv4
IPv6 Configuration Type: None
IPv4 address:
/ xx
Block private networks: True
Block bogon networks: True

Every other setting remained blank.

Thanks, the new version - fresh install worked without problems


[0] Message Index

Go to full version