OPNsense Forum

Archive => 18.1 Legacy Series => Topic started by: Cldetcom on May 07, 2018, 05:32:46 pm

Title: Bell Fibe PPPoE
Post by: Cldetcom on May 07, 2018, 05:32:46 pm
Hello all,

I am new to the forum. I have been using OPNsense for almost a year and it rocks, well, until today. Lol. I have been using an ISP that provides the WAN link with a simple DHCP connection. With them all has been working flawlesly. I changed to another provider (Bel) that provides a crapy all-in-one unit (ONT,Router,WIFI) and I want to remove this unit and use OPNSense.

There are no guides on how to setup PPPOE for OPNSense so I tested first my setup with an old Cisco RV042 that I had lying around. I removed the SFP module from the BHH3000 unit from Bell and I inserted it into my Dell's powerconnect combo port 24. I plugged the WAN port from the RV042 to my Dell's port number 21. I then set VLAN 35 (used by Bell for the internet connection) on port 21 and port 24 (tagged on port 24)  of my powerconnect switch and configured my PPPoE username and password in the RV042. It worked in seconds. All was working fine, the WAN IP address and gateway were configured and I was able to browse the Internet. The only issue is that the RV042 is quite old and only has 100Mbps ports so I was limited to that.

Then I removed the RV042 and plugged the WAN port of my OPNSense unit in the same port 21 of the powerconnect. I used the wizard to setup PPPoE and..... nothing. The interface for the WAN connection was set to a non-existing thing. So after spending several hours moving here and there I managed the connection to go UP but I get a messed up configuration. If I verify the "Interfaces: Overview" page for my PPPOE connection I see that the Status is up, PPPoE is UP. The assigned IP address is fine (winthin Bell's public IPs range) but the given gateway for the connection is a private IP ( Of course this doesn't work since I am not able to get out to the Internet.

What has to be done in OPNSense to get the PPPoE to work as simple as it was with the RV042. Since the RV042 worked first shot there is no issue with the VLAN configuration or something else. The OPNSense configuration is simply not working and I can't find a decent manual or guide to get it to work. I only found a post where the guy said that it simply didn't work and he had to go back to pfsense, I don't really want to go pfsense.

Any ideas?

Thx in advance
Title: Re: Bell Fibe PPPoE
Post by: Cldetcom on May 07, 2018, 10:22:01 pm
An update.

I am still trying. I reinstalled OPNSense from scratch, ran the wizard, same thing. Installed pfSense from scratch, ran the wizard and it works. So this seems to be an issue related to OPNSense. I will stay with pfSense (that is working out of the box) in the meanwhile.
Title: Re: Bell Fibe PPPoE
Post by: franco on May 08, 2018, 07:18:38 am
Hi there,

The wizard is not perfect, but also provides little flexibility in testing with users as you can see from this thread:


It would be best to skip the wizard and go with the real configuration pages there. It could also help pin down the differences with the wizard's setup. I'm sure there is at least one bug in the wizard, but we can't inspect this locally unfortunately.