OPNsense Forum

Archive => 17.7 Legacy Series => Topic started by: srteyo on January 17, 2018, 10:31:17 am

Title: Restoring config breaks LAN connectivity
Post by: srteyo on January 17, 2018, 10:31:17 am
Hi guys,

I've recently started using OPNSense 17.7.5 DVD version in a test environment before putting it in a production environment replacing the basic ISP modem-router we have at the moment. With the default config, everything seems to work just fine. It's when I tinker with backup/restore config that everything goes south.

Starting config:
WAN:, gateway:
LAN:, WorkStation1 (WS1) connected via cable and given IP by DHCP:

1) WS1 pings and google.com successfully. Can use the internet normally.
2) Backup entire config, everything works.
3) Restore that very same config xml right away.
4) Restart.
5) WS1 can ping but can't ping google.com or even the WAN interface. Obviously can't access the internet.

I'd been banging my head against the wall with this until I finally found out what was causing it. I found it by sheer luck when taking a shot in the dark, though, as everything else seemed to be configured correctly.

I find very strange that something so crucial and used such as the backup/restore function is not working properly, but on the other hand, I managed to reproduce the problem following the steps provided above, so I came here for help.

I haven't found any issues in github related to this. What do you guys think?


I've done the same thing for the second time and this time it's worked. Right after that, I imported only the firewall rules (some basic rules to allow webgui from WAN and OpenVPN traffic) from an older backup and it broke just as I described. After disabling and erasing all these custom rules, the problem persists. Could it be that restoring firewall rules can break things down?
Title: Re: Restoring config breaks LAN connectivity
Post by: franco on January 17, 2018, 10:36:51 pm
Hmm, if ones does a config export and import with a reboot... nothing changes in the configuration as it reads and writes the file with the same content.

Unless you can see how the /conf/config.xml prior to export and after import looks like on the disk this is hard to trace. Something could happen to it on reboot that causes it to write an incompatible setting, but it's unlikely.

So have you tried to review the difference of the configs on the System: Configuration: History page?