OPNsense Forum

Archive => 17.7 Legacy Series => Topic started by: AC on January 10, 2018, 08:43:26 am

Title: Gateway switching problems
Post by: AC on January 10, 2018, 08:43:26 am
Hey Folks

i experience a strange behavior and I'm a little bit helpless with that.

I'm routing to different Networks with multi-wan. DNS is routed to two DSL connections AND a special Network where the parent DNS Server is in. I configured the three Interfaces as GatewayGroup_DNS.

Everything worked fine - but about once a day, only my DNS routing does stop working. I can't ping or lookup DNS Servernames but i can ping IP's in every net through every interface connected.

The strange thing is, when this happens, I also can't ping the opensenseFirewall Gateway but only from my DNS-Servers! Every Client can ping the Firewall! Also, when I'm using the parent DNS Server in my Client directly, DNS will work for that Client.

I'm not using any DNS Service from the Firewall - just routing DNS from my Servers to the GatewayGroup_DNS.

No IDS used! No DNS-Service from opnsense. DNS Server seem to get blocked after some hours!

Reboot helps...
Title: Re: Gateway switching problems
Post by: AC on January 11, 2018, 06:34:34 pm
Now I know where it comes from. Seems to be one of my DSL Connections.

I need to totally disable the whole interface in "Interfaces". This connection DSL02 was my default Gateway and experienced some error (don't know - still searching). When that happens, nothing helps:
I promoted my DSL01 connect as default Gateway.
I turned the DLS02 Gateway off.
Tried to restart apinger.

Turned my Interface DSL02 off and the packets flow again.

Is there a logfile where i can see errors on my interfaces?
Title: Re: Gateway switching problems
Post by: AC on January 15, 2018, 02:50:39 pm
Found that error.

I bound the internal DNS Server on System -> Settings -> General to one of my aDSL-connection.

Removed that and ticked "Allow DNS server list to be overridden by DHCP/PPP on WAN"

No more problems