OPNsense Forum

Archive => 17.7 Legacy Series => Topic started by: nivek1612 on December 30, 2017, 09:14:48 am

Title: [SOLVED] radvd AdvLinkMTU puzzle
Post by: nivek1612 on December 30, 2017, 09:14:48 am
Recently moved over from pfSense (I know what took me so long)
Pretty happy with OPNsense (apinger aside but I know thats a a whole different subject) 

However my log in Sytsem -> Routes -> log file is full of these messages - roughly one every 5 mins

radvd[3150]: our AdvLinkMTU on igb1 doesn't agree with fe80::6203:47ff:fe16:19b0

igb1 is my LAN
the link local address is that of my Billion 8800NL in bridge mode acting as my modem to my ISP. It is connected to the LAN via one of its LAN ports so that I can extract connection stats.

I've tried changing LAN config entry for MTU in OPNsense for the LAN to 1492 etc to no avail and can see no way of changing the Billion

I sure its something stupid I'm doing but anyone care to point me straight
Title: Re: [SOLVED] radvd AdvLinkMTU puzzle
Post by: nivek1612 on January 01, 2018, 06:16:04 pm
Tracked it down

Despite the Bilion Router being in bridge mode the presence of a disabled WAN PPPoA interface was causing radvd process to be run on the billion

Killing the radvd process and removing the PPPoA cured it 

Turns out that after a reboot the the radvd process was back on the modem. Downgraded firmware to 2.32d.dh14 from 2.34e and the problems is resolved. I can only surmise the Billion firmware has a bug in at 2.34e. There is no newer firmware.