OPNsense Forum

Archive => 17.7 Legacy Series => Topic started by: dupsatou on December 11, 2017, 07:40:59 am

Title: [SOLVED] Weird issue after power loss/restart
Post by: dupsatou on December 11, 2017, 07:40:59 am

I made the move to Opnsense from VyOS several months ago and haven't looked back.  Since everything was set up it's all been working swimmingly.  But for some reason after a power blip 2 days ago I have not been able to get NFS traffic working again between a client/server across VLANs.  I've been over the rules so many times and everything looks fine.  I've rebooted everything again to make sure something didn't load incorrectly, I've done system updates to both client/server as well as upgrading opnsense.  I cannot see any reason why traffic should be getting hung up.  But when I move the client to be on the same VLAN as the server therefore bypassing Opnsense it works just fine.  When I put it back, it fails.  Doing a tcpdump on the client shows what appears to maybe be a timeout on port 2049 but opnsense should be allowing that through from the rules.  I have even modified the rule at this point to allow all traffic from the client to server regardless of the port and it still hangs up.

Is there any reason why this would've worked for months and suddenly quit after a reboot?  Anybody have any suggestions of something I might be missing?  Anything is greatly appreciated!

Title: Re: Weird issue after power loss/restart
Post by: dupsatou on December 11, 2017, 06:19:36 pm
Well I feel like a doofus.  It was an asymmetric route that I continuously overlooked because I insisted... to myself... that I didn't have one.

Hope this helps somebody else as stubborn as I was.
Title: Re: [SOLVED] Weird issue after power loss/restart
Post by: franco on December 12, 2017, 08:20:35 am
Hi dupsatou,

Happy this resolved itself.  Thank you for the follow-up. :)