OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: cake on February 18, 2017, 02:43:17 am

Title: [SOLVED] UPnP
Post by: cake on February 18, 2017, 02:43:17 am
I am missing the UPnP in services. So in System-->Firmware--> Packages I see miniupnpd was already installed, So I tried to install in plugins --> os-upnp.
It installed and I rebooted, but dnscrypt-proxy no longer worked. (I am using multiple dnscrypt) dnscrypt-proxy would not start, and I could not find anything in the /var/log as to why (I tried to increase verb) - my skills are not that good. UPnP showed up in Services, just like some screen shots I have seen in other posts.

So I removed os-upnp, and after reboot. dnscrypt-proxy started automatically and works again, but Universal Plug and Play is missing in Services (GUI). I have a machine with Steam on it, and on several games the mutiplayer does not work, so I am guessing I need UPnP and allow that machine on the network to open ports? Just wondering if anyone else knows what I did wrong.
Title: Re: UPnP
Post by: cory1768 on February 18, 2017, 10:28:47 pm
UPnP was moved to a plugin, as per their update notes:

The following services moved to individual plugins and need to be reinstalled in order to be used: SNMP, Load Balancer, Wake on LAN, Universal Plug and Play, IGMP Proxy.  Their respective configurations will be preserved by the system even if these plugins are not installed.

I too had the same issue, I simply removed the UPnP plugin and then went back re-added it. Went into my UPnP settings hit save and on the refresh the service was suddenly running again. Not sure what the issue might have been but possibly something due to the upgrade. I hope this helps you.
Title: Re: UPnP
Post by: Nnyan on March 06, 2017, 09:16:36 pm
Pretty new to OPNSense an I completely missed this (and didn't find anything mentioned in the Docs).  and I was about to post about this.  Thank you for the info.