OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: szty0pa on February 03, 2017, 05:41:41 pm

Title: possible install, upgrade, hardware issues (can anyone confirm them?)
Post by: szty0pa on February 03, 2017, 05:41:41 pm
Hi guys!

Thank you for all your hard work making this amazing OS possible!
I am experimenting with OPNsense on a Wyse 7010 (https://appservices.wyse.com/supportdownload/WES/Dell%20Wyse%20Enhanced%20Microsoft%20Windows%20Embedded%20Standard%207%20WFR8%20Release%20Notes.pdf) box for a few months now (starting with 16.7.10 I think). [at the end of the linked document are some crude hardware specs, but these are the best I found]
It generally is working well, though I think I spotted a few things that might make OPNsense even better:

 - a manually installed system won't boot after the install is complete! (guided install works fine though) I think this might have to do with the box being an EFI system (the guided install even asks if I want a GPT or MBR install), and going with the defaults (use the whole disk for / and make it bootable) in the manual install creates an MBR/BIOS system.

 - upgrading from 16.7 to 17.1R1 resulted something like a serial port issue mentioned in the PFsense forums a few years ago (something like this (https://www.youtube.com/watch?v=MPO5nAkVm7o)) even though this box does not have any serial ports, not even headers or options to disable in the firmware setup. I just found a newer firmware for this, and will try to update it later on tonight, but freshly reinstalling 17.1 solved this fortunately.)

[the following are definitely upstream FreeBSD issues, but might help someone as I found a workaround for these]
 - the VGA console output through DisplayPort is garbled (looks like 640x480 with horizontally offseted lines), gop set 10 at the boot prompt and/or in the loader.rc.local solves it for most modern displays (1920x1080);  solution (https://forums.freebsd.org/threads/53150/) [note: this is a UEFI issue, not FreeBSD specifically, a firmware update might help]

 - the AR938x wifi chip has some problems associating with the AP using WPA2 in spite of supposedly being supported by FreeBSD (https://wiki.freebsd.org/dev/ath_hal%284%29/HardwareSupport). I found that it can be (partially) solved by booting up the box with Alpinelinux, connecting manually and then restarting it with OPNsense. (I said partially because it was working with 16.7 before;  with 17.1 it associates but the connection is not working either because of a configuration issue or the driver itself: pinging an arbitrary IP or the AP itself results in network unreachable messages.) I will also try to investigate this further tonight and try to see if connecting in linux solves the problem because it registers the card with the AP or is it a firmware glitch in the wifi card?

I will try to keep you guys posted.
Thanks for all again! :)