OPNsense Forum

Archive => 15.1 Legacy Series => Topic started by: fratotec on May 10, 2015, 01:53:59 am

Title: [SOLVED] pftop not working
Post by: fratotec on May 10, 2015, 01:53:59 am
I did my first FreeBSD / Opnsense firewall installation and after adding a lot of config ( transferred from a Linux / Shorewall box ) and did the last update I realised that pftop is not working ( not shure if it worked before either )
Executing from the shell gives an error: > Error Reading status (DIOCGETSTATUS): Permission denied.
The permissions on the pf device are
ls -la /dev/pf
crw-rw----  1 root  proxy  0x4c May  9 20:36 /dev/pf
The program version is

Any clues / hints ?


Title: Re: pftop not working
Post by: AdSchellevis on May 10, 2015, 11:14:19 am

I had the same issue on my install, so it was easy to reproduce. It has something to do with the last base/kernel update which cleaned up a lot of non standard hooks.
Some ports although are build up to a specific kernel and need some structures to be the same but these dependencies are a bit tricky to catch. So after upgrade some programs have issues because of mismatch in base/kernel. 

We are working on a solution for new releases with base kernel impact, but solving this issue is fortunately quite simple.
Just run:

Code: [Select]
pkg install -f pftop

To reinstall the package again (same version, but build with current base/kernel) and it functions again.

Title: [SOLVED] pftop not working
Post by: fratotec on May 10, 2015, 04:09:28 pm
Great, many thanks,
the reinstall did it.