OPNsense Forum

Archive => 16.7 Legacy Series => Topic started by: VintageGeek on August 27, 2016, 08:58:10 pm

Title: [SOLVED] OPN sense 16.7 Installation Woes
Post by: VintageGeek on August 27, 2016, 08:58:10 pm
Just want to relay my experiences as they are similar to some others.

As background, I am using a lightweight PC with the following hardware in a residential setting:
AMD Athlon 5350 Quad Core APU 2.05GHZ AM1 Processor
GIGABYTE AM1M-S2H mATX AM1 Motherboard
2 x Intel Gigabit PCIe network cards
8GB DDR3-1600 RAM

It has been running pfSense for several months but I wanted to try OPNsense for comparison. I decided to use the 64 bit VGA installer and install from USB.

The first thing that happened is that my Windows 7 PC blue screened the moment the USB flash drive was burned. Unplugged the drive and rebooted. Plugged in the drive to flash again. Another blue screen. This was reproduced again. Bug in the Win7 USB drivers? Very odd.

Burned it again with a fresh download on Windows 10 and a fresh flash drive. No blue screen under Win10. Tried to boot it on the router PC but it instantly rebooted. Tried another PC with the same results. These systems both have USB3 ports but the flash drive is USB2 plugged into a USB2 port.

Tried the nano install to see if it would work. No reboot but it just sat there with a flashing cursor on a black screen. That was on the same 2 systems.

I had been looking through the forums for solutions for awhile and realized it might be the USB3 issue. That was when I decided to try the 16.1 release. It booted and installed fine. After running update a couple of times it seemed to update to 16.7. I'm not really sure of that because Lobby Dashboard is not working and there doesn't seem to be any other way of finding the current version.

Apart from those issues, it seems to be working fine.
Title: Re: OPN sense 16.7 Installation Woes
Post by: wurmloch on August 28, 2016, 12:49:40 am

Had the same BoD (blue screen of death) experience on Win7. Now I use a Win 8.1 notebook with rufus portable (or xubuntu with dd) to write the usb stick. Always a usb2 stick on a usb2 port, to be safe. The same on the target machine, I use usb2.

As your dashboard isn't working, I would not call it a successful installation, I would try again. So far I did some successful installations 16.7 on pc-engines apu1 (nano image to sd card) and apu2 (serial image to mSata ssd) boards as well as on 19" servers (vga image to sata hdd) with supermicro boards from usb stick or usb-dvd drive. On the apu I use a serial cable with usb2serial adapter and PuTTY to carry out the installation.

Don't give up :-)
Title: Re: OPN sense 16.7 Installation Woes
Post by: bobbythomas on August 28, 2016, 06:01:16 am

I haven't tried burning 16.7 but was able to burn 16.1 to usb on my MSI laptop with windows 7 without any issues. I was then able to install it on my intel NUC and everything was working for a while. But then I thought to virtualize the firewall on NUC and installed 16.7 on Proxmox. Had some issues couple of days back with the WAN link and the issues seems to be resolved.
Bobby Thomas

Sent from my ONE A2003 using Tapatalk

Title: Re: OPN sense 16.7 Installation Woes
Post by: VintageGeek on September 17, 2016, 05:22:36 pm
Lobby Dashboard is now working. Not sure what changed but that was the only outstanding issue here.

Thanks to everyone for their outstanding work on OPNsense. It resolves a couple of issues I had with PFsense. Good work. ;)