OPNsense Forum

Archive => 21.7 Legacy Series => Topic started by: JRC on May 13, 2022, 06:10:46 am

Title: [Solved] Unable to get to the WebUI, it just times out.
Post by: JRC on May 13, 2022, 06:10:46 am
It was working, then it stopped working, no changes were made on the opnSense box, the only thing that changes was the possible expiration of the self signed cert used for the webui, but I would expect that to give me a security error and not a time out. I get the same timeout when I try non-ssl traffic, but I believe that is to be expected.

As near as I can tell Lighttpd is running:

Code: [Select]
cat /var/log/lighttpd.log
Dec 21 18:24:06 OPNsense lighttpd[57191]: (server.c.2057) server stopped by UID = 0 PID = 64556
Dec 21 18:24:06 OPNsense lighttpd[44915]: (server.c.1551) server started (lighttpd/1.4.61)
Dec 21 18:34:33 OPNsense lighttpd[14335]: (server.c.1551) server started (lighttpd/1.4.61)
Dec 23 20:45:36 OPNsense lighttpd[14335]: (server.c.2057) server stopped by UID = 0 PID = 8414
Dec 23 20:45:36 OPNsense lighttpd[2156]: (server.c.1551) server started (lighttpd/1.4.61)
Feb 22 16:19:44 OPNsense lighttpd[8847]: (server.c.1551) server started (lighttpd/1.4.61)
May 12 20:21:31 OPNsense lighttpd[8847]: (server.c.2057) server stopped by UID = 0 PID = 24361
May 12 20:21:31 OPNsense lighttpd[30999]: (server.c.1551) server started (lighttpd/1.4.61)
May 12 20:33:02 OPNsense lighttpd[30999]: (server.c.2057) server stopped by UID = 0 PID = 1781
May 12 20:33:02 OPNsense lighttpd[14785]: (server.c.1551) server started (lighttpd/1.4.61)
May 12 20:40:55 OPNsense lighttpd[14785]: (server.c.2057) server stopped by UID = 0 PID = 31149
May 12 20:40:55 OPNsense lighttpd[40665]: (server.c.1551) server started (lighttpd/1.4.61)
May 12 20:55:12 OPNsense lighttpd[60294]: (server.c.2057) server stopped by UID = 0 PID = 96360
May 12 20:55:12 OPNsense lighttpd[8095]: (server.c.1551) server started (lighttpd/1.4.63)
May 12 21:02:27 OPNsense lighttpd[75562]: (server.c.1551) server started (lighttpd/1.4.63)

Code: [Select]
ps aux | grep light
root          75562    0.0  0.0   17684    6824  -  S    21:02    0:00.01 /usr/local/sbin/lighttpd -f /var/etc/lighty-webConfigurator.conf
root          15614    0.0  0.0 1060888    3116  0  R+   21:07    0:00.00 grep light

I tried restarting lighttpd
Code: [Select]
configctl webgui restart
and when that did not work I ran:
Code: [Select]
configctl webgui restart renew
curl also times out, on from the local cli on the opnsense box aswell:

Code: [Select]

*** OPNsense.domain.tld: OPNsense 21.7.8 (amd64/OpenSSL) ***

 LAN (lagg0)     -> v4: <lan_ip>/24
 WAN (bce3)      -> v4/DHCP4: <public_ip>/23

curl https://<lan_ip>

curl: (28) Failed to connect to port 443 after 75018 ms: Operation timed out

Not sure where to go from here. So any help would be greatly appreciated.

I am running 21.7.8, and plan to go to 22 as soon as I can get this fixed. Oh, and I can ssh in just fine, form a machine that has a firewall rule that allows all traffic to get to the opnsense box itself (again, this was all working not too long ago, before the cert expired).
Title: Re: Unable to get to the WebUI, it just times out.
Post by: JRC on May 13, 2022, 06:25:03 am
Well it turns out that I was using the wrong port (443) instead of 8443. I found this out by going into the /conf/config.xml file, then locating the webui section and seeing what it was set to there.

It works now, with the expired cert and all.

Going to leave this here rather than deleting it. Hopefully it'll help someone in the future.