OPNsense Forum

Archive => 19.7 Legacy Series => Topic started by: Yolo on November 26, 2019, 07:56:58 pm

Title: Solved - Zotac CI329 Nano - Error 19 during installation
Post by: Yolo on November 26, 2019, 07:56:58 pm
** I fixed the issue, see below for the steps **

Not sure if the his the correct subforum, let me know I need to post this in a sub. Also posted this in the Dutch subforum.

I am trying to install Opnsense 19.7 on a Zotac CI329 Nano (https://www.zotac.com/us/product/mini_pcs/ci329-nano). Whatever I tried, I get a error 19 during the installation and end up in mountroot. I tried installing Pfsense and FreeNAS: same error. Tried installing Ubuntu 18.4.3: worked flawless the first time installing it. No problems what so ever. What I've tried so far:

1. Multiple USB sticks to rule out that 1 might be broken (even bought a new one from the store)
2. Setting set kern.cam.boot_delay="10000" or set kern.cam.boot_delay="30000" through option 3
3. Setting hw.sdhci.enable_msi=0, hint.sdhci_pci.0.disabled=1, hint.sdhci_pci.1.disabled=1 through option 3
4. Turned legacy boot on, AHCI turned on and UEFI off.
5. Tried installing 18.7, same error
6. Updated BIOS to latest version and retried all the steps mentioned above.
7. Also tried to boot from a SD card, same results.
8. Booted an USB 2.0 stick from the USB 2.0 port. Same error.

USB-sticks have been created using Rufus or physdiskwrite (as recommended on the site).

Does anyone have any tips on how to troubleshoot this further? Or solutions to use?  Maybe version 17 would work and the upgrade from there? (however, I can't find it anywhere as a download). Haven't found a way to get all the crashlogs to the USB-stick. I am about to pull out all my hair and send this box back...

** I fixed the issue**

What I did was the following:

0. Keep in mind that I updated the BIOS the version that was available on the 30th of November 2019.
1. Reset the bios to the default settings.
2. Enable legacy boot, disable UEFI boot
3. Define the internal harddrive as an SSD instead of harddrive (in the devices menu)
4. Created a live-cd/usb with gparted on it. Threw away all the partition present on the hard dive and set a new MBR (type msdos). Save and exit.
5. Went to the store, got a USB 2.0 flash drive.
6. Downloaded OPNsense-19.7-OpenSSL-vga-amd64, extracted it and "burned" it to the flash drive with Rufus.
7. Put the USB 2.0 flash drive in the single USB 2.0 slot on the back of the device.
8. Boot the machine.
8.1 Pray to Terminus (https://en.wikipedia.org/wiki/Terminus_(god)) or Chenghuangshen (https://en.wikipedia.org/wiki/City_God_(China)) that this will work.
9. Profit! The machine boots correctly and I can install Opnsense.
Title: Re: Zotac CI329 Nano - Error 19 during installation
Post by: Yolo on November 30, 2019, 12:36:05 pm
Added screenshots to show the actual errors:

Title: Re: Zotac CI329 Nano - Error 19 during installation
Post by: Alphabet Soup on December 02, 2019, 01:50:46 am
You've hit everything I would have thought to try.  For me, your #8 has usually been the one that gets it working... puzzled that didn't solve it for you.  Might be something about the Nano image.  Is there a reason you're using the Nano image instead of a regular VGA or Serial image?  Maybe somebody else spots something you've missed.

Probably not much help, but I use Etcher (https://www.balena.io/etcher/ (https://www.balena.io/etcher/)) to write the images to media.
Title: Re: Zotac CI329 Nano - Error 19 during installation
Post by: opnfwb on December 02, 2019, 03:32:39 am
The error messages mention OPNsense Nano. Are you able to duplicate these same errors when using the full version of OPNsense and booting that off of a USB stick?