OPNsense Forum

Archive => 18.7 Legacy Series => Topic started by: ipa_net_engineer on January 23, 2019, 03:17:04 pm

Title: Problem with FRR plugin
Post by: ipa_net_engineer on January 23, 2019, 03:17:04 pm
I'm new to opensense and have come across an issue. I tried searching on google and in the forums but haven't really found anything matching this.

I've been using OPNSense to test ZeroTier coupled with Free Range Routing to create some underlay networks for eBGP peering across global data centers as well as create a global remote worker network.

Everything worked pretty well and I got ZT and FRR working the way I wanted with iBGP peering into the DC route reflector and advertising the ZT networks.

When I went to reboot the VM, I came across an error with the FRR plugin and can't boot OPNSense now.

I have two questions

1. How do I disable the FRR plugin from the command line to continue the boot and workaround
2. What seems to be the issue with this error between OPNSense and FRR.

 Thanks and sorry for the screenshoot vs. text. - was having issues copying text from the Hypervisor console.
Title: Re: Problem with FRR plugin
Post by: fabian on January 23, 2019, 05:56:37 pm
1) For a quick workaround, your can delete the file mentioned in the second line (the frr.inc using the rm command). When you delete it, it may break OSPFv2 and it is not available in the service widget anymore.

From the error I guess you are using an outdated or defect OPNsense core package but I cannot tell for sure - Ad Schellevis changed many lines some time ago:

Can you add the versions you are using (OPNsense core, os-frr)?