OPNsense Forum

Archive => 18.7 Legacy Series => Topic started by: ThePOO on October 19, 2018, 11:15:59 pm

Title: {SOLVED} What could be using all my memory?
Post by: ThePOO on October 19, 2018, 11:15:59 pm
3953 MB RAM capacity.

18.7.4 RAM use was around 908 MB.

18.7.5 was applied and my RAM use jumped up to 3772.

18.7.5_1 was applied and high use of RAM continues ,  97% used.
Swap file 99% used.   tmpfs at 99%

After a short time the box locks up.    After a hard reset OPNsense takes about five minutes to come up then locks up again after a short time.

I get little time to troubleshoot ... any pointers would be appreciated, thanks?

UPDATE:    Here is what worked for me ....
I reset OPNsense to factory settings -- then I restored the configuration saved previously.
After the restoration I had to attend to another issue and about 30 minutes later returned.   Success!
It all works and my memory use is at 696 MB (17%), 0% swap use., 1% tmpfs

Wish I knew what was eating all the memory?   But reset/restore worked like a champ!   Me So Happy!
Title: Re: {SOLVED} What could be using all my memory?
Post by: weust on October 20, 2018, 11:06:23 am
You don't give a lot of information to work with.
What services do you have enabled, and with what settings?
Title: Re: {SOLVED} What could be using all my memory?
Post by: ThePOO on October 20, 2018, 04:40:36 pm
Sorry I wasn't more informative in my original post.     There just wasn't much time between crashes to collect anything meaningful.     And, I had to go look into another problem that was happening at the same time, elsewhere.
I was just looking for the possibility that someone else had a similar circumstance and a quick fix.
While fixing the other pressing issue, I thought about my game plan to fix OPNsense.     -- reset to factory settings -- restore my configuration.      And that saved my bacon, this time.      I tried that once, in past, and it failed miserably and I ended up doing all my configuration, from scratch, over again --- long ago and with pfSense, not with OPNsense.

Everything is up, and is performing EXTREMELY well today, no issues at all.

HEY!    Thanks for commenting, I truly do appreciate your taking the time to show interest.

I have no idea why my OPNsense went nuts.      My approach to fixing this, this time, because of circumstance --- rip off the bandaid, pour alcohol all over it, and see it I stay conscientious.      It worked out ok, this time.

Again, thanks for your response.