Archive > 15.7 Legacy Series

[SOLVED] Need help allowing FreeNAS/Jails access through firewall

(1/2) > >>

Hello All,

I've just started using OPNSense a few days ago.  I built my OPNSense box out of left over parts that I had lying around after years of building my own computers.  This box has an Intel Pentium Dual Core G3220 cpu, 8GB RAM, 60GB SSD, and an Intel Pro 1000 PT dual port server adapter.  My network is fairly simple.  I have a Motorola SurfBoard cable modem > OPNSense Router/Firewall > MikroTek 10 port switch.  I have a D-Link 860L Wireless AC1200 router in AP mode and 4 other devices (PC's/TV's) connect via 1 gig ports on the switch, and a FreeNAS box connected using one of the 10 gig SFP+ uplinks.

My problem is that FreeNAS and 7 of the 9 jails I have running have no access to the internet while all my other devices don't seem to be having any problems connecting.  I do have UPnP enabled on OPNSense.  The jails running transmission and emby media server are utilizing UPnP and are the only ones that have access to the internet.  I've setup port forwarding for all the other jails and confirmed that the ports are open using Open Port Check Tool but I still can't access them from outside the LAN and FreeNAS itself can't access the update server.  I have FreeNAS and all the jails on static IP's and I've checked the firewall log to see if they are being blocked.  I've added rules to pass the traffic on anything I see in the log that I recognize but I'm having no luck figuring this out. 

I'm also having some performance issues with my internet speed that is a separate issue probably unrelated to this after installing the new router.  My desktop PC is getting about 40 Mbps down/1 Mbps up but my laptop is getting 120 Mbps/12Mbps over wifi which is completely opposite from what I would expect.

I would appreciate any help in resolving these issue. Thanks in advance.

Hi knight,

what kind of LAN settings do you use? Static/dynamic/dynamic served from somewhere else? IPv4 or IPv6?

The fact that UPnP devices figure out their routes is a good hint that the base setup has a little quirk for less-adaptive setups like your FreeNAS and the other jails.

Maybe you can give these a quick run on the FreeNAS:

# route get
# ping


My WAN is setup as DHCP and the LAN is static @  I discovered today that my OwnCloud jail is accessible through web browser from my office so that seems to be working.  The main offenders seem to be FreeNAS itself and the plex media server installation. 

I ran the commands you suggested.  I've attached the output.

Default route is set, DNS lookup isn't working though. Does this work?

# ping

Where does the FreeNAS IP come from, also static? If yes, there needs to be an entry in /etc/resolv.conf for which name server to use.

I double checked my network setting on FreeNAS and my name servers where erased.  Something I should of thought to check.  Anyway, FreeNAS is able to reach the update server now.  I just need to figure out why remote access to Plex doesn't work.  I've been checking the Plex forum's and some have mention something about Plex and FreeNAS not using jumbo frames and MTU should be set 1500.  I haven't had a chance to test it yet though. 

Thanks for the help. 


[0] Message Index

[#] Next page

Go to full version