Quote/usr/src/sys/dev/pci/pci_host_generic_fdt.c:122:2: error: call to undeclared function 'ofw_bus_destroy_iinfo'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
122 | ofw_bus_destroy_iinfo(&sc->pci_iinfo);
| ^
/usr/src/sys/dev/pci/pci_host_generic_fdt.c:122:2: note: did you mean 'ofw_bus_setup_iinfo'?
/usr/src/sys/dev/ofw/ofw_bus_subr.h:88:6: note: 'ofw_bus_setup_iinfo' declared here
88 | void ofw_bus_setup_iinfo(phandle_t, struct ofw_bus_iinfo *, int);
| ^
1 error generated.
--- pci_host_generic_fdt.o ---
*** [pci_host_generic_fdt.o] Error code 1
make[2]: stopped making "all" in /usr/obj/usr/src/arm64.aarch64/sys/SMP-ARM
Quote from: nero355 on October 03, 2026, 08:36:21 PMIs Multicast DNS allowed on the WiFi Bridge ?!
Perhaps disable IGMP Snooping tuneable or something like that ?
Quote from: suur13 on October 03, 2026, 02:50:39 PMIf I connect iPhone to Wifi via Opnsense box own WLAN interface I can not reach BubbleUPnP.Is Multicast DNS allowed on the WiFi Bridge ?!
Quote from: Schwermzilla on October 03, 2026, 12:30:33 AMYou got it! memes be praised, it was DNS.LOL! NICE! ^_^
Following your thoughts, I was able to connect with a static ip on my laptop, received a DNS error trying to access any website. So I just deleted both DNS setups and reservations, and rebuilt/re-enabled everything in DNSmasq and it worked! So I clearly fumbled something in the DNS settings on my first... many attempts.
I will figure out how to mark this as Resolved!
Thanks again!
Quote from: lmoore on October 03, 2026, 02:42:59 AMIt doesn't appear that mail is installed in OPNsense by default, at least not on mine. There is nothing in /etc/mail and no sendmail program.Makes sense I guess and the documentation seems to confirm it : https://docs.opnsense.org/manual/how-tos/mailgateway.html#postfix
QuoteNICE! :)Quote from: nero355 on October 02, 2026, 11:09:49 PMBut how about adding .conf filesI have done this with Unbound - after reading the documentation. Your mileage may vary for other services, depending on how OPNsense configures them. However, it's best they are managed using an applicable plug-in.
[Edit] Of course, such custom settings wont be included in a back-up.
OPNsense Web GUI for Unbound lets me know there is a configuration which could possibly overwrite settings in the Web GUI.
Quote from: putt1ck on October 03, 2026, 12:32:15 PMNow I'm nervous we've been wasting effort - we have several deployed systems where we've customised the rspamd plugin configuration to enable DKIM,as per this post:It seems to be supported according to : https://docs.opnsense.org/manual/how-tos/mailgateway.html#rspamd
https://forum.opnsense.org/index.php?topic=20280.msg270642#msg270642
- is there a risk that configuration work will be lost on the next service/firewall restart?
Quote from: putt1ck on October 03, 2026, 06:49:57 AMWhile we're comfortable making Postfix work via conf it would seem that shouldn't be using a plugin on the firewall and we should have a separate VM to act as the relay for mail.:)
Quote from: viragomann on January 19, 2026, 09:05:20 PMDid you add proper firewall rules to the interfaces to permit UPnP?
In addition to the access to the other LAN devices, it's also required pass the UPnP multicasts to the other interface.