OPNsense Forum

Archive => 18.7 Legacy Series => Topic started by: Calypso on September 21, 2018, 08:34:49 am

Title: Slow response of HAProxy on 18.7
Post by: Calypso on September 21, 2018, 08:34:49 am
Something strange happened after upgrading OPNSense to 18.7 (coming from 18.1.13). I've upgrade to 18.7.1, then to .2 and .3. Everything is working fine, except when I access a site that's using HAProxy (just plain HTTP traffic, no HTTPS) it stalles for quite some time (variable) before actually starting to transfer the information.

Sometimes it goes just as expected (fast), but the delay doesn't seem to be fixed. When looking at the logs in the backend server, no request is made in the time that the transfer is stalled.

I've already tried to delete all entries in the haproxy configuration and started anew, but it still happens. I use DNSMasq for DNS (that kind of unpredictable delays always triggers "DNS problems" for me in some way) but that is working without an issue.

Tried it on 2 machines - 1 hardware and 1 on vmWare - and it happens at both. When going back (through a snapshot on vmWare) it's gone and hosted sites are always fast again. Both machines have multiple WAN IP's, and if I use a NAT port forward on it to the backend server, ofcourse there is not problem.

Where I suspected HAProxy in the first few weeks, I'm now not convinced it's a HAProxy problem but something else (like DNS), but haven't got a clue where to search for it... Does someone have any ideas?