OPNsense Forum

Archive => 18.1 Legacy Series => Topic started by: sk on May 09, 2018, 02:14:07 pm

Title: Booting issue on a HP T610 thin client [SOLVED]
Post by: sk on May 09, 2018, 02:14:07 pm
Hello all

I am trying to get OPNSense 18.1.7_1-amd64 running on a HP Thin Client T610 with 4GB RAM. I have added another intel ethernet on the PCIe slot, and a HDD (80GB SATA) on the system.

Details of the system
OPNsense 18.1.7_1-amd64
FreeBSD 11.1-RELEASE-p9
OpenSSL 1.0.2o 27 Mar 2018
CPU Type    AMD G-T56N Processor (1 cores)

The problem is, if I let the system boot on its own, it gets stuck at a very early stage. But if I select Safe mode, it boots without any issue. In fact, with Safe mode it boots to the firewall completely and gives the music-notes indicating it is up and running. I tried single user, but it seems to be getting stuck at the same place as regular startup.

The last two lines when it gets stuck is
Code: [Select]
cryptosoft0: <software crypto> on motherboard
acpi0: <HPQOEM SLIC-BPC> on motherboard
(screenshot available at https://paste.pics/32S7Q)

when it goes through, the next few lines are
Code: [Select]
cryptosoft0: <software crypto> on motherboard
acpi0: <HPQOEM SLIC-BPC> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 550
Event timer "HPET1" frequency 14318180 Hz quality 450
Event timer "HPET2" frequency 14318180 Hz quality 450
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0

(complete dmesg available at https://pastebin.com/rXb3CrmN)

I am very much confused as to what might be the cause for this -- given that I cannot seem to notice anything unusual that should stop the booting from carrying on (I left it for several hours, just to make sure it is truly stuck).

Any support / suggestion / pointer to help the booting and functioning this system is greatly appreciated.

Thanks and regards

Title: Re: Booting issue on a HP T610 thin client
Post by: dmberry on May 09, 2018, 07:31:13 pm
I have the exact same issue with the HP T610,

It may be some issue with Free BSD11.x, I've seen some posts around the web about issues with the T610 and BSD 11.x

When I was troubleshooting I did manage to get PFSense 2.3x to load which is based on FreeBSD 10.x but for now I've gone back to running Opnsense 18.1 on my ALIX board.

If anyone needs any debugging or testing on this let me know as the T610 is just acting as a book end at the moment.

Would be good to get this running on the T610 as it could be a great little device for SOHO as they can be picked up quite cheaply on ebay.
Title: Re: Booting issue on a HP T610 thin client
Post by: dmberry on May 09, 2018, 07:37:06 pm
Oh also found this today :


Going to give the 32 bit installer a shot.
Title: Re: Booting issue on a HP T610 thin client
Post by: dmberry on May 09, 2018, 08:08:08 pm
So using the 32bit installer I've managed to get it to install 18.1.6 on the T610
Title: Re: Booting issue on a HP T610 thin client
Post by: sk on May 09, 2018, 09:10:29 pm
thanks to everyone for responses.

Could you please confirm that the system boots using the 32bit installer and gives you the fully functional firewall without having to modify anything? Did you manage to identify what was causing the deadlock at that point of booting?

Personally, I will not be pleased if I have to use 32bit OS when the system is capable of 64 bit and I intend to run it with 8GB RAM anyway. But if that is the *only* way forward, maybe I will either have to wait or keep on requesting for a possible solution.

Thanks and regards
Title: Re: Booting issue on a HP T610 thin client
Post by: dmberry on May 10, 2018, 08:27:45 am

System boots and and I have run the installer and configured a base system using the 32bit installer media, so it does seem to be some issue / incompatibility with CPU & FreeBSD 11.x x64.

For me it's not the end of the world running it in 32bit mode with 4GB of RAM.  I grabbed it on ebay as a cheap  alternative to replacing my ageing alix2d3 (1x500Mhz CPU256MB Ram) with a PC Engines APU2c4 (4x1Ghz CPU 4GB)

The old Alix2D3 with OpnSense 18.1 works fine as a basic FW/Router for a 80/20 VDSL Connection, but is very slow when navigating around the UI, so this will be more than enough for my needs without the expense of getting a new APU2 board.

It looks to be pulling about 22W of power when in use with an additional PCI-E single port nic and a 16GB SSD. Compared to the APU2 which uses about 6w the 16w of extra electricity usage means it's cheaper buy a T610 2nd hand and run it for 5-7 years before the APU2 would break even TCO.

Title: Re: Booting issue on a HP T610 thin client [solved]
Post by: sk on May 10, 2018, 11:41:28 am

Yes, it does make sense, and I too am trying to replace an alix (the home broadband has become too much for the old board :D), and am using a quad port intel card to create different networks for my pi-farm, wi-fi guests, wi-fi home users and my other bits and bobs. Also, I have good news :D (I think) -- please read on.


Since the system was booting in "Safe mode" (and all the fun comments I have come across regarding the allusion to the same term used in a well known OS  :P ), I decided to venture that path a bit more. After much googling, a site pointed me to https://github.com/lattera/freebsd/blob/master/sys/boot/forth/menu-commands.4th where I found the relevant section for "safe mode"
Code: [Select]
: safemode_enable ( -- )
s" set kern.smp.disabled=1" evaluate
s" set hw.ata.ata_dma=0" evaluate
s" set hw.ata.atapi_dma=0" evaluate
s" set hw.ata.wc=0" evaluate
s" set hw.eisa_slots=0" evaluate
s" set kern.eventtimer.periodic=1" evaluate
        s" set kern.geom.part.check_integrity=0" evaluate

So I created a /boot/loader.conf.local file, containing
Code: [Select]

and the system seem to be working quite happy so far. Rebooted 3 times (once was pulling the plug, the other two were from console and shell) -- it is still booting OK and I have not observed any problem with its functioning so far. If something is wrong, maybe it is waiting for the opportuned moment to surface, but for now I consider this to be a step forward. Time to configure and put it into test bed to see how things go.

If anyone could please shed any light if I am doing something wrong in terms of firewall / OPNSense functionality by using the above method, would appreciate if you could please point me to the correct direction.

Thanks to everyone once again for your input and suggestions.

Best regards
Title: Re: Booting issue on a HP T610 thin client [SOLVED]
Post by: potes on December 18, 2018, 08:58:53 am
Hi everyone,

First of all say that I'm a newbie and I'm on my first opnsense/freebsd install, but as I was able to solve the issue I thought it was a good way to share with all of you.
I have also a HP thin Client 610 plus and I'm installing opnsense on it, I want 64bit with 8Gb.

When I start installing it I got the same error that appear here (is how I found this post). Initially I use the "safe mode" trick to be able to start the machine, but with only one core I was no happy. After reading some other post with similar errors (like disable acpi.... DON'T DO IT...), I start playing around with diferent option on the HP BIOS, and finally found the way to start 64 bits opnsense without any special configuration at boot level.

At HP BIOS, on boot order, we only have to disable all devices under EFI and use instead Legacy, and it works perfectly. I have to disabble it two times, the fisrt time when I boot the installer via USB and a second time on the first boot after the install. I don't know why, the the EFI mode was enable again on the SSD that I install opnsense.

Wish this help someone.