OPNsense Forum

Archive => 18.1 Legacy Series => Topic started by: jtk174 on March 29, 2018, 09:49:18 pm

Title: pppoe password
Post by: jtk174 on March 29, 2018, 09:49:18 pm
Just been running opnsense 18.1.4-amd64 for a few weeks, so this is pretty new to me.

Had been having some speed issues ( not opnsense related ) and had gone to the BT wholesale speedchecker @ http://www.speedtest.btwholesale.com/
As some issues were identified, it requested that if I wanted to do further testing, I would have to change my connection point temporarily, in order to run the tests.
However, when I went to change my pppoe settings, opnsense insists on a password being entered. As no password is required for the BT connection I could not proceed.
Anything I can do ?
Title: Re: pppoe password
Post by: elektroinside on March 29, 2018, 10:35:48 pm
You could open a ticket here to get rid of the mandatory password check for PPPoE links:

It's the first time I ever heard of a passwordless PPPoE link. This setup might not be that popular and so the bug (or missing feature) might not get a high priority. But the devs will know better :-)
Title: Re: pppoe password
Post by: jtk174 on March 30, 2018, 12:22:10 pm
Many thanks for your reply.
I will give it a go  :)
Title: Re: pppoe password
Post by: marjohn56 on March 30, 2018, 01:10:35 pm
@elektroinside - You do need a username/password to connect to the BTOR network, these used to be

Username: bthomehub@btbroadband.com
Password: <blank or anything>
VLAN: 101
VPI: 1

@jtk174 - Can you post of screen grab of that page from the BTOR  website, I think it may be referring to using the test socket.
Title: Re: pppoe password
Post by: elektroinside on March 30, 2018, 05:05:15 pm
Oh, ok. Maybe he could try with any password, just to confirm it works :)
Title: Re: pppoe password
Post by: jtk174 on March 31, 2018, 03:26:12 pm
I will try to attach a screenshot of the page that caused me the problem. However, I contacted BT first and they said to try either bt or BT. I tried bt first and that appeared to connect, giving me an address on the wan interface in the 172.20 range. The test would still not run, after I unticked the relevant box in wan interface settings.
Around the same time I was contemplating trying mobile broadband and this is now what I intend to do.
My BT down was 18Mb and 1Mb in the up.
My tests with the mobile broadband were 69Mb Down and 21Mb Up. As a result, I have decided not to waste any more time and get the mobile broadband setup. I'm still under contract with BT for about 6 weeks, so perhaps I can try a multi wan config. On the other hand I might just go and clear the crap out of my garage  :)

Thanks for the replies folks. Its good to see an active community here.