OPNsense Forum

Archive => 18.1 Legacy Series => Topic started by: visualstation on February 15, 2018, 10:43:14 am

Title: Error when installing package after upgrade from 17.7.x to 18.1
Post by: visualstation on February 15, 2018, 10:43:14 am
Hello Franco,
Hello team,

I did 1 hour ago, an upgrade from 17.7.x to 18.1.
The upgrade as successful, but an error message is showed since the upgrade when I'm installing new plugins.

Quote
Fatal error: Uncaught Error: Call to undefined function get_interface_ip() in /usr/local/etc/inc/system.inc:761
Stack trace:
#0 /usr/local/etc/rc.configure_plugins(39): system_syslogd_start(true)
#1 {main}
  thrown in /usr/local/etc/inc/system.inc on line 761

A report has been sent via the firewall.

Platform: APU 2C4 + mSATA SSD
Version: x64
Title: Re: Error when installing package after upgrade from 17.7.x to 18.1
Post by: franco on February 15, 2018, 02:25:04 pm
Hi,

Thanks, this should do the trick: https://github.com/opnsense/core/commit/b85cd97da

# opnsense-patch b85cd97da


Cheers,
Franco
Title: Re: Error when installing package after upgrade from 17.7.x to 18.1
Post by: Evil_Sense on February 15, 2018, 10:50:27 pm
Patch works flawlessly, no error on installing and uninstalling plugins anymore :)