OPNsense Forum

English Forums => Hardware and Performance => Topic started by: ktk on January 20, 2018, 11:20:50 am

Title: [HOWTO] Installing 17.7 (and probably above) on APU2/APU3 boards & SD card
Post by: ktk on January 20, 2018, 11:20:50 am
It looks like there are some issues with installing current OPNsense on PC Engines APU2/APU3 boards on an SD card so I thought I will summarize what worked and what doesn't so others can save some time.

What does NOT work: I first tried to dd the NANO image directly to the SD card. While it does boot it screws up on the next reboot. As soon as I rebooted with a proper configuration I got tons of READ errors from the SD card very early in the boot process. Apparently something goes wrong with the disk layout and breaks the install.

This process was how I did it the past years since I started on PFsense and I guess many were used to this. It did work with OPNsense as well until recently.

How to install:

That's it, like this I did not had any problems booting from SD card anymore. Hope this works for everyone.
Title: Re: [HOWTO] Installing 17.7 (and probably above) on APU2/APU3 boards & SD card
Post by: namezero111111 on January 21, 2018, 02:00:17 pm
I'd like to add that the following works for the Alix series, which is incapable of booting off of USB:

1. Start a VM (I used VirtualBox) with the installer ISO (i386) and CF Card (via reader) attached
2. Do a normal install by logging in with user installer/opnsense
3. Ensure Alix LBA mode is activated in BIOS (press 's' during memory count)
4. It'll boot off the CF card.
   - Note: The Output dies after the boot selector, but the machine is actually booting!
   - Be very patient, it will eventually come up after 5-10 min at the latest
   - Log in to the WebGUI and
      a. Configure the console output to serial again System: Settings: Administration
      b. Enable ramdisk fro /tmp and /var under System: Settings: Miscellaneous
I used this successfully with:
Alix 2D3, BIOS 0.99m
4GB Transcend CF
OPNsense 18.1 R1
Title: Re: [HOWTO] Installing 17.7 (and probably above) on APU2/APU3 boards & SD card
Post by: terrajbbq on April 01, 2018, 04:34:32 pm
In my case, on an APU board, the initial boot after "dd"-ing the nano image to the SD card worked fine. I had it running for a few weeks but encountered a problem that I figured a reboot might solve. It didn't boot. Attaching a serial cable would display messages about USB transmission failing, and some timeouts (I don't have the exact messages any more).

Initially I thought it was related to the bootdelay, so I tried installing the package to add that after a fresh install but the same problem happened. The only results I found when searching seemed to suggest bootdelay or AHCI related issues - I actually only found this thread after it was mentioned on Twitter!

A friend suggested using the installer rather than "dd"-ing the image.

What I did was similar to ktk, with a few slight differences:
1. Blank the SD card first (dd from /dev/zero to it) - installation failed when I didn't do this
2. "dd" the nano image onto a USB stick
3. Attach serial cable
4. Insert USB stick and boot up
5. Log in as the root user and go to the shell
6. Run "opnsense-installer"
7. Proceed with the installation (guided with GPT/UEFI)
8. After installation, remove USB stick and reboot

As an extra precaution, after I'd verified that it booted correctly I shut down, took out the card and used "dd" to make an image of the working SD card (compressing it after). I'm also making sure I periodically back up the settings now!
Title: Re: [HOWTO] Installing 17.7 (and probably above) on APU2/APU3 boards & SD card
Post by: harrypnyce on March 28, 2021, 03:31:16 am
I've got a much older AMD Sempron 145 and have struggled immensely trying to get this running again.  18.1 worked once upon a time, until I finally borked it attempting and in-place upgrade from 18.1 -> 18.7 and during the next upgrade path (i believe to 19.x) everything went to hell and now I'm no longer able to boot the machine at all, as it continually locks up before I'm presented with the menu or login prompt.  I've also tried to boot from USB sticks with 20.1 & 21.1 off of three separate brands of USB flash drive (16GB Lexar, 32GB SanDisk & 8GB off-brand generic), however I'd been attempting the VGA image.  I guess I'll start the AMD64 serial image downloading.  On my very last attempt I directly installed the
Code: [Select]
OPNsense-21.1-OpenSSL-vga-amd64.img to a 500GB HDD, but that also fails with the following: (https://i.imgur.com/P6f5yMh.png)

This is the hardware I have successfully used in the past with OPNsense v17.x & 18.1: https://www.cnet.com/products/emachines-el1352g-01w-sempron-145-2-8-ghz-2-gb-500-gb/ (https://www.cnet.com/products/emachines-el1352g-01w-sempron-145-2-8-ghz-2-gb-500-gb/).

I'm open to suggestion, my FreeBSD abilities are obviously not great, but I'm been banging my head against the wall not knowing what searches to even proceed with for days and days now.  Thank you to anyone who may be able to nudge me in the proper direction.  Should I revert to a legacy version?  Or find new hardware that's better than a 10+ year old single-core CPU with 2GB of RAM?  Was hoping to turn this into a basic router capable of doing 100Mbps.