OPNsense Forum

Archive => 17.7 Legacy Series => Topic started by: Mathieu on August 06, 2017, 06:38:32 pm

Title: OPNsense 17.7 on SD card in the PC Engines APU3B4
Post by: Mathieu on August 06, 2017, 06:38:32 pm
I tried to get OPNsense 17.7 (OPNsense-17.7-OpenSSL-nano-amd64.img.bz2) installed and working on an 8GB SD card in an APU3B4 (http://pcengines.ch/apu3b4.htm) from PC Engines. But no luck, it fails each times.

First, deploying the image on the SD card from any GNU/Linux computer around:
Code: [Select]
bzip2 -dc OPNsense-17.7-OpenSSL-nano-amd64.img.bz2 | pv | sudo dd of=/dev/mmcblk0 bs=1M
This works, and the APU does boot[1] on the SD card. But it success to boot only the first time!

If you try to reboot, then the boot fails with C a n n o t  f i n d  ' k e r n e l ' error.

Too bad, because, of course, the first time I get it to boot I started to configure everything... to finally loose all after a reboot.  :'(

I tried to add the line kern.cam.boot_delay="10000" (with and without quotes) in /boot/loader.conf.local as suggested in Install pfSense nanobsd 2.0 to thumb drive (https://doc.pfsense.org/index.php/Install_pfSense_nanobsd_2.0_to_thumb_drive), but it did not helped.

I also tried to boot on an USB key (with the same image), and from there to proceed to opnsense-installer on the SD card. But no more luck: I got lot of path not found errors while trying to partition the SD card.

For information, with pfSense-CE-2.3.4-RELEASE-4g-amd64-nanobsd.img.gz it does works perfectly (even the console garbage described in [1]) with the SD card, and installation eventually failed.

[1] There is only the problem of the characters being echoed as garbage on the console, but it's only during the boot:

   o o
      a a
         d d
            i i
               n n
                  g g

                     / /
                        b b
                           o o
                              o o
                                 t t

It never gets newline, so it's quite hard (but not impossible) to read
Title: Re: OPNsense 17.7 on SD card in the PC Engines APU3B4
Post by: franco on August 06, 2017, 07:59:06 pm
Please don't get me wrong. There are surely issues in FreeBSD 11.0. It's unfortunate, but it's not our focus to start working on the operating system unless we know what patches we are looking for (help from the community).

pfSense 2.3.4 has FreeBSD 10.3, which luckily doesn't have this boot issue. As far as I know the Nano images are end of life so the upcoming 2.4 will likely not be what you are looking for, too.

So the question is: who is willing to help pin this down, research and write patches for new APU board's compatibility in FreeBSD? We all do our fair share in advancing the project, but we just can advance everything all the time in all directions at once. :)

Title: Re: OPNsense 17.7 on SD card in the PC Engines APU3B4
Post by: doublea666 on August 07, 2017, 06:18:05 am
Hello Everybody,

i have something similar, and thought first my APU apu2c4 Board has an hardware problem. It boots fine and reaching starting webgui it restarts and then my console looks like the post above, comes to a point with slashes and blue background. From this point console output stops but booting somehow continues and then after a minute or so the webgui is available.

Greetings Andreas
Title: Re: OPNsense 17.7 on SD card in the PC Engines APU3B4
Post by: tillsense on September 25, 2017, 08:20:37 pm
For the apu3 (nearly identical except for sim) the same> https://forum.opnsense.org/index.php?topic=6024.0