OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: BillySilver on July 01, 2017, 08:43:47 pm

Title: Upgraded to 17.1.8, now cryptic Fatal boot error
Post by: BillySilver on July 01, 2017, 08:43:47 pm
Just upgraded to 17.1.8, rebooted, and now I can't connect or login to my OPNsense VM instance. I can only interact with it through Vbox GUI, but it won't accept any of my logins. I suspect it has something to do with this output at the end of the boot sequence (see attached).

What the heck happened?? VirtualBox also said it had a driver issue and recommended I rebuild it with a specific command. I ran that command and it worked, and my other VM's work just fine. Even OPNsense seems to work fine as far as Vbox goes- it boots up and functions properly on the virtualization layer.

When I type any login name, it doesn't even prompt for a password, it just immediately says "Login incorrect".

-William
Title: Re: Upgraded to 17.1.8, now cryptic Fatal boot error
Post by: franco on July 04, 2017, 03:42:15 pm
PHP setup is missing, which prevented a bootup of the whole OPNsense code. :/

Is configd running?

# configctl template reload OPNsense/WebGui
# ls -lah /usr/local/etc/php.ini

Is PHP working now?  Try another reboot...

php.ini is never deleted, it could have been a UFS problem (file with no contents after boot)
Title: Re: Upgraded to 17.1.8, now cryptic Fatal boot error
Post by: BillySilver on July 04, 2017, 06:38:40 pm
Thanks for the help, but I just scrapped it and installed a new image on a new VM... I'll keep this in mind in case it happens again though.