OPNsense Forum

Archive => 15.1 Legacy Series => Topic started by: candrist on February 16, 2015, 12:48:48 am

Title: [SOLVED] Outbound NAT
Post by: candrist on February 16, 2015, 12:48:48 am
Brand new to OPNsense. Have been using m0n0wall for 10+ years.

I am trying to setup Outbound NAT for single computer on network, but it doesn't seem to work. I have it setup in hybrid mode and then add the rule for my specific ip and tell it to make it a static port.

Can someone tell me what I am doing wrong?

(http://dropbox.yeahmon.net/images/OutboundNAT.PNG)
Title: Re: Outbound NAT
Post by: Dominian on February 16, 2015, 02:55:51 pm
Hmmm if it's outbound NAT you have the source set to WAN... try changing that to LAN.
Title: Re: Outbound NAT
Post by: Dominian on February 16, 2015, 03:18:31 pm
I went back and rechecked what I said, you're right it should work, however I have no true way of testing this right now as I do not utilize custom outbound NAT rules at this time.
Title: Re: Outbound NAT
Post by: candrist on February 17, 2015, 12:58:34 am
Thanks for looking.
Title: Re: Outbound NAT
Post by: candrist on February 25, 2015, 12:08:24 am
I know this is not a feature that most people use. Is there any way to know if how I am setting this up is correct and this is a config issue or a bug in the software?
Title: Re: [SOLVED] Outbound NAT
Post by: candrist on February 25, 2015, 12:59:56 am
I ended up switching to Advanced Outbound NAT and defining all the rules for my network manually and it works now.

Hybrid did not work properly for me for some reason.
Title: Re: [SOLVED] Outbound NAT
Post by: weust on February 25, 2015, 08:01:50 am
For my PS4 I use Manual (what you end up using) and that worked for me since September last year.
Need the Static Port (no map in m0n0wall) for Type 2.
Title: Re: [SOLVED] Outbound NAT
Post by: Dominian on February 25, 2015, 02:38:45 pm
Just to go back over this, there's another forum post I'm on for testing of the libressl features.

I can tell you this much, when I roll back to using openssl, with no UPnP utilized, I did NOT have to do custom outbound NAT rules.

The basic NAT rules worked for me on Xbox.  I've since upgrading my firewall back to using libressl and rebooted.  I will be re-testing this tonight.