OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: dasmaeh on June 05, 2017, 01:11:18 pm

Title: IGMP-Proxy stops stream after 2 minutes
Post by: dasmaeh on June 05, 2017, 01:11:18 pm
I've more or less sucessfully set up IPTV on my kodi media center. However after 2 minutes of streaming the stream get's dropped by igmpproxy.
This seams to be related to IGMPv3 as the kodi plugin is using v3 (actually necessary to run German Telekom Entertain TV). Using the settop box provided by my ISP works though.
Stopping and restarting the proxy while the stream is stopped leads to restarting the stream and runs forever.

I'm pretty sure this is a bug in igmpproxy but want to confirm before filing a bug report. Any ideas, what to test?
Title: Re: IGMP-Proxy stops stream after 2 minutes
Post by: bringha on June 05, 2017, 02:06:56 pm
Hi dasmaeh,

this topic has been discussed already in several topics,
e.g. https://forum.opnsense.org/index.php?topic=4828.msg19080#msg19080 (https://forum.opnsense.org/index.php?topic=4828.msg19080#msg19080)

Still not functional also in my installation ....

Br br
Title: Re: IGMP-Proxy stops stream after 2 minutes
Post by: dasmaeh on June 05, 2017, 02:40:56 pm
I know that thread. But I'm not completely sure, igmpproxy really is the culprit. Using the box provided by my ISP works well with the same setup on opnsense / igmpproxy.

I've collected log files for both boxes but can't find any significant differences between both. Could someone with some experience in igmpproxy please have a look.

Kodi on a raspberry till the point the stream stops: log_raspmc

ISP box (1&1 MediaCenter), about same amount of time: log_1&1_mc

I just want to be sure, where the problem is and where to look for a solution.