OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: eptesicus on May 28, 2017, 10:50:27 pm

Title: OpenVPN Server - No WAN?
Post by: eptesicus on May 28, 2017, 10:50:27 pm
I have setup two VPN clients on my firewall using the method here: https://forum.opnsense.org/index.php?topic=4979.0 (https://forum.opnsense.org/index.php?topic=4979.0). This allows all of my traffic to be routed over VPN. One tunnel to the Netherlands for downloads, and another to the US east coast for normal traffic.

I also have a VPN server running on the firewall so that I can connect to my local network from outside the network. I have OpenVPN for Android on my phone that I want to use in order to connect to my home network when I'm off of my home wifi (using tasker to automatically connect VPN when I'm off of my wifi, and disconnect when I connect to my home wifi). The problem that I have now, is that I when I'm connect to the OpenVPN server on my firewall from my laptop or phone, I'm only able to access my local network, and traffic cannot access the WAN. What am I missing here? I also have an ad-block server on my network (pi-hole) that I want to ensure will work on the clients connecting to the VPN server. Below is my config.

OpenVPN Server Config
(http://i.imgur.com/MEOaEXN.png)



NAT Outbound Rules
(http://i.imgur.com/Y0s9KzL.png)
Title: Re: OpenVPN Server - No WAN?
Post by: eptesicus on May 31, 2017, 01:54:52 pm
Unchecking "Redirect Gateway" allows internet traffic to work, but I then lose the ability to access resources on the LAN.