OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: s4rs on April 10, 2017, 04:29:46 pm

Title: Can't upgrade from 17.1.3 to 17.1.4 [SOLVED]
Post by: s4rs on April 10, 2017, 04:29:46 pm
I am trying to upgrade from 17.1.3 to 17.1.4 but it gets stuck. I tried from the GUI and the console without success. From the GUI I see this

There are 38 updates available, total download size is none. This update requires a reboot.

Then I hit the Upgrade Now Button

and the log shows

Code: [Select]
***GOT REQUEST TO UPGRADE: all***
Updating OPNsense repository catalogue...
OPNsense repository is up-to-date.
All repositories are up-to-date.
Updating OPNsense repository catalogue...
OPNsense repository is up-to-date.
All repositories are up-to-date.
Checking for upgrades (46 candidates): .......... done
Processing candidates (46 candidates): ........ done
Checking integrity... done (1 conflicting)
  - py27-setuptools-32.1.0_1 conflicts with py27-setuptools27-32.1.0 on /usr/local/bin/easy_install
Cannot solve problem using SAT solver, trying another plan
Checking integrity... done (0 conflicting)
The following 38 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
py27-sqlite3-2.7.13_7
opnsense-17.1.3
py27-setuptools27-32.1.0

New packages to be INSTALLED:
py27-setuptools: 32.1.0_1

Installed packages to be UPGRADED:
squid: 3.5.24 -> 3.5.24_2
png: 1.6.28 -> 1.6.29
pkgconf: 1.3.0_3 -> 1.3.0,1
php70-zlib: 7.0.16 -> 7.0.17
php70-xml: 7.0.16 -> 7.0.17
php70-sqlite3: 7.0.16 -> 7.0.17
php70-sockets: 7.0.16 -> 7.0.17
php70-simplexml: 7.0.16 -> 7.0.17
php70-session: 7.0.16 -> 7.0.17
php70-pdo: 7.0.16 -> 7.0.17
php70-openssl: 7.0.16 -> 7.0.17
php70-mcrypt: 7.0.16 -> 7.0.17
php70-ldap: 7.0.16 -> 7.0.17
php70-json: 7.0.16 -> 7.0.17
php70-hash: 7.0.16 -> 7.0.17
php70-gettext: 7.0.16 -> 7.0.17
php70-filter: 7.0.16 -> 7.0.17
php70-dom: 7.0.16 -> 7.0.17
php70-curl: 7.0.16 -> 7.0.17
php70-ctype: 7.0.16 -> 7.0.17
php70: 7.0.16 -> 7.0.17
opnsense-update: 17.1.3 -> 17.1.4
opnsense-lang: 17.1.3 -> 17.1.4
ntp: 4.2.8p9_4 -> 4.2.8p10_2
lzo2: 2.09 -> 2.10_1

Installed packages to be REINSTALLED:
py27-ujson-1.35 (direct dependency changed: py27-setuptools)
py27-requests-2.11.1 (direct dependency changed: py27-setuptools)
py27-pytz-2016.10,1 (direct dependency changed: py27-setuptools)
py27-netaddr-0.7.18 (direct dependency changed: py27-setuptools)
py27-MarkupSafe-1.0 (direct dependency changed: py27-setuptools)
py27-Jinja2-2.8 (direct dependency changed: py27-Babel)
py27-Babel-2.3.4 (direct dependency changed: py27-setuptools)
openvpn23-2.3.14_1 (options changed)
dnsmasq-2.76,1 (options changed)

Number of packages to be removed: 3
Number of packages to be installed: 1
Number of packages to be upgraded: 25
Number of packages to be reinstalled: 9

The operation will free 20 MiB.
pkg-static: Cannot delete vital package: opnsense!
pkg-static: If you are sure you want to remove opnsense,
pkg-static: unset the 'vital' flag with: pkg set -v 0 opnsense
Starting web GUI...done.
Generating RRD graphs...done.
***DONE***

is it safe to run pkg set -v 0 opnsense??
Title: Re: Can't upgrade from 17.1.3 to 17.1.4
Post by: franco on April 10, 2017, 05:26:17 pm
No, this will remove the GUI, leaving you stranded.

Instead run this command:

# pkg delete -f py27-setuptools27

After that the upgrade should work as normal.

The bug seems to surface in conjunction with manual ports / package build?


Cheers,
Franco
Title: Re: Can't upgrade from 17.1.3 to 17.1.4
Post by: s4rs on April 10, 2017, 05:56:49 pm
franco,
            Thanks for the tip, worked fine. I don't have any custom packages. Only thing I changed after going to 17.1.3 was to add a USB Ethernet adapter to create a Guest network..
Title: Re: Can't upgrade from 17.1.3 to 17.1.4 [SOLVED]
Post by: franco on April 11, 2017, 06:15:26 am
Hi s4rs,

Ok, glad that did the trick. :)

I still can't reproduce this. Right now all we know is that setuptools were renamed (rightfully so). We'll keep this under observation.


Thanks,
Franco