OPNsense Forum

Archive => 17.1 Legacy Series => Topic started by: ackahforson on February 28, 2017, 06:56:46 am

Title: Session Time-out (captive portal)
Post by: ackahforson on February 28, 2017, 06:56:46 am
Hi
My current OPNsense install is 17.1.2

Setup is as follows:
Internet =>OPNsense => (2 NICS 1. cable 192.168.3.1  2. wifi 192.168.4.1 + repeaters )

Issue:
Upon opening a page, client PC is presented with portal page (as expected),
upon login the client is successfully logged in and redirected to the page requested. BUT any other tab or page opened presents the portal page again or no response with the browser attempting to establish a connection!

On captive portal sessions, I observe the client successfully logged in with mac address "   h0_wlan1 expires in 113 sec" . sometimes 30 sec.

Any help pls?
Title: Re: Session Time-out (captive portal)
Post by: ackahforson on February 28, 2017, 08:21:21 pm
I reset the firewall to factory defaults and setup the network again. wifi network was setup using https://docs.opnsense.org/manual/captiveportal.html

the following was noted.
1. captive portal logins from LAN (cable) successfully logged in and stayed logged in.

2. captive portal logins from wifi (OPT1) successfully logged in but session ended in 30sec or less.  On captive portal sessions tab, instead of the mac address, this was shown: "   h0_wlan1 expires in 113 sec".

any pointers will be pretty much appreciated.
Title: Re: Session Time-out (captive portal)
Post by: AdSchellevis on February 28, 2017, 08:26:25 pm
It's an issue in parsing the mac addresses, we fixed this today.
More info can be found at the bottom of this issue https://github.com/opnsense/core/issues/1344

Code: [Select]
opnsense-patch 3151c87

Will probably fix this.