OPNsense Forum

Archive => 16.7 Legacy Series => Topic started by: Luna on January 05, 2017, 02:38:53 am

Title: Resolved: Access point in guest network won't work :(
Post by: Luna on January 05, 2017, 02:38:53 am
edit: fixed! I don't know what the problem was, but after a reboot of everything it works like I want :-). Thanks! Topic can be closed.


I followed this guide: https://docs.opnsense.org/manual/how-tos/guestnet.html (minus the captive portal and voucher stuff) and everything wired works like a charm, but not one access point will work on the network (I tried several). I hope someone here will know what I did wrong.

GUEST network:
Code: [Select]
IPv4 on its own NIC/physical interface (em2).
The four firewall rules from the guide:
Code: [Select]
Allow DNS on GUEST
Block Local Networks
Block Firewall Access
Allow Guest Network.

DHCP server:
Code: [Select] (subnet) (mask) - (range) (DNS server) (gateway)

When I put a UTP cable from em2 directly in a device, it will get a functioning network/internet connection with an IP address from the given range. But access points won't work for some reason. I tried running access points on DHCP mode and static mode with an IP address in the given range. There are no switches involved, the cable runs directly from the router's GUEST interface to the access point.

Does anyone have any idea what I did wrong or how I can troubleshoot this? If more information is needed, I'll provide it :-).

Many thanks in advance! By the way, I am still learning networking so it might be something supersimple, sorry in that case.
Title: Re: Resolved: Access point in guest network won't work :(
Post by: fabian on January 05, 2017, 01:11:00 pm
The only way to troubleshoot this is doing a packet capture. You have to find out if a client can send a DHCP message to the firewall.