OPNsense Forum

Archive => 16.7 Legacy Series => Topic started by: reep on September 13, 2016, 06:22:45 pm

Title: arpresolve issues with bridged modem
Post by: reep on September 13, 2016, 06:22:45 pm
Been trying to figure this out the last few days and just can't get it right.

I have both a Draytek 2820 modem/route and a Vigor 120 modem for testing (I have been using 2 x 2820s but was going to move to using the 120s)

I am trying to bridge a MPoA connection but whichever way I twist and turn I come up against a brick wall.

The opensense router has a "HP NC380T PCIe DP Multifunc Gig Server Adapter" dual NIC for the two WAN ports

I have the router in Multiwan mode. WAN 2 is disconnected for testing. WAN3 has a DHCP backup wifi ether connection and is in a gateway group that seems to be handling failover OK :-)

The logs show this for WAN1 :

arpresolve: can't allocate llinfo for on bce0

There are numerous posts on this, but few answers... drivers, other issues...

This is similar https://forum.pfsense.org/index.php?topic=31753.0

Tried force adding a default GW

root@OPNsense:~ # route add default
route: writing to routing socket: Network is unreachable
add net default: gateway fib 0: Network is unreachable

I have read various items on issues with bridging on the Drayteks e.g.:

I have tried ip arp accept 1 and 3  to enable acceptance of incorrectly addressed ARP packets but this does not seem to work

Quite simply I am stuck. Opnense works fine if it uses standard DHCP from the ADSL router but then the WAN interfaces get a Private IP and not the proper WAN IP (which makes mess for ipsec)

Any suggestion s on trying to pin this issue down and try to sure it ?

I'd try another ADSL modem if I knew there was one that would work. Unfortunately I can't use Opnsense in production until I can sort this out :-(

B. Rgds
Title: Re: arpresolve issues with bridged modem
Post by: reep on September 15, 2016, 09:05:51 pm
Been slowly digging away on this and revealing my woeful lack of knowledge of all things OSI :-)

I am pretty sure this is to do with ARP responses (or lack of) and MAC addressing.

I have a feeling that either:

The Draytek 120 is giving its own MAC address somehow rather than the Opnsense ethenet port MAC

The Draytek 120 is blocking ARP requests or responses (despite me having a go at allowing illegal source/destination addresses

Something in sysctl settings is buggering things up

I'm going to try and add the Opnsense MAC on the 120 and test that. My biggest problem is lack of knowledge on how to debug this :-(

Any help appreciated. It's really frustrating as this blocks me from switching off my venerable but ageing Draytek 3300 and moving fully to Opnsense.

B. Rgds
Title: Re: arpresolve issues with bridged modem
Post by: reep on September 20, 2016, 05:15:41 pm
Well, I tried every trick in the book that I know.... used the Vigor 120, tried the main 2820 in their 'half bridge mode' setting the DMZ IP by MAC (which is what works now with the Draytek 3300) But whatever I can get one connection up, but not the other....

The MPoA in the half bridge mode works but the PPPoE refuses to work correctly. I could put it in complete passthrough mode and let Opnsense try doing the PPPoE negotiation but I want both routers working the same way, either full bridge of half bridge.

So I am at a complete impasse and going to have to look for another solution. A shame as I noticed several more bugs and 'gotchas' on numerous issues (with both GUI and Firewall rules, particularly some of the multiwan stuff) but to pursue this I need to do it with a working system and can't afford anymore time on this right now.

I am pretty sure that the issue lies with FreeBSD/Apinger/low level networking but I don't have the knowledge to debug it. When something tells me that it can't connect as 'a port is using Jumbo frames' when I have pinned the MTU to say 1492 and can see that with ifconfig I know there is something fundamentally not right somewhere !

I'm pretty gutted as I think Opnsense is excellent, but if I can't get a basic connection working easily and as I require it, it is no use at all !

Note I was testing Endian and that that connected immediately....

Onwards and upwards.

B. Rgds