OPNsense Forum

Archive => 20.7 Legacy Series => Topic started by: ivwang on August 03, 2020, 03:53:39 pm

Title: PPPoE ipv6 weirdness at boot?
Post by: ivwang on August 03, 2020, 03:53:39 pm
Hi all,

Have been seeing this after upgraded to 20.7, it happens to my wan ipv6 99.9% of time after reboot

Symptom: WAN does not get ipv6 address, LAN (tracking ipv6 of WAN) seems to get a ipv6 address from ISP’s delegated prefix (which I know by looking at GUI interface overview page), however LAN does not publish the prefix in router advertisement (which I know from Wireshark capturing on a host connected to lan)

Weird thing is it almost look like there being some timing issue or race condition at boot to amplify the underlying problem, on the other hand it has higher chance to work if I disconnect WAN side PPPoE, wait couple of seconds then redial when the system is in a rather inactive state. Meaning WAN gets ipv6 assigned from ISP, LAN gets prefix and advertising as expected.

Currently I worked around by just requesting prefix, this gives me more reliable ipv6 after boot without manual intervention.

Btw, for anyone interested my ISP gives out an address via DHCPv6 (Which is via ipv4 PPPoE) and a /64 prefix (different from the DHCPv6 address is under) it had worked until 20.7.

Anyone seeing the same?

Thanks and cheers,
Title: Re: PPPoE ipv6 weirdness at boot?
Post by: skywalker007 on November 24, 2020, 12:18:06 pm
Do you still have this issue?
I experience something similar. When my VDSL connection lose sync and resyncs, then pppoE comes up with IPv4 only. I manually need to reload pppoE to get IPv6 back up.
Title: Re: PPPoE ipv6 weirdness at boot?
Post by: ivwang on November 25, 2020, 12:47:13 pm
Hi there,

I stopped testing this since around 20.7.3, but given there wasn't kernel changes seemingly related to PPPoE nor update to mpd package I would assume the status hasn't changed.

My workaround is to request only prefix. This somehow avoids triggering the issue. And my WAN interface (pppoe0) still gets a global ipv6 (Note this is not in the delegated /64, but an address from ISP's pool) assigned from my ISP.

At this moment I am really tempted give ransom to my ISP and "upgrade" my plan to static ipv6  :-\