OPNsense Forum

English Forums => 19.7 Legacy Series => Topic started by: niclasc on July 26, 2019, 11:57:58 am

Title: [SOLVED] Gateway monitor missing after update
Post by: niclasc on July 26, 2019, 11:57:58 am
I updated to 19.7.1 today an now one of my gateway monitor is missing av does not start
I monitored Cloudflares DNS to check online connectivity

dpinger   Gateway Monitor (Cloudflare)   
Title: Re: Gateway monitor missing after update
Post by: nivek1612 on July 26, 2019, 02:22:02 pm
I've also seen issue where I add a gateway that does not appear in the gateways list but Dpinger is trying to monitor it and there is no way to remove the gateway now.

https://forum.opnsense.org/index.php?topic=13602.0 (https://forum.opnsense.org/index.php?topic=13602.0)
 
Title: Re: Gateway monitor missing after update
Post by: niclasc on August 06, 2019, 09:03:15 pm
Any ideas on this problem?
Title: Re: Gateway monitor missing after update
Post by: AdSchellevis on August 06, 2019, 09:07:03 pm
should be fixed in a future release, https://github.com/opnsense/core/issues/3625 contains the steps to test earlier (on 19.7.2).
Title: Re: Gateway monitor missing after update
Post by: niclasc on August 06, 2019, 09:30:43 pm
@AdSchellevis tried that and now the Gateway is shown in the list but it does not work like before. It still won't start to monitor the IP like it did before

How do I set monitoring of something other than my gateway?
Title: Re: Gateway monitor missing after update
Post by: sashxp on August 06, 2019, 11:14:10 pm
I've also seen issue where I add a gateway that does not appear in the gateways list but Dpinger is trying to monitor it and there is no way to remove the gateway now.

https://forum.opnsense.org/index.php?topic=13602.0 (https://forum.opnsense.org/index.php?topic=13602.0)

I think i'm having the same Problem with 19.7.2 pls look at my thread @ https://forum.opnsense.org/index.php?topic=13713

should be fixed in a future release, https://github.com/opnsense/core/issues/3625 contains the steps to test earlier (on 19.7.2).

at the moment there are some Bugs inthe Gateway List. You can't create an Gateway or it will not listet in the gateway section. And at least there are some Ghost DPingers.

In Front of Table - the Checkbox is also not visible.
Title: Re: Gateway monitor missing after update
Post by: banym on August 07, 2019, 07:58:02 am
Hello,

this not only needs to be fixed in a 19.7.2, if you update an old firewall like I did, this leads to an offline connection.

I had a HA-Setup where both firewalls where updated and while updating to 19.7 both firewall run into this problem.
Since I had the other firewall working I could fix it manually by logging in via SSH to the backup firewall and reconfiguring the gateway service. If I only had one firewall I would have been screwed.

It should not be possible to update an old firewall ot the version including this bug since it leads to a offline firewall.

Regards,

Dominik
Title: Re: Gateway monitor missing after update
Post by: banym on August 07, 2019, 10:01:22 am
One more information I figured out updating another firewall.

It happened there, too in a single node configuration. I was prepared and fixed it by opening the gateway entry and just clicked save.

Before that I did set the default gw manually via SSH and did an update to 19.7.2 to see if there is a fix for the broken gateway configuration. It didn't work. I had to open the entry, click save and since then everything worked fine.

FYI

Regards,

Dominik
Title: Re: Gateway monitor missing after update
Post by: AdSchellevis on August 07, 2019, 10:08:29 am
We've added documentation about the subject recently https://docs.opnsense.org/manual/gateways.html. About the upgrade path from 19.1.x to 19.7.x, we might point it to 19.7.2 after some time.

There are some ipv6 setups, which don't seem to receive a gateway in the normal way and since we rewrote the complete gateway handling, some of the unexpected / unpredictable defaults might be different now.

The new priorities option helps to change decisions, which is explained in the docs now as well.

Best regards,

Ad
Title: Re: Gateway monitor missing after update
Post by: banym on August 07, 2019, 11:20:33 am
Hi Ad,

since on that machines only one gateway was defined it is a quite serious problem if it leads to an offline firewall.

The Systems the problem appeared for me did not make any use of IPv6 on the WAN interface.
Only one IPv4 Gateway was defined.
Since no changes to the configured Gateway needed to be done only the save button was pressed, maybe there is a way to implement a hotfix to do so for 19.7.

I am not sure but for firewalls comming from older releases only 19.7 is shown to them as new version? I can't go to a newer version directly including a possible fix? This would make it necessary to fix it in 19.7 or maybe many will face the same problem and would have to go onside only to press save once?

Regards,
Dominik
Title: Re: Gateway monitor missing after update
Post by: AdSchellevis on August 07, 2019, 11:27:48 am
Hi Dominik,

When Franco is back, I'll ask him to point the upgrade path to 19.7.2, which smoothens the ride.
In 99% of the cases you can easily work around these kind of issues depending on setup type by the way.

Best regards,

Ad
Title: Re: Gateway monitor missing after update
Post by: franco on August 21, 2019, 05:33:17 pm
We should make the upgrade path 19.7.3 when it is released. I see FreeBSD has released new security advisories so the latest kernel would be better...


Cheers,
Franco
Title: Re: Gateway monitor missing after update
Post by: niclasc on September 08, 2019, 04:04:51 pm
We should make the upgrade path 19.7.3 when it is released. I see FreeBSD has released new security advisories so the latest kernel would be better...


Cheers,
Franco

I have made the upgrade to 19.7.3 now and still have the same problem
If I go to Reporting -> Health and look under Quality I can see "Cloudflare" which is one of my old gateway I used to monitor. This gateway I cannot see under System -> Gateways
So I wonder if it got deleted in the gui but not in the system somehow.

Any idea where I can find Gateways in the console?
Title: Re: Gateway monitor missing after update
Post by: netranger on September 13, 2019, 06:28:27 pm
Hi there,

has the upgrade path already been changed or is there another way to directly go to the latest release?

Cheers,
NR
Title: Re: Gateway monitor missing after update
Post by: franco on September 16, 2019, 04:16:24 pm
Not yet, I hope to be able to do it this week.


Cheers,
Franco
Title: Re: Gateway monitor missing after update
Post by: packet loss on September 16, 2019, 09:20:38 pm
I'm not sure if there's an issue on how gateways are being saved and deleted in config.xml. I recently noticed an issue where I deleted 2 gateways and noticed they were still present in my config.xml after I saved my configuration file and looked at it with notepad++.

Those who might be having problems you might want to export your OPNsense configuration file, open it up and look at the gateway section to see if there are any duplicate or residual gateways in your configuration file that should no longer be there.

Not sure if this might be causing issues. It's worth looking at.
Title: Re: Gateway monitor missing after update
Post by: franco on September 17, 2019, 10:20:25 pm
PS: All done. 19.1.10_1 will go directly to 19.7.4_1 even though it advertises the 19.7 announcement (can't change that).
Title: Re: Gateway monitor missing after update
Post by: netranger on September 21, 2019, 02:17:29 pm
Thank you for the info and the awesome work! Upgrade went well :D

Cheers,
NR