OPNsense Forum

Archive => 15.7 Legacy Series => Topic started by: pusanggala on August 13, 2015, 06:06:48 pm

Title: Proxy logs - ERR: (65) No route to host
Post by: pusanggala on August 13, 2015, 06:06:48 pm
Hi there,

After I enabled transparent proxy, I got this lots of log entries on my Proxy server:

2015/08/13 23:18:33| Error sending to ICMPv6 packet to [2404:.........:c01::8b]. ERR: (65) No route to host
2015/08/13 23:19:04| Error sending to ICMPv6 packet to [2400:.........:1::681b:901f]. ERR: (65) No route to host
2015/08/13 23:21:22| Error sending to ICMPv6 packet to [2404:.........:809::2002]. ERR: (65) No route to host
2015/08/13 23:22:47| Error sending to ICMPv6 packet to [2404:.........:808::2002]. ERR: (65) No route to host
2015/08/13 23:22:52| Error sending to ICMPv6 packet to [2404:.........:c04::61]. ERR: (65) No route to host
2015/08/13 23:23:19| Error sending to ICMPv6 packet to [2606:.........:1047:6cf:353:607:e8a]. ERR: (65) No route to host
2015/08/13 23:23:33| Error sending to ICMPv6 packet to [2404:.........:c07::65]. ERR: (65) No route to host
2015/08/13 23:23:34| Error sending to ICMPv6 packet to [2404:.........:c02::69]. ERR: (65) No route to host
2015/08/13 23:24:04| Error sending to ICMPv6 packet to [2400:.........:1::681b:901f]. ERR: (65) No route to host
2015/08/13 23:26:36| Error sending to ICMPv6 packet to [2404:.........:80b::2002]. ERR: (65) No route to host
..................
.............
.....


Either "Allow IPv6" option is checked or unchecked on my opnsense networking settings, still this logs appears. I also don't have firewall rules that blocks that kind of packet.

The proxy log is currently being flooded by that notice. If you have any idea guys how to turn this off or fix this, or it's just safe to ignore that notice, please let me know.

Thanks!


Title: Re: Proxy logs - ERR: (65) No route to host
Post by: makiber on November 04, 2015, 10:45:32 pm
Hi I have the same problem. Could you fix it?

thx
Title: Re: Proxy logs - ERR: (65) No route to host
Post by: franco on November 06, 2015, 01:30:14 pm
It looks like this might help, but it is an inherent problem of squid trying to connect via IPv6...

http://dev-tricks.net/squid-101-network-is-unreachable-when-dns-returns-ipv6

Or one could try to suppress the IPv6 responses by doing:

System: Settings: Networking: [ x ] Prefer to use IPv4 even if IPv6 is available
Title: Re: Proxy logs - ERR: (65) No route to host
Post by: jeffg on March 10, 2017, 11:36:49 pm
Turning on "Prefer to use IPv4 even if IPv6 is available" did not seem to get rid of the messages.  I don't have IPv6 defined on the interfaces.
Title: Re: Proxy logs - ERR: (65) No route to host
Post by: jeffg on March 11, 2017, 12:01:18 am
I just enabled this, which might fix it.

Web Proxy, Administration,
Reference: http://www.squid-cache.org/Doc/config/dns_v4_first/