OPNsense Forum

English Forums => 19.1 Legacy Series => Topic started by: poupin on February 06, 2019, 09:00:56 pm

Title: Problem with WLE200NX after upgrade to 19.1
Post by: poupin on February 06, 2019, 09:00:56 pm
Hi,

I've upgraded to 19.1 from 18.7. After the upgrade everything seems fairly normal except the WiFi was down. I've tried to set it up, but without success. So I've deleted the interface and wireless device, then restarted the router. After this I'm not able to add the wireless device (dmesg output attached). Is the WLE200NX supported by the new kernel used for 19.1? Is there necessary to pass some parameter to the new kernel?
Previous versions of OPNsense (18.7, 18.1, ...) works on the HW fine (APU1D + WLE200NX + mSATA SSD).

Thank you for your support.

Cheers Martin
Title: Re: Problem with WLE200NX after upgrade to 19.1
Post by: newsense on February 09, 2019, 06:51:52 am
There's not much info that can be gleaned from that dmesg. There's only a wlan entry and the following error doesn't appear to be related:

Quote
random: entropy device external interface
wlan: mac acl policy registered
netmap: loaded module
module_register_init: MOD_LOAD (vesa, 0xffffffff8113fe30, 0) error 19


How current is your coreboot version ? Might be a long shot but worth checking at the very least.

A screenshot from the dmidecode widget would clarify that - you can install it from the plugin section.
Title: Re: Problem with WLE200NX after upgrade to 19.1
Post by: poupin on March 17, 2019, 08:42:32 pm
Finally it helps to move the mPCIe card to other slot. Don't understand why, but helps.