OPNsense Forum

English Forums => 18.7 Legacy Series => Topic started by: dsb_dkr on December 17, 2018, 08:49:56 am

Title: Editing aliases doesnt sync to Cluster member
Post by: dsb_dkr on December 17, 2018, 08:49:56 am
Hi,
if we only edit an alias, press apply, the config change didnt get synced to the cluster member.
Changing a firewall rule, will sync everything, including the changed alias to the cluster member.
Running 18.7.9 (behavior already exists on 18.7.8)

Gruesse
Daniel
Title: Re: Editing aliases doesnt sync to Cluster member
Post by: mimugmail on December 17, 2018, 09:02:46 am
Yep, that's true. There is now a sync button in System : HA : Status.
It's too complex to build a sync trigger for every change and would slow it down.
Title: Re: Editing aliases doesnt sync to Cluster member
Post by: dsb_dkr on December 17, 2018, 10:00:24 am
I know this button,
but it has worked earlier without it.
The behavior changed.
I want the old behavior back.

Why?
Because imaging you are runinng a cluster, all the day you do apply on rules and just everything get synced, but not for alias changes. one day you will have a outage on the maincluster and not all changes are synced to the standby, then you loose.
I believe this is something which is not acceptable for a cluster.

And one important thing to mention is:

Go to Systems > HA Settings
Scroll down to Checkbox (x) Aliases, expand the (i) (tool tip?) and read:
"Automatically sync the aliases over to the other HA host when changes are made. "


Thanks
Daniel
Title: Re: Editing aliases doesnt sync to Cluster member
Post by: dsb_dkr on December 20, 2018, 04:15:02 pm
re-up,
i think it is important and it is a bug.
Title: Re: Editing aliases doesnt sync to Cluster member
Post by: mimugmail on December 20, 2018, 04:17:38 pm
It's not a bug, the description is bow updated that it needs to be synced manually