OPNsense Forum

Archive => 18.7 Legacy Series => Topic started by: micmon on November 13, 2018, 07:09:40 pm

Title: No DynDNS and IPv6 errors in log after WAN reload
Post by: micmon on November 13, 2018, 07:09:40 pm
I run OPNsense 18.7.7 behind a bridged modem and use its DynDNS plugin to keep my WWW domain up to date. This used to work fine until today, where I found that my domain was not accessible. On OPNsense dashboard I found the DynDNS to be displayed in red, so for some reason OPNsense did not managed to update it after getting a new IP on the WAN interface. Running "/usr/local/etc/rc.dyndns" from the console fixed it. I also noticed that the LAN interface did not have an IPv6 address (it is set to track WAN). Pressing "save" and "apply" on the WAN interface fixed that, but it again ended up not having up to date DynDNS.

In the logs I found "Could not resolve host: dyndns.strato.com" as well as "Invalid IPv6 address" (see attached log).

I never got to reproduce the missing IPv6 after a manual WAN reload. The errors still occur on every reload but the LAN ends up having IPv6 and DHCPv6 seems to work just fine. The DynDNS seems to work sometimes, sometimes not.

Looks like timing issues to me. Anyone else seeing anything like this?