OPNsense Forum

Archive => 19.1 Legacy Series => Topic started by: ruggerio on November 07, 2018, 09:50:07 am

Title: [SOLVED] Suricata stopps after a few minutes
Post by: ruggerio on November 07, 2018, 09:50:07 am
Hi,

If i reboot the firewall, i have to start suricata manually (already had this in production). Now, in dev, i start suricata, but it stops after a few minutes.

Anybody else having this?
Title: Re: Suricata stopps after a few minutes
Post by: hutiucip on November 07, 2018, 10:16:43 am
Hi!
Yes, me, and for me the culprit was ”abuse.ch/URLhaus” ruleset. Stop using it, if you do, and should be fine.
Cheers!
Title: Re: Suricata stopps after a few minutes
Post by: ruggerio on November 07, 2018, 11:51:45 am
again? This issue has already been in Production, but has been fixed...

Title: Re: Suricata stopps after a few minutes
Post by: franco on November 07, 2018, 12:16:38 pm
I don't think that has anything to do with 19.1. Reporting crashing services is appreciated, but if the original software authors are not contacted directly the issue fix may be delayed indefinitely. The software authors have deeper insights into what is going on and how we actually faultily configure their service and then we can do something about it.


Cheers,
Franco
Title: Re: Suricata stopps after a few minutes
Post by: ruggerio on November 07, 2018, 12:53:30 pm
for sure, but:

after reboot in 18.7, it did not start automatically. Launching Suricata manually was the solution and Suricata kept up running.

Different in 19.1, where it crashes after a restart of the service.
Title: Re: Suricata stopps after a few minutes [solved]
Post by: ruggerio on November 07, 2018, 02:22:41 pm
disabled urlhaus, survives now reboots.